Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Июн 2021, 17:05
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Перечисления и структура выбора "Если"  (Прочитано 2384 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Самовар

  • *
  • Регистрация: 2016-08-20
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Профессия: Ученик 1С
Добрый день. Начал изучать 1С. Возникла проблема:
Есть форма документа, на ней два поля ввода.  Первое поле имеет обычный тип "Строка", второе имеет тип перечислениеСсылка (Должность) т.е. выбор идет из выпадающего списка.       
Необходимо при выборе определенного значения во втором поле заполнять определенные реквизиты. 
Делаю так:

&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)

если Объект.Должность = "Менеджер"

Тогда  Объект.Отдел = "Отдел продаж";

КонецЕсли;

КонецПроцедуры

Но ничего не происходит. Но если "Объект.Должность" заменить на обычный строковый тип и написать в строке "Менеджер". Все работает. Подскажите, как правильно работать с перечислениями и структурой выбора "если"

Спасибо.
                     


Оффлайн Zeed

  • **
  • Регистрация: 2016-04-27
  • Сообщений: 59
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Профессия: Ученик 1С
Добрый день. Начал изучать 1С. Возникла проблема:...                 

На клиенте нужно воспользоваться ПредопределенноеЗначение("Перечисление.Должности.Менеджер") , на сервере можно так Объект.Должность = Перечисления.Должности.Менеджер
 
&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
    Если Объект.Должность = ПредопределенноеЗначение("Перечисление.Должности.Менеджер") Тогда
  Объект.Отдел = "Отдел продаж";
    КонецЕсли;

КонецПроцедуры
   

Оффлайн SGIRG

  • ***
  • Регистрация: 2014-03-26
  • Сообщений: 114
  • РЕПУТАЦИЯ: 33
  • КПД: 29%
Если обрабатываем информацию связанную с конкретным сотрудником, то не поленитесь найти регистр сведений, в котором будет информация не только о должности сотрудника, но и подразделении. Тогда не придется писать извращенские условия типа Если Тогда
PS: возможно данный регистр у Вас называется КадроваяИсторияСотрудников
Нажимайте "Спасибо", так приятнее))


Теги:
 

При запуске выдает "Не верный формат хранилища данный

Автор Павел Р.Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 741
Последний ответ 05 Янв 2018, 13:51
от Геннадий ОбьГЭС
Большая самостоятельная работа "Резервирование товаров и планирование активных п

Автор totenkopf2012Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 5120
Последний ответ 09 Мар 2019, 16:21
от Геннадий ОбьГЭС
Замена элемента "оплата по окладу (по часам)

Автор Мария112689Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 706
Последний ответ 24 Мая 2019, 12:28
от Геннадий ОбьГЭС
ФОРМА №1-т (проф) «Сведения о численности и потребности..." в ЗУП 3.0

Автор s26021968Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 6469
Последний ответ 28 Ноя 2014, 09:18
от cska-fanat-kz
ведомость в банк" не заполняется НДФЛ

Автор Анфиса333Раздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 2956
Последний ответ 11 Фев 2016, 09:33
от Анфиса333

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

LexaK
68 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
68 Сообщений
antoneus antoneus
33 Сообщений
Ивашка
27 Сообщений
neek666
26 Сообщений
KATERINA 861
19 Сообщений
Алексей_1985_06
15 Сообщений
SSC
15 Сообщений
alexandr_ll
14 Сообщений
pouyo
8 Сообщений

* Кто онлайн

  • Точка Гостей: 574
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск