Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Фев 2018, 22:38
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Перечисления и структура выбора "Если"  (Прочитано 939 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Самовар

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-20
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день. Начал изучать 1С. Возникла проблема:
Есть форма документа, на ней два поля ввода.  Первое поле имеет обычный тип "Строка", второе имеет тип перечислениеСсылка (Должность) т.е. выбор идет из выпадающего списка.       
Необходимо при выборе определенного значения во втором поле заполнять определенные реквизиты. 
Делаю так:

&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)

если Объект.Должность = "Менеджер"

Тогда  Объект.Отдел = "Отдел продаж";

КонецЕсли;

КонецПроцедуры

Но ничего не происходит. Но если "Объект.Должность" заменить на обычный строковый тип и написать в строке "Менеджер". Все работает. Подскажите, как правильно работать с перечислениями и структурой выбора "если"

Спасибо.
                     


Оффлайн Zeed

  • **
  • Сообщений: 59
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2016-04-27
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день. Начал изучать 1С. Возникла проблема:...                 

На клиенте нужно воспользоваться ПредопределенноеЗначение("Перечисление.Должности.Менеджер") , на сервере можно так Объект.Должность = Перечисления.Должности.Менеджер
 
&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
    Если Объект.Должность = ПредопределенноеЗначение("Перечисление.Должности.Менеджер") Тогда
  Объект.Отдел = "Отдел продаж";
    КонецЕсли;

КонецПроцедуры
   

Оффлайн SGIRG

  • **
  • Сообщений: 93
  • РЕПУТАЦИЯ: 30
  • КПД: 32%
  • Регистрация: 2014-03-26
  • Сайт: 
  • Профессия: Программист 8.1
Если обрабатываем информацию связанную с конкретным сотрудником, то не поленитесь найти регистр сведений, в котором будет информация не только о должности сотрудника, но и подразделении. Тогда не придется писать извращенские условия типа Если Тогда
PS: возможно данный регистр у Вас называется КадроваяИсторияСотрудников
Нажимайте "Спасибо", так приятнее))


Теги:
 

Вывод информации: если поле не заполнено, то вывод иной информации. Новичок

Автор kiksiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 436
Последний ответ 10 Окт 2017, 12:33
от kiksi
Как из справочника вытащить список одной группы справочника и вставить его в поле документа для выбора одного элемента из полученного списка?

Автор ilnur75Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 1790
Последний ответ 21 Сен 2016, 08:16
от GadLex
Режим диалога выбора файлов - выбрать из нескольких типов файлов.

Автор Yuliya_DenРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 4753
Последний ответ 19 Апр 2016, 15:28
от Yuliya_Den
Как рассчитать продолжительность отпуска, если сотрудник переведен на новую должность с измененной продолжительностью положенного отпуска

Автор topicsРаздел Статьи

Ответов: 0
Просмотров: 2577
Последний ответ 04 Авг 2014, 13:26
от topics
Движимое имущество налогом на имущество не облагается, если оно выполнено из комплектующих изделий, купленных у взаимозависимого лица

Автор newsРаздел Новости

Ответов: 0
Просмотров: 1532
Последний ответ 18 Июн 2015, 15:07
от news

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
231 Сообщений
AIFrame AIFrame
65 Сообщений
alexandr_ll
41 Сообщений
MuI_I_Ika MuI_I_Ika
39 Сообщений
BuhRust
30 Сообщений
wise wise
27 Сообщений
andron81_81
25 Сообщений
kiksi
23 Сообщений
pavl_vs
23 Сообщений
ildar32 ildar32
22 Сообщений

* Кто онлайн

  • Точка Гостей: 388
  • Точка Скрытых: 0
  • Точка Пользователей: 15
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal