Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
16 окт 2021, 05:40

Перечисления и структура выбора "Если"

Автор Самовар, 20 авг 2016, 17:04

0 Пользователей и 1 гость просматривают эту тему.

Самовар

Добрый день. Начал изучать 1С. Возникла проблема:
Есть форма документа, на ней два поля ввода.  Первое поле имеет обычный тип "Строка", второе имеет тип перечислениеСсылка (Должность) т.е. выбор идет из выпадающего списка.       
Необходимо при выборе определенного значения во втором поле заполнять определенные реквизиты. 
Делаю так:


&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)

если Объект.Должность = "Менеджер"

Тогда  Объект.Отдел = "Отдел продаж";

КонецЕсли;

КонецПроцедуры


Но ничего не происходит. Но если "Объект.Должность" заменить на обычный строковый тип и написать в строке "Менеджер". Все работает. Подскажите, как правильно работать с перечислениями и структурой выбора "если"

Спасибо.
                     

Zeed

Цитата: Самовар от 20 авг 2016, 17:04
Добрый день. Начал изучать 1С. Возникла проблема:...                 

На клиенте нужно воспользоваться ПредопределенноеЗначение("Перечисление.Должности.Менеджер") , на сервере можно так Объект.Должность = Перечисления.Должности.Менеджер


&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
    Если Объект.Должность = ПредопределенноеЗначение("Перечисление.Должности.Менеджер") Тогда
  Объект.Отдел = "Отдел продаж";
    КонецЕсли;

КонецПроцедуры

   

SGIRG

Если обрабатываем информацию связанную с конкретным сотрудником, то не поленитесь найти регистр сведений, в котором будет информация не только о должности сотрудника, но и подразделении. Тогда не придется писать извращенские условия типа Если Тогда
PS: возможно данный регистр у Вас называется КадроваяИсторияСотрудников
Нажимайте "Спасибо", так приятнее))

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск