Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
29 Май 2017, 04:53
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполнение в табличную часть документа из справочника по определенному реквизиту  (Прочитано 648 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн witch_n

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-18
  • Сайт: 
  • Профессия: Программист 1С
В табличную часть документ Заполнениеданныхсрц, подбираю по реквизиту ЛицевойсчетСРЦ из справочника КарточкаАбонента Абонентов. В табличную чать Абоненты не выходят, но когда вызываю метоб Сообщить(стр.Абонент); они отображаются. Помогите разобраться пожалуйста!




Запрос=Новый Запрос;
Запрос.Текст="ВЫБРАТЬ
|   ЗаполнениеДанныхСРЦСРЦ.ЛицевойсчетСРЦ,
|   ЗаполнениеДанныхСРЦСРЦ.Лицсчет,
|   ЗаполнениеДанныхСРЦСРЦ.Абонент,
|   ЗаполнениеДанныхСРЦСРЦ.Сумма,
|   ЗаполнениеДанныхСРЦ.Ссылка
|ПОМЕСТИТЬ ВТ_Док
|ИЗ
|   Документ.ЗаполнениеДанныхСРЦ.СРЦ КАК ЗаполнениеДанныхСРЦСРЦ
|   ЛЕВОЕ СОЕДИНЕНИЕ Документ.ЗаполнениеДанныхСРЦ КАК ЗаполнениеДанныхСРЦ
|   ПО ЗаполнениеДанныхСРЦСРЦ.Ссылка = ЗаполнениеДанныхСРЦ.Ссылка
|;
|
|////////////////////////////////////////////////////////////­////////////////////
|ВЫБРАТЬ
|   КарточкаАбонента.ЛицСчет,
|   КарточкаАбонента.Ссылка
|ПОМЕСТИТЬ ВТ_Справочн
|ИЗ
|   Справочник.КарточкаАбонента КАК КарточкаАбонента
|;
|
|////////////////////////////////////////////////////////////­////////////////////
|ВЫБРАТЬ
|   ВТ_Справочн.ЛицСчет,
|   ВТ_Док.ЛицевойсчетСРЦ,
|   ВТ_Док.Лицсчет КАК Лицсчет1,
|   ВТ_Док.Абонент,
|   ВТ_Справочн.Ссылка,
|   ВТ_Док.Сумма
|ИЗ
|   ВТ_Док КАК ВТ_Док,
|   ВТ_Справочн КАК ВТ_Справочн
|ГДЕ
|   ВТ_Док.ЛицевойсчетСРЦ = ВТ_Справочн.ЛицСчет
|   И ВТ_Док.Ссылка = &Ссылка
|
|СГРУППИРОВАТЬ ПО
|   ВТ_Справочн.ЛицСчет,
|   ВТ_Док.ЛицевойсчетСРЦ,
|   ВТ_Док.Лицсчет,
|   ВТ_Док.Абонент,
|   ВТ_Справочн.Ссылка,
|   ВТ_Док.Сумма";
Запрос.УстановитьПараметр("ССылка",ЭтотОбъект.Ссылка);


Выборка=Запрос.Выполнить().Выгрузить();
Для Каждого Стр Из Выборка Цикл
Выборка1=Справочники.КарточкаАбонента.НайтиПоРеквизиту("ЛицСчет",Стр.ЛицСчет,,);
Выборка2=Выборка1.ПолучитьОбъект();
стр.Абонент=Выборка2.ссылка;

Сообщить(стр.Абонент);
КонецЦикла;


Оффлайн SGIRG

  • **
  • Сообщений: 83
  • РЕПУТАЦИЯ: 26
  • КПД: 31%
  • Регистрация: 2014-03-26
  • Сайт: 
  • Профессия: Программист 8.1
Для чего все это?
Для Каждого Стр Из Выборка Цикл 
Выборка1=Справочники.КарточкаАбонента.НайтиПоРеквизиту("ЛицСчет",Стр.ЛицСчет,,);
Выборка2=Выборка1.ПолучитьОбъект();
стр.Абонент=Выборка2.ссылка;

Сообщить(стр.Абонент);
КонецЦикла;

У Вас же в запросе уже есть ссылка на карточку абонента:
|   ВТ_Справочн.Ссылка, 
Нажимайте "Спасибо", так приятнее))

Оффлайн witch_n

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-18
  • Сайт: 
  • Профессия: Программист 1С

Оффлайн SGIRG

  • **
  • Сообщений: 83
  • РЕПУТАЦИЯ: 26
  • КПД: 31%
  • Регистрация: 2014-03-26
  • Сайт: 
  • Профессия: Программист 8.1
У Вас и Запрос то весь написан как-то необдуманно и криво.
Опишите, что конкретно и куда должно заполняться и на основе чего
Нажимайте "Спасибо", так приятнее))

Оффлайн witch_n

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-18
  • Сайт: 
  • Профессия: Программист 1С
В документе у меня есть поле лицевыесчетаСРЦ, я обращаюсь к справочнику карточкаАбонента в нем есть поле Лицсчет и сравнивая эти два поля вывожу в табличную часть документа справочник Карточка Абонента

Оффлайн SGIRG

  • **
  • Сообщений: 83
  • РЕПУТАЦИЯ: 26
  • КПД: 31%
  • Регистрация: 2014-03-26
  • Сайт: 
  • Профессия: Программист 8.1
В документе у меня есть поле лицевыесчетаСРЦ
Это строковое поле?
1. А почему бы не ссылка на справочник КарточкаАбонента???? Судя по всему в карточке, поле Личевой счет уникально, а это значит, что можно в свойствах справочника поставить ввод по строке по полю Лицевой счет. И тогда при наборе счета в документе будет подтягиваться ссылка на карточку абонента.
2. В событиях при изменении поля лицевыесчетаСРЦ сделать заполнение ТЧ из уже заполненной способом выше ссылки.

Либо в первом способе оставляете строку, а в событиях "ПриИзменеии" Ищете ссылку на элемент справочника и так же на основе неё заполняете ТЧ.

не нужно делать запросы к самому документу.
Нажимайте "Спасибо", так приятнее))

Оффлайн witch_n

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-18
  • Сайт: 
  • Профессия: Программист 1С
Это число, Покажите на коде пожалуйста, так мне сложновато очень

Оффлайн SGIRG

  • **
  • Сообщений: 83
  • РЕПУТАЦИЯ: 26
  • КПД: 31%
  • Регистрация: 2014-03-26
  • Сайт: 
  • Профессия: Программист 8.1
Это число
Эм... это самописный справочник или типовой? Крайне не логично номер лицевого счета делать числом это всегда должна быть строка, т.к. личевые счета часто могут начинаться на некоторое количество нулей.

вот пример, если ЛицевойсчетСРЦ не ссылка:
1. Необходимо объявить событие элемента формы ПриИзменении
2. В созданную процедуру запихать след. код.
&НаКлиенте
Процедура ЛицевойсчетСРЦПриИзменении(Элемент)
    ЗаполнитьТЧНаОсновеЛицевогоСчета();
КонецПроцедуры

&НаСервере
Процедура ЗаполнитьТЧНаОсновеЛицевогоСчета()
    Запрос = Новый Запрос;
    Запрос.Текст = "
        |ВЫБРАТЬ
        |    КарточкаАбонента.Ссылка
        |ИЗ
        |    Справочник.КарточкаАбонента КАК КарточкаАбонента
        |ГДЕ
        |    КарточкаАбонента.ЛицевойСчет = &ЛицевойСчет;
    Запрос.УстановитьПараметр("ЛицевойСчет", Объект.ЛицевойсчетСРЦ);
    Результат = Запрос.Выполнить()
    Если Результат.Пустой()
        Возврат;
    КонецЕсли;
   
    Выборка = Результат.Выбрать();
    Выборка.Следцющий();
    КарточкаАбонента = Выборка.Ссылка;
   
    // Далее заполняешь куда угодно информацию из карточки абонента
КонецПроцедуры

Это при условии, что ЛицевойсчетСРЦ находится в реквизитах документа.

Сложно написать конкретный код, если не известны метаданные справочника и документа
Нажимайте "Спасибо", так приятнее))

Оффлайн witch_n

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-18
  • Сайт: 
  • Профессия: Программист 1С

Оффлайн SGIRG

  • **
  • Сообщений: 83
  • РЕПУТАЦИЯ: 26
  • КПД: 31%
  • Регистрация: 2014-03-26
  • Сайт: 
  • Профессия: Программист 8.1
Только если вечером. Яндекс диск у нас заблокирован.
Нажимайте "Спасибо", так приятнее))


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4041
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7007
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4044
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 6700
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 6689
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
81 Сообщений
wise wise
63 Сообщений
MuI_I_Ika MuI_I_Ika
49 Сообщений
Dethmontt Dethmontt
49 Сообщений
alex0402
43 Сообщений
Сергей Федоров Сергей Федоров
32 Сообщений
ilyay ilyay
27 Сообщений
ilnur75
25 Сообщений
Дмитрий Медведков
19 Сообщений
DmitriyF DmitriyF
17 Сообщений

* Кто онлайн

  • Точка Гостей: 221
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal