Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Июл 2017, 09:33
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполнение поля справочника из подчиненного справочника  (Прочитано 964 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Space_minus

  • **
  • Сообщений: 92
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-03-17
  • Сайт: 
  • Профессия: Ученик 1С
Всем привет! Необходимо мне заполнить поле(Наименование) справочника "Студенты" из подчиненного справочника "ФизЛицо" поле (Наименование)
В модуле формы справочника "Студенты" Написал код:
&НаСервере
Процедура ЗаполнитьФИОпоФизЛицу()
Справочники = РеквизитФормыВЗначение("Объект");
Справочники.Студенты.Наименование = Справочники.ФизическиеЛица.Наименование;
ЗначениеВРеквизитФормы(Справочники, "Объект");
КонецПроцедуры

&НаКлиенте
Процедура ПриИзмененииФизЛица(Элемент)
Если ЗначениеЗаполнено(Объект.ФизЛицо) Тогда
ЗаполнитьФИОпоФизЛицу();
Иначе
КонецЕсли;
КонецПроцедуры

затем указал событие у поля

и вылазит ошибка:


Подскажите, как исправить проблему


Оффлайн SGIRG

  • **
  • Сообщений: 85
  • РЕПУТАЦИЯ: 27
  • КПД: 32%
  • Регистрация: 2014-03-26
  • Сайт: 
  • Профессия: Программист 8.1
У Вас же форма элемента справочника.
значит нужно делать вот так:
Наименование = Физлицо.Наименование;
Нажимайте "Спасибо", так приятнее))

Оффлайн Space_minus

  • **
  • Сообщений: 92
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-03-17
  • Сайт: 
  • Профессия: Ученик 1С
У Вас же форма элемента справочника.
значит нужно делать вот так:
Наименование = Физлицо.Наименование;

не определяется:
{Справочник.Студенты.Форма.ФормаЭлемента.Форма(251,17)}: Переменная не определена (ФизЛицо)

Оффлайн SGIRG

  • **
  • Сообщений: 85
  • РЕПУТАЦИЯ: 27
  • КПД: 32%
  • Регистрация: 2014-03-26
  • Сайт: 
  • Профессия: Программист 8.1
Ну у Вас элемент формы называется "Физлицо". На картинке не видно откуда в него данные попадают
Нажимайте "Спасибо", так приятнее))

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
нечего мудрить там где не надо :thwrt:
получать объект сервера...

Если ЗначениеЗаполнено(Объект.ФизЛицо) Тогда
        ЗаполнитьФИОпоФизЛицу();   
    Иначе
    КонецЕсли;

когда достаточно

Если ЗначениеЗаполнено(Объект.ФизЛицо) Тогда
        Объект.Наименование = ЗаполнитьФИОпоФизЛицу(Объект.ФизЛицо);   
    Иначе
    КонецЕсли;

...
Функция ЗаполнитьФИОпоФизЛицу(ФизЛицо)
    Возврат ФизЛицо.Наименование;
КонецФункции;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн ilnur75

  • ***
  • Сообщений: 111
  • РЕПУТАЦИЯ: 10
  • КПД: 9%
  • Регистрация: 2016-03-13
  • Сайт: 
  • Профессия: Ученик 1С
все проще, например прописать
&НаКлиенте
Процедура ПрописатьФИО()
   Объект.Наименование = ?(ПустаяСтрока(Объект.ФизЛицо), "", СокрЛП(Объект.ФизЛицо) ) ;
КонецПроцедуры

&НаКлиенте
Процедура ФизЛицоПриИзменении(Элемент)
   ПрописатьФИО();
КонецПроцедуры

Оффлайн Space_minus

  • **
  • Сообщений: 92
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-03-17
  • Сайт: 
  • Профессия: Ученик 1С
Всем плюсик за помощь :)
&НаКлиенте
Процедура ФизЛицоПриИзменении(Элемент)
Если НЕ Объект.ФизЛицо.Пустая() Тогда
Объект.Наименование = Объект.ФизЛицо;
КонецЕсли;
КонецПроцедуры

норм заработало


Теги:
 

Заполнение табл. части документа из табл. части другого документа

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 6730
Последний ответ 16 Авг 2012, 21:50
от Will
Заполнение табличной части документа табличной частью из другого документа

Автор PeaceownerРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2327
Последний ответ 30 Ноя 2011, 07:10
от has
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 14661
Последний ответ 16 Авг 2012, 12:07
от Will
заполнение закладки "Материалы" в документе "Поступление из переработки"

Автор Sasa1CРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3304
Последний ответ 10 Июн 2013, 22:34
от Sasa1C
Заполнение столбца табличной части документа по умолчанию и выборка из табличной части.

Автор marshalbratskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1278
Последний ответ 25 Май 2016, 19:38
от marshalbratsk

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
105 Сообщений
alex0402
93 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
65 Сообщений
Golickoff Golickoff
49 Сообщений
ilyay ilyay
49 Сообщений
AIFrame
47 Сообщений
ab30ru
38 Сообщений
wise wise
34 Сообщений
Амал
30 Сообщений
LexaK
22 Сообщений

* Кто онлайн

  • Точка Гостей: 183
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal