Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 11:10
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Открытие формы регистра сведений при нажатии на кнопку  (Прочитано 1009 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Rusf1n

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-01
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день. На форме справочника создал 4 кнопки(фото, видео, аудио, текст). При нажатии на фото, видео или аудио - происходит соответствующее действие и данные успешно сохраняются в регистр сведений, также вся необходимая информация отображается сразу же автоматически и в динамическом списке. Если посмотреть каждую из этих записей, то открывается "ФормаЗаписи" регистра где имеется поле комментарий. Его успешно можно заполнить.
Вопрос вот в чем, при нажатии на кнопку "Текст" - надо, чтобы правильно открывалась "ФормаЗаписи" регистра сведений, где я бы мог оставить комментарий, и данные тоже попали в регистр и обновились в дин. списке. Как это сделать??? Заранее спасибо за ответ.

Ниже представляю код для получения аудиозаписи и записи его в регистр!
 //Получение аудио с устройства
&НаКлиенте
Процедура Аудио(Команда)
Если СредстваМультимедиа.ПоддерживаетсяАудиозапись() тогда
Результат = СредстваМультимедиа.СделатьАудиозапись();
        РезультатАудио = ПредопределенноеЗначение("Перечисление.ВидыПередаваемыхДанных.Аудио");
Иначе
Сообщить("Аудиозапись не поддерживается!");
КонецЕсли;
Данные = Результат.ПолучитьДвоичныеДанные();
ДанныеМультимедиа = РезультатАудио;
РасширениеФайла   = Результат.РасширениеФайла;
ЗаписатьДанныеВРегистр(РасширениеФайла, Данные, ДанныеМультимедиа);
КонецПроцедуры

&НаСервере
Процедура ЗаписатьДанныеВРегистр(РасширениеФайла,Данные,ДанныеМультимедиа)
НовРег = РегистрыСведений.ПередаваемыеДанные.СоздатьМенеджерЗаписи();
НовРег.Период        = ТекущаяДата();
НовРег.ТочкаМаршрута = Объект.Ссылка; 
НовРег.Расширение    = РасширениеФайла;
НовРег.ВидДанных     = ДанныеМультимедиа;
НовРег.Данные        = Новый ХранилищеЗначения(Данные);
НовРег.Записать(Ложь); 
КонецПроцедуры
 
   


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
ну и чем же так существенно отличается кнопка "Аудио" от кнопки "Текст"? :dfbsdfbsdf:
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Rusf1n

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-01
  • Сайт: 
  • Профессия: Ученик 1С
При нажатии на кнопку аудио происходит запись разговора и представляются данные в виде двоичных данных, которые успешно записываются в регистр. А при нажатии на кнопку ТЕКСТ - должна открыться форма где можно просто написать комментарий и все

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
ну значит либо надо при вызове
    ЗаписатьДанныеВРегистр(РасширениеФайла, Данные, ДанныеМультимедиа);
в параметры подсунуть пустые значения, либо в самой процедуре предусмотреть, что входные параметры могут быть не заданы
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 291
Последний ответ 21 Сен 2017, 10:33
от Insider
Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4818
Последний ответ 03 Авг 2011, 11:45
от t955938
получаю значение реквизита формы, дает значение 0

Автор mikel10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3413
Последний ответ 12 Июл 2013, 15:35
от mikel10
Как обратиться к функции модуля формы из модуля Менеджера?

Автор TreeDogNightРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4994
Последний ответ 10 Июл 2014, 14:05
от cska-fanat-kz
Настройка формы "Заполнение товаров"

Автор ЖаннаРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 586
Последний ответ 10 Мар 2017, 21:00
от Жанна

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
177 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
alex0402
44 Сообщений
andron81_81
38 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal