Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 июн 2021, 21:15

Открытие формы регистра сведений при нажатии на кнопку

Автор Rusf1n, 08 авг 2016, 17:03

0 Пользователей и 1 гость просматривают эту тему.

Rusf1n

Добрый день. На форме справочника создал 4 кнопки(фото, видео, аудио, текст). При нажатии на фото, видео или аудио - происходит соответствующее действие и данные успешно сохраняются в регистр сведений, также вся необходимая информация отображается сразу же автоматически и в динамическом списке. Если посмотреть каждую из этих записей, то открывается "ФормаЗаписи" регистра где имеется поле комментарий. Его успешно можно заполнить.
Вопрос вот в чем, при нажатии на кнопку "Текст" - надо, чтобы правильно открывалась "ФормаЗаписи" регистра сведений, где я бы мог оставить комментарий, и данные тоже попали в регистр и обновились в дин. списке. Как это сделать??? Заранее спасибо за ответ.

Ниже представляю код для получения аудиозаписи и записи его в регистр!
//Получение аудио с устройства
&НаКлиенте
Процедура Аудио(Команда)
Если СредстваМультимедиа.ПоддерживаетсяАудиозапись() тогда
Результат = СредстваМультимедиа.СделатьАудиозапись();
        РезультатАудио = ПредопределенноеЗначение("Перечисление.ВидыПередаваемыхДанных.Аудио");
Иначе
Сообщить("Аудиозапись не поддерживается!");
КонецЕсли;
Данные = Результат.ПолучитьДвоичныеДанные();
ДанныеМультимедиа = РезультатАудио;
РасширениеФайла   = Результат.РасширениеФайла;
ЗаписатьДанныеВРегистр(РасширениеФайла, Данные, ДанныеМультимедиа);
КонецПроцедуры

&НаСервере
Процедура ЗаписатьДанныеВРегистр(РасширениеФайла,Данные,ДанныеМультимедиа)
НовРег = РегистрыСведений.ПередаваемыеДанные.СоздатьМенеджерЗаписи();
НовРег.Период        = ТекущаяДата();
НовРег.ТочкаМаршрута = Объект.Ссылка; 
НовРег.Расширение    = РасширениеФайла;
НовРег.ВидДанных     = ДанныеМультимедиа;
НовРег.Данные        = Новый ХранилищеЗначения(Данные);
НовРег.Записать(Ложь); 
КонецПроцедуры
   

cska-fanat-kz

ну и чем же так существенно отличается кнопка "Аудио" от кнопки "Текст"? :dfbsdfbsdf:
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Rusf1n

При нажатии на кнопку аудио происходит запись разговора и представляются данные в виде двоичных данных, которые успешно записываются в регистр. А при нажатии на кнопку ТЕКСТ - должна открыться форма где можно просто написать комментарий и все

cska-fanat-kz

ну значит либо надо при вызове
    ЗаписатьДанныеВРегистр(РасширениеФайла, Данные, ДанныеМультимедиа);
в параметры подсунуть пустые значения, либо в самой процедуре предусмотреть, что входные параметры могут быть не заданы
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск