Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Июл 2017, 01:32
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Открытие формы регистра сведений при нажатии на кнопку  (Прочитано 769 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Rusf1n

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-01
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день. На форме справочника создал 4 кнопки(фото, видео, аудио, текст). При нажатии на фото, видео или аудио - происходит соответствующее действие и данные успешно сохраняются в регистр сведений, также вся необходимая информация отображается сразу же автоматически и в динамическом списке. Если посмотреть каждую из этих записей, то открывается "ФормаЗаписи" регистра где имеется поле комментарий. Его успешно можно заполнить.
Вопрос вот в чем, при нажатии на кнопку "Текст" - надо, чтобы правильно открывалась "ФормаЗаписи" регистра сведений, где я бы мог оставить комментарий, и данные тоже попали в регистр и обновились в дин. списке. Как это сделать??? Заранее спасибо за ответ.

Ниже представляю код для получения аудиозаписи и записи его в регистр!
 //Получение аудио с устройства
&НаКлиенте
Процедура Аудио(Команда)
Если СредстваМультимедиа.ПоддерживаетсяАудиозапись() тогда
Результат = СредстваМультимедиа.СделатьАудиозапись();
        РезультатАудио = ПредопределенноеЗначение("Перечисление.ВидыПередаваемыхДанных.Аудио");
Иначе
Сообщить("Аудиозапись не поддерживается!");
КонецЕсли;
Данные = Результат.ПолучитьДвоичныеДанные();
ДанныеМультимедиа = РезультатАудио;
РасширениеФайла   = Результат.РасширениеФайла;
ЗаписатьДанныеВРегистр(РасширениеФайла, Данные, ДанныеМультимедиа);
КонецПроцедуры

&НаСервере
Процедура ЗаписатьДанныеВРегистр(РасширениеФайла,Данные,ДанныеМультимедиа)
НовРег = РегистрыСведений.ПередаваемыеДанные.СоздатьМенеджерЗаписи();
НовРег.Период        = ТекущаяДата();
НовРег.ТочкаМаршрута = Объект.Ссылка; 
НовРег.Расширение    = РасширениеФайла;
НовРег.ВидДанных     = ДанныеМультимедиа;
НовРег.Данные        = Новый ХранилищеЗначения(Данные);
НовРег.Записать(Ложь); 
КонецПроцедуры
 
   


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
ну и чем же так существенно отличается кнопка "Аудио" от кнопки "Текст"? :dfbsdfbsdf:
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Rusf1n

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-01
  • Сайт: 
  • Профессия: Ученик 1С
При нажатии на кнопку аудио происходит запись разговора и представляются данные в виде двоичных данных, которые успешно записываются в регистр. А при нажатии на кнопку ТЕКСТ - должна открыться форма где можно просто написать комментарий и все

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
ну значит либо надо при вызове
    ЗаписатьДанныеВРегистр(РасширениеФайла, Данные, ДанныеМультимедиа);
в параметры подсунуть пустые значения, либо в самой процедуре предусмотреть, что входные параметры могут быть не заданы
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
116 Сообщений
alex0402
102 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
72 Сообщений
AIFrame
49 Сообщений
ilyay ilyay
49 Сообщений
Golickoff Golickoff
49 Сообщений
ab30ru
38 Сообщений
wise wise
34 Сообщений
Амал
30 Сообщений
lansy
22 Сообщений

* Кто онлайн

  • Точка Гостей: 151
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal