Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 июн 2021, 12:04

Метод объекта не обнаружен (ФамилияИнициалыФизЛица)

Автор Space_minus, 05 авг 2016, 05:37

0 Пользователей и 1 гость просматривают эту тему.

Space_minus

Хочу просклонять ФИО, в базе "Колледж" есть общая модуль ФамилияИнициалыФизЛица!


Функция ФамилияИнициалыФизЛица(Объект = "", Фамилия = " ", Имя = " ", Отчество = " ") Экспорт
    Если Не ЗначениеЗаполнено(Фамилия) И Не ЗначениеЗаполнено(Имя) Тогда
        ФИО = ФамилияИмяОтчествоФизЛица(Объект);
        Фамилия = ФИО.Фамилия;
        Имя        = ФИО.Имя;
        Отчество= ФИО.Отчество;
    КонецЕсли;   
    Возврат ?(НЕ ПустаяСтрока(Фамилия),
                Фамилия + ?(НЕ ПустаяСтрока(Имя)," " + Лев(Имя,1) + "." + ?(НЕ ПустаяСтрока(Отчество),Лев(Отчество,1)+".", ""), ""),
                "");
КонецФункции


В запросе для ПФ создал переменную, которая выводит ФИО "ФИОответвтвенного"


&НаСервере
Функция ПечатьДоговорТрехсторонний (МассивОбъектов,ОбъектыПечати)
ТабДок = Новый ТабличныйДокумент;
ТабДок.АвтоМасштаб = Истина;
ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Портрет;



Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| КонтрактНаОбучение.Организация.НомерЛицензии КАК НомерЛицензии,
| КонтрактНаОбучение.Организация.КемЛицензирована КАК КемЛицензирована,
| КонтрактНаОбучение.Организация.ДатаЛицензии КАК ДатаЛицензии,
| КонтрактНаОбучение.Номер КАК Номер,
| КонтрактНаОбучение.Студенты.Специальность.Нормативный_Срок_Освоения КАК НормСрок,
| КонтрактНаОбучение.Студенты.Специальность.Срок_Обучения_Согласно_Учебному_Плану КАК СрокОбуч,
| КонтрактНаОбучение.Студенты.Специальность.Стоимость КАК Стоимость,
| КонтрактНаОбучение.Дата КАК Дата,
| КонтрактНаОбучение.Организация.ИНН КАК ИНН,
| КонтрактНаОбучение.Организация.КПП КАК КПП,
| КонтрактНаОбучение.Организация.Код_ОКТМО КАК ОКТМО,
| БанковскиеСчета.Банк.Наименование КАК БанкНаименование,
| БанковскиеСчета.Банк.КоррСчет КАК БанкКоррСчет,
| БанковскиеСчета.Банк.Код КАК БИК,
| КонтрактНаОбучение.Студенты.ФизЛицо.СерияДокументаУдостоверяющегоЛичность КАК ПотрСерияПаспорта,
| КонтрактНаОбучение.Студенты.ФизЛицо.НомерДокументаУдостоверяющегоЛичность КАК ПотрНомерПаспорта,
| КонтрактНаОбучение.Студенты.ФизЛицо.КемВыданДокументУдостоверяющийЛичность.Наименование КАК ПотрКемВыданПаспорт,
| КонтрактНаОбучение.Студенты.ФизЛицо.ДатаВыдачиДокументаУдостоверяющегоЛичность КАК ПотрДатаВыдчиПаспорта,
| КонтрактНаОбучение.Студенты.ФизЛицо.КодПодразделенияДокументУдостоверяющийЛичность КАК ПотрКодПодразделения,
| КонтрактНаОбучение.Студенты.ФизЛицо.ДатаРождения КАК ПотрДатаРождения,
| КонтрактНаОбучение.Студенты.ФизЛицо.МестоРождения КАК ПотрМестоРождения,
| ОтветственныеЛицаОрганизаций.Период КАК ДатаДоверености,
| ОтветственныеЛицаОрганизаций.Должность.Номер_Доверености КАК НомерДоверености,
| ОтветственныеЛицаОрганизаций.Сотрудник.Наименование КАК ОтветственныйФИО,
| КонтрактНаОбучение.Заказчик КАК ЗаказчикФИО,
| КонтрактНаОбучение.Серия_Паспорта_Заказчика КАК ЗаказчикСерияПаспорта,
| КонтрактНаОбучение.Номер_Паспорта_Заказчика КАК ЗаказчикНомерПаспорта,
| КонтрактНаОбучение.Паспорт_Выдан КАК ЗаказчикКемВыданПаспорт,
| КонтрактНаОбучение.Дата_Выдачи_Паспорта_Заказчика КАК ЗаказчикДатаВыдчиПаспорта,
| КонтрактНаОбучение.Код_Подразделения_Паспорта_Заказчика КАК ЗаказчикКодПодразделения,
| КонтрактНаОбучение.Дата_Рождения_Заказчика КАК ЗаказчикДатаРождения,
| КонтрактНаОбучение.Место_Рождения_Заказчика КАК ЗаказчикМестоРождения,
| КонтрактНаОбучение.Телефон_Заказчика КАК ЗаказчикНомерТелефона,
| КонтрактНаОбучение.АдресЗаказчика КАК ЗаказчикАдрес,
| КонтрактНаОбучение.Студенты.Специальность.Полное_Название_Образовательной_Программы КАК ПолнНаимОбрПрогр,
| КонтрактНаОбучение.Студенты.Наименование КАК Потребитель,
| ОтветственныеЛицаОрганизаций.Должность.Наименование_В_падеже_Дат КАК ДолжностьВПадеже,
| АдресАбитуриента.Представление КАК ПотрАдрес,
| АдресОрганизации.Представление КАК АдресОрганизации,
| ТелефонАбитуриента.Представление КАК ПотрНомерТелефона,
| КонтрактНаОбучение.Организация.НаименованиеПолное КАК ОрганизацияНаименованиеПолное,
| КонтрактНаОбучение.Студенты.ФизЛицо.ФормаОбучения КАК ФормаОбучения,
| ТелефонОрганизации.Представление КАК ТелефонОрганизации,
| КонтрактНаОбучение.Организация.КодБюджетнойКлассификации КАК КБК,
| КонтрактНаОбучение.НазначениеПлатежа.Наименование КАК НазначениеПлатежа
|ИЗ
| Документ.КонтрактНаОбучение КАК КонтрактНаОбучение
| ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
| ФизическиеЛицаКонтактнаяИнформация.Ссылка КАК Ссылка,
| ФизическиеЛицаКонтактнаяИнформация.Представление КАК Представление
| ИЗ
| Справочник.ФизическиеЛица.КонтактнаяИнформация КАК ФизическиеЛицаКонтактнаяИнформация
| ГДЕ
| ФизическиеЛицаКонтактнаяИнформация.Тип = ЗНАЧЕНИЕ(Перечисление.ТипыКонтактнойИнформации.Адрес)
| И ФизическиеЛицаКонтактнаяИнформация.Вид = ЗНАЧЕНИЕ(Справочник.ВидыКонтактнойИнформации.АдресПоПрописке)) КАК АдресАбитуриента
| ПО КонтрактНаОбучение.Студенты.ФизЛицо.Ссылка = АдресАбитуриента.Ссылка
| ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
| ФизическиеЛицаКонтактнаяИнформация.Ссылка КАК Ссылка,
| ФизическиеЛицаКонтактнаяИнформация.Представление КАК Представление
| ИЗ
| Справочник.ФизическиеЛица.КонтактнаяИнформация КАК ФизическиеЛицаКонтактнаяИнформация
| ГДЕ
| ФизическиеЛицаКонтактнаяИнформация.Тип = ЗНАЧЕНИЕ(Перечисление.ТипыКонтактнойИнформации.Телефон)) КАК ТелефонАбитуриента
| ПО КонтрактНаОбучение.Студенты.ФизЛицо.Ссылка = ТелефонАбитуриента.Ссылка
| ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
| ОрганизацииКонтактнаяИнформация.Ссылка КАК Ссылка,
| ОрганизацииКонтактнаяИнформация.Представление КАК Представление
| ИЗ
| Справочник.Организации.КонтактнаяИнформация КАК ОрганизацииКонтактнаяИнформация
| ГДЕ
| ОрганизацииКонтактнаяИнформация.Тип = ЗНАЧЕНИЕ(Перечисление.ТипыКонтактнойИнформации.Адрес)
| И ОрганизацииКонтактнаяИнформация.Вид = ЗНАЧЕНИЕ(Справочник.ВидыКонтактнойИнформации.ОрганизацияЮридическийАдрес)) КАК АдресОрганизации
| ПО КонтрактНаОбучение.Организация.Ссылка = АдресОрганизации.Ссылка
| ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
| ОрганизацииКонтактнаяИнформация.Ссылка КАК Ссылка,
| ОрганизацииКонтактнаяИнформация.Представление КАК Представление
| ИЗ
| Справочник.Организации.КонтактнаяИнформация КАК ОрганизацииКонтактнаяИнформация
| ГДЕ
| ОрганизацииКонтактнаяИнформация.Тип = ЗНАЧЕНИЕ(Перечисление.ТипыКонтактнойИнформации.Телефон)) КАК ТелефонОрганизации
| ПО КонтрактНаОбучение.Организация.Ссылка = ТелефонОрганизации.Ссылка,
| РегистрСведений.ОтветственныеЛицаОрганизаций КАК ОтветственныеЛицаОрганизаций,
| Справочник.БанковскиеСчета КАК БанковскиеСчета
|ГДЕ
| КонтрактНаОбучение.Ссылка В(&МассивОбъектов)";


Запрос.УстановитьПараметр("МассивОбъектов",МассивОбъектов);
РезультатЗапроса = Запрос.Выполнить().Выбрать();



Пока РезультатЗапроса.Следующий() Цикл
//НомерСтрокиНачало = ТабДок.ВысотаТаблицы + 1;
Макет = ПолучитьМакет("ДоговорТрехсторонний");

ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
ОбластьМакета.Параметры.Заполнить(РезультатЗапроса);
ТабДок.Вывести(ОбластьМакета);

ОбластьМакета = Макет.ПолучитьОбласть("Абзац1");
ОбластьМакета.Параметры.Абзац1 = "            "+РезультатЗапроса.ОрганизацияНаименованиеПолное+" на основании лицензии регистрационный № "+РезультатЗапроса.НомерЛицензии+", выданной "+РезультатЗапроса.КемЛицензирована+"  "+Формат(РезультатЗапроса.ДатаЛицензии,"ДФ=dd.MM.yyyy")+" (бессрочно), в лице "+РезультатЗапроса.ДолжностьВПадеже+" "+РезультатЗапроса.ОтветственныйФИО+", действующего на основании доверенности "+РезультатЗапроса.НомерДоверености+" от  "+Формат(РезультатЗапроса.ДатаДоверености,"ДФ=dd.MM.yyyy")+" года, (далее - Исполнитель), с одной стороны и";
ТабДок.Вывести(ОбластьМакета);

ОбластьМакета = Макет.ПолучитьОбласть("Пункт1");
ОбластьМакета.Параметры.Заполнить(РезультатЗапроса);
ТабДок.Вывести(ОбластьМакета);




ОбластьМакета = Макет.ПолучитьОбласть("ИО");
ФамИО = ОбщегоНазначения.ФамилияИнициалыФизЛица(РезультатЗапроса.ОтветственныйФИО); //"ФамИО" - параметр на ПФ в области "ИО", а "ОтветственныйФИО" это переменная из запроса
                                                                         
ТабДок.Вывести(ОбластьМакета);


КонецЦикла;
Возврат ТабДок;


после компиляции вылазит ошибка:

Подскажите в чем дело? Как грамотно сделать инициалы?


cska-fanat-kz

проверить настройки общего модуля ОбщегоНазначения, если он только клиентский, то будете получать подобную ошибку.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Space_minus

Проверил настройки общего модуля, Клиент и серверный

cska-fanat-kz

Так "ОбщегоНазначения" или "ФамилияИнициалыФизЛица"?!
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Space_minus

Общий модуль "ФамилияИнициалыФизЛица" тогда наверное надо написать 

ФамИО = РаботаСоСтрокамиСервер.ФамилияИнициалыФизЛица(РезультатЗапроса.ОтветственныйФИО);



но ФамИО  не выводитсы на ПФ

cska-fanat-kz

ну элементарно же!
<<ИмяОбщегоМодуля>>.<<ИмяПроцедуры()>>
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск