Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Мар 2017, 17:15
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Отображение номенклатуры в Иерархии в печатной форме  (Прочитано 790 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Lostuk

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-04
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день. Я далек еще от правильного и красивого писания кода, поэтому не ругайтесь, а лучше помогите:)
Есть печатная форма, в ней нужно сделать вывод номенклатуры в виде Иерархии. В данный момент он мне показывает иерархию, но не отображает название групп(Приложил скриншот).
Функция Печать() Экспорт
    мВалютаРегламентированногоУчета = глЗначениеПеременной("ВалютаРегламентированногоУчета");
    мВалютаУпрУчета                 = глЗначениеПеременной("ВалютаУправленческогоУчета");
 
    ДопКолонка = Константы.ДополнительнаяКолонкаПечатныхФормДокументов.Получить();
    Если ДопКолонка = Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.Артикул Тогда
        ТоварКод = "Артикул";
    Иначе
        ТоварКод = "Код";
    КонецЕсли;
 
    Если СсылкаНаОбъект.Склад.ВидСклада = Перечисления.ВидыСкладов.НТТ Тогда
        ВалютаПересчета = мВалютаРегламентированногоУчета;
    Иначе
        ВалютаПересчета = мВалютаУпрУчета;
    КонецЕсли;
 
    ВалютаПечати = мВалютаРегламентированногоУчета;
    Параметры    = МодульВалютногоУчета.ПолучитьКурсВалюты(ВалютаПересчета, СсылкаНаОбъект.Дата);
    Запрос       = Новый Запрос;
    Запрос.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект);
   
    Запрос.Текст =
    "ВЫБРАТЬ
    |   Номер  КАК НомерДокумента,
    |   Дата   КАК ДатаДокумента,
    |   Дата   КАК ДатаНачалаИнвентаризации,
    |   Организация КАК Руководители,
    |   Организация,
    |   Склад.Представление КАК ПредставлениеСклада
    |ИЗ
    |   Документ.ИнвентаризацияТоваровНаСкладе КАК ИнвентаризацияТоваровНаСкладе
    |
    |ГДЕ
    |   ИнвентаризацияТоваровНаСкладе.Ссылка = &ТекущийДокумент";
 
    Шапка = Запрос.Выполнить().Выбрать();
    Шапка.Следующий();
   
    Запрос.УстановитьПараметр("Курс",            Параметры.Курс);
    Запрос.УстановитьПараметр("Кратность",       Параметры.Кратность);
    Запрос.УстановитьПараметр("ВидСкладаНТТ",    Перечисления.ВидыСкладов.НТТ);
 
    Запрос.Текст =
    "ВЫБРАТЬ
    |   НомерСтроки КАК Номер,
    |   Номенклатура,
    |   Номенклатура.ЭтоГруппа КАК ЭтоГруппа,
    |   Номенклатура.Родитель КАК Родитель,
    |   Номенклатура.НаименованиеПолное КАК ТоварНаименование,
    |   Номенклатура." + ТоварКод + "   КАК ТоварКод,
    |   ЕдиницаИзмерения.Представление  КАК ЕдиницаИзмеренияНаименование,
    |   ЕдиницаИзмерения.ЕдиницаПоКлассификатору.Код КАК ЕдиницаИзмеренияКодПоОКЕИ,
    |   Количество                     КАК ФактКоличество,
    |   КоличествоУчет                 КАК БухКоличество,
    |   ВЫБОР
    |       КОГДА Ссылка.Склад.ВидСклада = &ВидСкладаНТТ ТОГДА ЦенаВРознице
    |       ИНАЧЕ Цена * &Курс / &Кратность
    |   КОНЕЦ КАК Цена,
    |   ВЫБОР
    |       КОГДА Ссылка.Склад.ВидСклада = &ВидСкладаНТТ ТОГДА Количество * ЦенаВРознице
    |       ИНАЧЕ Сумма * &Курс / &Кратность
    |   КОНЕЦ КАК ФактСумма,
    |   ВЫБОР
    |       КОГДА Ссылка.Склад.ВидСклада = &ВидСкладаНТТ ТОГДА КоличествоУчет *ЦенаВРознице
    |       ИНАЧЕ СуммаУчет * &Курс / &Кратность
    |   КОНЕЦ КАК БухСумма,
    |   ХарактеристикаНоменклатуры     КАК Характеристика,
    |   СерияНоменклатуры КАК Серия
    |ИЗ
    |   Документ.ИнвентаризацияТоваровНаСкладе.Товары КАК Товары
    |   
    |ГДЕ
    |   Товары.Ссылка = &ТекущийДокумент
    |   И (Товары.Количество - Товары.КоличествоУчет) <> 0
    |   
    |УПОРЯДОЧИТЬ ПО
    |Товары.Номенклатура.Родитель
    |ИТОГИ ПО ОБЩИЕ,
    |    Номенклатура ИЕРАРХИЯ";
 
    Результат = Запрос.Выполнить();
    ВыборкаСтрокТовары = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкамСИерархией);
   
 
    ТабДокумент = Новый ТабличныйДокумент;
    ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ИнвентаризацияТоваровНаСкладе_ИНВ19";
    Макет       = ПолучитьМакет("ИНВ19КОПИЯ");
 
 
    ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
    ОбластьМакета.Параметры.Заполнить(Шапка);
    СведенияОбОрганизации = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Шапка.Организация, Шапка.ДатаДокумента);
    ОбластьМакета.Параметры.ПредставлениеОрганизации = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОбОрганизации);
    ОбластьМакета.Параметры.ОрганизацияПоОКПО        = СведенияОбОрганизации.КодПоОКПО;
    ОбластьМакета.Параметры.ДатаДокумента            = Шапка.ДатаДокумента;
    ОбластьМакета.Параметры.ДатаНачалаИнвентаризации = Шапка.ДатаНачалаИнвентаризации;
    ОбластьМакета.Параметры.НомерДокумента           = ОбщегоНазначения.ПолучитьНомерНаПечать(СсылкаНаОбъект);
 
    Руководители = РегламентированнаяОтчетность.ОтветственныеЛицаОрганизаций(Шапка.Руководители, Шапка.ДатаДокумента,);
    Руководитель = Руководители.Руководитель;
    Бухгалтер    = Руководители.ГлавныйБухгалтер;
 
    ТабДокумент.Вывести(ОбластьМакета);
    ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
   
    НомерСтраницы   = 2;
   
    ИтогоРезультатИзлишекКолво   = 0;
    ИтогоРезультатИзлишекСумма   = 0;
    ИтогоРезультатНедостачаКолво = 0;
    ИтогоРезультатНедостачаСумма = 0;
    ИтогоРезультатРазница = 0;
    Разность = 0;
 
 
    // Выводим заголовок таблицы
    ЗаголовокТаблицы = Макет.ПолучитьОбласть("ЗаголовокТаблицы1");
    ЗаголовокТаблицы.Параметры.НомерСтраницы = "Страница " + НомерСтраницы;
    ТабДокумент.Вывести(ЗаголовокТаблицы);
 
    КоличествоСтрок = ВыборкаСтрокТовары.Количество();
 
    // Выводим многострочную часть докмента
    //ОбластьМакетаГр            = Макет.ПолучитьОбласть("СтрокаГруппы");    //Заккоментировал
    //ОбластьМакета              = Макет.ПолучитьОбласть("СтрокаТаблицы1");
    ОбластьИтоговПоСтранице    = Макет.ПолучитьОбласть("ИтогоТаблицы1");
    ОбластьПодвала             = Макет.ПолучитьОбласть("Подвал");
    МассивВыводимыхОбластей    = Новый Массив;
    Ном = 0;
   
    ///   ТУТ Я НАЧАЛ ИЗОБРЕТАТЬ ВЕЛОСИПЕД, для отображения групп!!!//////
    ///
    ВыборкаСтрокТовары.Следующий();
    ТабДокумент.НачатьАвтогруппировкуСтрок();
   
    ВыборкаНоменклатуры = ВыборкаСтрокТовары.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
   
    Пока ВыборкаНоменклатуры.Следующий() Цикл
       
        Ном = Ном + 1;
 
        Если ВыборкаНоменклатуры.Номенклатура.ЭтоГруппа Тогда
            ОбластьМакета = Макет.ПолучитьОбласть("СтрокаГруппы");
        Иначе
            ОбластьМакета = Макет.ПолучитьОбласть("СтрокаТаблицы1");
        КонецЕсли;
       
        ОбластьМакета.Параметры.Заполнить(ВыборкаНоменклатуры);
       
        РодительНоменклатуры = ВыборкаНоменклатуры.Родитель;
       
        УровеньИерархии = 0;
        Пока ЗначениеЗаполнено(РодительНоменклатуры) Цикл
            УровеньИерархии = УровеньИерархии +1;
            РодительНоменклатуры = РодительНоменклатуры.Родитель;
        КонецЦикла;       
        ТабДокумент.Вывести(ОбластьМакета,УровеньИерархии);
    КонецЦикла;

        ТабДокумент.ЗакончитьАвтогруппировкуСтрок();
 
        Пока ВыборкаСтрокТовары.Следующий() Цикл
       
        Разница     = 0;
        РазницаСумм = 0;
       
        Разница     = ВыборкаСтрокТовары.ФактКоличество - ВыборкаСтрокТовары.БухКоличество;      //
        РазницаСумм = ВыборкаСтрокТовары.ФактСумма      - ВыборкаСтрокТовары.БухСумма;        //
   
        Если Разница < 0 И РазницаСумм < 0 Тогда
            ОбластьМакета.Параметры.РезультатНедостачаКолво = - Разница;
            ОбластьМакета.Параметры.РезультатНедостачаСумма = - РазницаСумм;
            ОбластьМакета.Параметры.РезультатИзлишекКолво   = 0;
            ОбластьМакета.Параметры.РезультатИзлишекСумма   = 0;
       
            ОбластьМакета.Параметры.Разность =  РазницаСумм;
       
 
            ИтогоРезультатНедостачаКолво = ИтогоРезультатНедостачаКолво + (- Разница);
            ИтогоРезультатНедостачаСумма = ИтогоРезультатНедостачаСумма + (- РазницаСумм);
        ИначеЕсли Разница < 0 И РазницаСумм >= 0 Тогда
            ОбластьМакета.Параметры.РезультатНедостачаКолво = - Разница;
            ОбластьМакета.Параметры.РезультатНедостачаСумма = РазницаСумм;
            ОбластьМакета.Параметры.РезультатИзлишекКолво   = 0;
            ОбластьМакета.Параметры.РезультатИзлишекСумма   = 0;
 
            ОбластьМакета.Параметры.Разность =  РазницаСумм;
   
       
            ИтогоРезультатНедостачаКолво = ИтогоРезультатНедостачаКолво + (- Разница);
            ИтогоРезультатНедостачаСумма = ИтогоРезультатНедостачаСумма + РазницаСумм;
        Иначе
            ОбластьМакета.Параметры.РезультатНедостачаКолво = 0;
            ОбластьМакета.Параметры.РезультатНедостачаСумма = 0;
            ОбластьМакета.Параметры.РезультатИзлишекКолво   = Разница;
            ОбластьМакета.Параметры.РезультатИзлишекСумма   = РазницаСумм;
   
            ОбластьМакета.Параметры.Разность =  РазницаСумм;
       
            ИтогоРезультатИзлишекКолво   = ИтогоРезультатИзлишекКолво   + Разница;
            ИтогоРезультатИзлишекСумма   = ИтогоРезультатИзлишекСумма   + РазницаСумм;
        КонецЕсли;
   
        ИтогоРезультатРазница = ИтогоРезультатИзлишекСумма - ИтогоРезультатНедостачаСумма;
 
        МассивВыводимыхОбластей.Очистить();
        МассивВыводимыхОбластей.Добавить(ОбластьМакета);
        МассивВыводимыхОбластей.Добавить(ОбластьИтоговПоСтранице);
        Если Ном = КоличествоСтрок Тогда
            МассивВыводимыхОбластей.Добавить(ОбластьПодвала);
        КонецЕсли;
       
        Если НЕ ФормированиеПечатныхФорм.ПроверитьВыводТабличногоДокумента(ТабДокумент, МассивВыводимыхОбластей) Тогда
           
            НомерСтраницы = НомерСтраницы + 1;
            ТабДокумент.Вывести(ОбластьИтоговПоСтранице);
            ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
            ЗаголовокТаблицы.Параметры.НомерСтраницы = "Страница " + НомерСтраницы;
            ТабДокумент.Вывести(ЗаголовокТаблицы);
           
        КонецЕсли;
       
        ТабДокумент.Вывести(ОбластьМакета);
 
    КонецЦикла;
 
    ОбластьИтоговПоСтранице.Параметры.ИтогоРезультатИзлишекКолво   = ИтогоРезультатИзлишекКолво;
    ОбластьИтоговПоСтранице.Параметры.ИтогоРезультатИзлишекСумма   = ИтогоРезультатИзлишекСумма;
    ОбластьИтоговПоСтранице.Параметры.ИтогоРезультатНедостачаКолво = ИтогоРезультатНедостачаКолво;
    ОбластьИтоговПоСтранице.Параметры.ИтогоРезультатНедостачаСумма = ИтогоРезультатНедостачаСумма;
 
    ОбластьИтоговПоСтранице.Параметры.ИтогоРезультатРазница = ИтогоРезультатРазница;   
 
    ТабДокумент.Вывести(ОбластьИтоговПоСтранице);
 
    ОбластьПодвала.Параметры.ФИОБухгалтера =  Бухгалтер;
    ОбластьПодвала.Параметры.Заполнить(Шапка);
    ТабДокумент.Вывести(ОбластьПодвала);
 
    ТабДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
 
    Возврат ТабДокумент;
 
КонецФункции


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1096
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
1)
Если ВыборкаНоменклатуры.Номенклатура.ЭтоГруппа Тогда             ОбластьМакета = Макет.ПолучитьОбласть("СтрокаГруппы");         Иначе             ОбластьМакета = Макет.ПолучитьОбласть("СтрокаТаблицы1");         КонецЕсли;

вот это всегда будет ЛОЖЬ

2)
ОбластьМакета.Параметры.Заполнить(ВыборкаНоменклатуры);

параметры в строке из выборки заполняются, РодительНоменклатура - никак не учитывается
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Lostuk

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-04
  • Сайт: 
  • Профессия: Ученик 1С
1)
Если ВыборкаНоменклатуры.Номенклатура.ЭтоГруппа Тогда             ОбластьМакета = Макет.ПолучитьОбласть("СтрокаГруппы");         Иначе             ОбластьМакета = Макет.ПолучитьОбласть("СтрокаТаблицы1");         КонецЕсли;

вот это всегда будет ЛОЖЬ

2)
ОбластьМакета.Параметры.Заполнить(ВыборкаНоменклатуры);

параметры в строке из выборки заполняются, РодительНоменклатура - никак не учитывается

Спасибо за ответ... Но если честно это не помогает мне исправить проблему. Если можете подскажите подробнее, пожалуйста. Кстати, в первом пункте, оно не всегда будет "ложь". Прикладываю скриншот.

Оффлайн Летящий в даль

  • **
  • Сообщений: 56
  • РЕПУТАЦИЯ: 12
  • КПД: 21%
  • 1с - это диагенез :D
  • Регистрация: 2016-05-16
  • Сайт: 
  • Профессия: Программист 1С
Можно ваще прямой обход поставит и не парится создавать 2 выборки)) и в макете 1 область))

Оффлайн Lostuk

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-04
  • Сайт: 
  • Профессия: Ученик 1С
Глупый в этом я еще)) Мне бы хоть пример или набросок какой.

Оффлайн Летящий в даль

  • **
  • Сообщений: 56
  • РЕПУТАЦИЯ: 12
  • КПД: 21%
  • 1с - это диагенез :D
  • Регистрация: 2016-05-16
  • Сайт: 
  • Профессия: Программист 1С
Дак пробуй)) инструкцию дали
Вот пример с иерархией

ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);


ТабДок.НачатьАвтогруппировкуСтрок();

стр=0;
ин=0;
цвет= новый Цвет(224,224,224);
СтатьяПредыдущая=Неопределено;
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
ВыборкаПоБюджету=ВыборкаДетальныеЗаписи.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам) ;

ОбластьСтрокаТабл.Параметры.НаименованиеСтатьи=ВыборкаДетальныеЗаписи.СтатьиБюджета;
СтатьяПредыдущая=ВыборкаДетальныеЗаписи.СтатьиБюджета;
ОбластьСтрокаТабл.Параметры.Подразделение=ВыборкаДетальныеЗаписи.ЦФО;
ОбластьСтрокаТабл.Параметры.Коммент="";
ОбластьСтрокаТабл.Параметры.Контрагент=ВыборкаДетальныеЗаписи.Контрагент;
ОбластьСтрокаТабл.Параметры.Номенклатура=ВыборкаДетальныеЗаписи.Номенклатура;
ОбластьСтрокаТабл.Параметры.СуммаГод=?(ЗначениеЗаполнено(ВыборкаДетальныеЗаписи.СуммаСценарияОборотГод),(ВыборкаДетальныеЗаписи.СуммаСценарияОборотГод),"0,00") ;
ОбластьСтрокаТабл.Параметры.СуммаС1=?(ЗначениеЗаполнено(ВыборкаДетальныеЗаписи.СуммаСценарияОборотМесяц1),(ВыборкаДетальныеЗаписи.СуммаСценарияОборотМесяц1),"0,00");
ОбластьСтрокаТабл.Параметры.СуммаС2=?(ЗначениеЗаполнено(ВыборкаДетальныеЗаписи.СуммаСценарияОборотМесяц2),(ВыборкаДетальныеЗаписи.СуммаСценарияОборотМесяц2),"0,00");

//ОбластьСтрокаТабл.Параметры.РазностьС2иС1=Строка(?(ЗначениеЗаполнено(ВыборкаДетальныеЗаписи.СуммаСценарияОборотМесяц2),Число(ВыборкаДетальныеЗаписи.СуммаСценарияОборотМесяц2),0)-?(ЗначениеЗаполнено(ВыборкаДетальныеЗаписи.СуммаСценарияОборотМесяц1),Число(ВыборкаДетальныеЗаписи.СуммаСценарияОборотМесяц1),0)) ; //"Нужнос посчитать";//Строка(ВыборкаДетальныеЗаписи.Разница);
ОбластьСтрокаТабл.Параметры.РазностьС2иС1=?(ЗначениеЗаполнено(ВыборкаДетальныеЗаписи.Разница),(ВыборкаДетальныеЗаписи.Разница),"0,00");

ОбластьСтрокаТабл.Параметры.Коммент=ВыборкаДетальныеЗаписи.Комментарий;

ТабДок.Вывести(ОбластьСтрокаТабл,ВыборкаДетальныеЗаписи.Уровень());
ТабДок.Область(ТабДок.ВысотаТаблицы,2,ТабДок.ВысотаТаблицы,2).Отступ=ВыборкаДетальныеЗаписи.Уровень()*2;

Пока ВыборкаПоБюджету.Следующий() Цикл

ОбластьСтрокаТабл.Параметры.НаименованиеСтатьи=ВыборкаПоБюджету.СтатьиБюджета;//Нужно сделать иерархию вссю
ОбластьСтрокаТабл.Параметры.Подразделение=ВыборкаПоБюджету.ЦФО;
ОбластьСтрокаТабл.Параметры.Контрагент=ВыборкаПоБюджету.Контрагент;
ОбластьСтрокаТабл.Параметры.Номенклатура=ВыборкаПоБюджету.Номенклатура;
ОбластьСтрокаТабл.Параметры.Коммент="";
ОбластьСтрокаТабл.Параметры.СуммаГод=?(ЗначениеЗаполнено(ВыборкаПоБюджету.СуммаСценарияОборотГод),(ВыборкаПоБюджету.СуммаСценарияОборотГод),"0,00") ;
ОбластьСтрокаТабл.Параметры.СуммаС1=?(ЗначениеЗаполнено(ВыборкаПоБюджету.СуммаСценарияОборотМесяц1),(ВыборкаПоБюджету.СуммаСценарияОборотМесяц1),"0,00");
ОбластьСтрокаТабл.Параметры.СуммаС2=?(ЗначениеЗаполнено(ВыборкаПоБюджету.СуммаСценарияОборотМесяц2),(ВыборкаПоБюджету.СуммаСценарияОборотМесяц2),"0,00");
ОбластьСтрокаТабл.Параметры.РазностьС2иС1=?(ЗначениеЗаполнено(ВыборкаПоБюджету.Разница),(ВыборкаПоБюджету.Разница),"0,00");
//ОбластьСтрокаТабл.Параметры.РазностьС2иС1=Строка(?(ЗначениеЗаполнено(ВыборкаПоБюджету.СуммаСценарияОборотМесяц2),Число(ВыборкаПоБюджету.СуммаСценарияОборотМесяц2),0)-?(ЗначениеЗаполнено(ВыборкаПоБюджету.СуммаСценарияОборотМесяц1),Число(ВыборкаПоБюджету.СуммаСценарияОборотМесяц1),0));
ОбластьСтрокаТабл.Параметры.Коммент=ВыборкаПоБюджету.Комментарий;


ТабДок.Вывести(ОбластьСтрокаТабл,ВыборкаПоБюджету.Уровень());
ТабДок.Область(ТабДок.ВысотаТаблицы,2,ТабДок.ВысотаТаблицы,24).ЦветФона = цвет;

ТабДок.Область(ТабДок.ВысотаТаблицы,2,ТабДок.ВысотаТаблицы,2).Отступ=ВыборкаПоБюджету.Уровень()*2;
ин=ин+1;
КонецЦикла;
КонецЦикла;
первое че попалось)) а так смотри в типовых ))

Оффлайн Lostuk

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-04
  • Сайт: 
  • Профессия: Ученик 1С
Благодарю!:) Сейчас помучаюсь еще помучаюсь. Второй день уже сижу с этой фигней.:(

Оффлайн Летящий в даль

  • **
  • Сообщений: 56
  • РЕПУТАЦИЯ: 12
  • КПД: 21%
  • 1с - это диагенез :D
  • Регистрация: 2016-05-16
  • Сайт: 
  • Профессия: Программист 1С

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1096
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Кстати, в первом пункте, оно не всегда будет "ложь".

у вас что, в табличной части в колонке "Номенклатура" может быть группа?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Lostuk

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-04
  • Сайт: 
  • Профессия: Ученик 1С
Так ничего и не получилось. Может кто сможет помочь в скайпе?
Добавлено: 04 Авг 2016, 16:08

Почему после выполнения данного запроса, все значения NULL?

Запрос.Текст = 
"ВЫБРАТЬ
| НомерСтроки КАК Номер,
| Номенклатура,
| Номенклатура.Родитель КАК Родитель,
| Номенклатура.НаименованиеПолное КАК ТоварНаименование,
| Номенклатура." + ТоварКод + "   КАК ТоварКод,
| ЕдиницаИзмерения.Представление  КАК ЕдиницаИзмеренияНаименование,
| ЕдиницаИзмерения.ЕдиницаПоКлассификатору.Код КАК ЕдиницаИзмеренияКодПоОКЕИ,
| Количество                     КАК ФактКоличество,
| КоличествоУчет                 КАК БухКоличество,
| ВЫБОР
| КОГДА Ссылка.Склад.ВидСклада = &ВидСкладаНТТ ТОГДА ЦенаВРознице
| ИНАЧЕ Цена * &Курс / &Кратность
| КОНЕЦ КАК Цена,
| ВЫБОР
| КОГДА Ссылка.Склад.ВидСклада = &ВидСкладаНТТ ТОГДА Количество * ЦенаВРознице
| ИНАЧЕ Сумма * &Курс / &Кратность
| КОНЕЦ КАК ФактСумма,
| ВЫБОР
| КОГДА Ссылка.Склад.ВидСклада = &ВидСкладаНТТ ТОГДА КоличествоУчет *ЦенаВРознице
| ИНАЧЕ СуммаУчет * &Курс / &Кратность
| КОНЕЦ КАК БухСумма,
| ХарактеристикаНоменклатуры     КАК Характеристика,
| СерияНоменклатуры КАК Серия
|ИЗ
| Документ.ИнвентаризацияТоваровНаСкладе.Товары КАК Товары
|
|ГДЕ
| Товары.Ссылка = &ТекущийДокумент
| И (Товары.Количество - Товары.КоличествоУчет) <> 0
|
|УПОРЯДОЧИТЬ ПО
|Товары.Номенклатура.Родитель";
|ИТОГИ ПО ОБЩИЕ,
|    Номенклатура ИЕРАРХИЯ";

Последний раз редактировалось: Lostuk; 04 Авг 2016, 16:08. Причина: Объединение сообщений


Теги:
 

Группа "СписокКомпоновщикНастроекПользовательскиеНастройки" в форме "Перечисления"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1104
Последний ответ 12 Ноя 2016, 18:08
от Азамат Хубиев
"фильтрация" номенклатуры

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 12
Просмотров: 6084
Последний ответ 11 Мар 2014, 16:09
от mashencev_anton
Ребята, срочно нужна помощь. Какую процедуру нужно написать в форме справочника, чтобы таблица заполнялась данными из другого справочника?

Автор Олька БякинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 1911
Последний ответ 27 Май 2016, 15:19
от Олька Бякина
Номенклатуры типов "расход" и "услуга. Как использовать?

Автор joyerРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 2287
Последний ответ 29 Июн 2011, 21:11
от joyer
Модуль к форме "Настройка заполнения"

Автор oyufedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3870
Последний ответ 17 Янв 2014, 16:35
от oyufed

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
150 Сообщений
alex0402
109 Сообщений
MuI_I_Ika MuI_I_Ika
53 Сообщений
Norfolk
51 Сообщений
LexaK
48 Сообщений
AsadRoman
27 Сообщений
SlimShady
22 Сообщений
друган
21 Сообщений
alexandr_ll
19 Сообщений
Константин5825
17 Сообщений

* Кто онлайн

  • Точка Гостей: 809
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal