Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Июл 2017, 15:31
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Сумма и ствака НДС  (Прочитано 364 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн cozac.eric

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-01
  • Сайт: 
  • Профессия: Программист 1С
Помогите подсчитать сумму НДС и общую сумму
Написал код но сказали переделать

Вот код:

Процедура ТоварСтавкиНДСПриИзменении(Элемент)

ТекущиеДанные = Элементы.Товар.ТекущиеДанные;


Если ТекущиеДанные.СтавкиНДС = ПредопределенноеЗначение("Перечисление.СтавкиНДС.НДС20") тогда
ТекущиеДанные.СуммаНДС = ТекущиеДанные.Количество * ТекущиеДанные.Цена/100 * 20



ИначеЕсли ТекущиеДанные.СтавкиНДС = ПредопределенноеЗначение("Перечисление.СтавкиНДС.НДС6") тогда
ТекущиеДанные.СуммаНДС = ТекущиеДанные.Количество * ТекущиеДанные.Цена/100 * 6


ИначеЕсли ТекущиеДанные.СтавкиНДС = ПредопределенноеЗначение("Перечисление.СтавкиНДС.БезНДС") тогда
ТекущиеДанные.СуммаНДС = 0


КонецЕсли;
ТекущиеДанные.Итого = ТекущиеДанные.Сумма + ТекущиеДанные.СуммаНДС;
КонецПроцедуры


Оффлайн cozac.eric

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-01
  • Сайт: 
  • Профессия: Программист 1С
Сказали сделать задавая общее условие чтобы при изменении ставки ндс не изменять код а чтобы процедура сама высчитала
я сам не очень понял поэтому и спрашиваю может кто-то чем то поможет

Онлайн LexaK

  • *****
  • Сообщений: 1246
  • РЕПУТАЦИЯ: 344
  • КПД: 28%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
все правильно вам сказали, вы все свои ставки НДС забили в коде, при появлении новой ставки вам надо будет изменять код расчета суммы НДС.
самое простое это подсмотреть как "Большой брат" это делает.

или вот подсказка.
когда у вас меняется ставка ндс в ТЧ
не надо писать кучу если, просто обработайте ставку НДС функцией, код будет примерно такой, функцию СтавкаНДС() напишите сами
она должна возвращать число
для 20% - 0.2
для 18% - 0.18
... и т.д.

вроде все понятно
Процедура ТоварСтавкиНДСПриИзменении(Элемент)

    ТекущиеДанные = Элементы.Товар.ТекущиеДанные;
    ТекущиеДанные.СуммаНДС = ТекущиеДанные.Сумма * СтавкаНДС(ТекущиеДанные.СтавкиНДС);
    ТекущиеДанные.Итого = ТекущиеДанные.Сумма + ТекущиеДанные.СуммаНДС;

КонецПроцедуры

заметили как сильно изменился ваш предыдущий код? ;)
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн cozac.eric

  • *
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-01
  • Сайт: 
  • Профессия: Программист 1С
Спасибо большое помогли


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
93 Сообщений
alex0402
93 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
64 Сообщений
Golickoff Golickoff
51 Сообщений
ilyay ilyay
45 Сообщений
AIFrame
41 Сообщений
wise wise
31 Сообщений
Амал
30 Сообщений
ab30ru
24 Сообщений
lansy
22 Сообщений

* Кто онлайн

  • Точка Гостей: 967
  • Точка Скрытых: 0
  • Точка Пользователей: 19
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal