Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Июн 2021, 01:19
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Вывести 2 табличной части на ПФ документа  (Прочитано 2672 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Space_minus

  • **
  • Регистрация: 2016-03-17
  • Сообщений: 98
  • РЕПУТАЦИЯ: 0
  • Профессия: Ученик 1С
На форме есть 2 табличной части, подскажите как правильно их выводить!

Как только я не извращался, не получилось адекватно их вывести

&НаСервере
Функция ПечатьЗаявка (МассивОбъектов,ОбъектыПечати)
ТабДок = Новый ТабличныйДокумент;
ТабДок.АвтоМасштаб = Истина;
ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Портрет;

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ЗаявкаВГИБДД.ДолжностьГИБДД.Наименование КАК ДолжностьГИБДД,
| ЗаявкаВГИБДД.СотрудникГИБДД.Наименование КАК СотрудникГИБДД,
| ЗаявкаВГИБДД.Сотрудник.Наименование КАК Сотрудник,
| ЗаявкаВГИБДД.Должность.Наименование КАК Должность,
| ЗаявкаВГИБДД.ПриказОЗачислении.Номер КАК НомерПриказа,
| ЗаявкаВГИБДД.ПриказОЗачислении.Дата КАК ДатаПриказа,
| ЗаявкаВГИБДДМастера.ФИО_Мастера КАК ФИО_Преподователя,
| ЗаявкаВГИБДДПреподователи.ФИО_Преподователя КАК ФИО_Мастера,
| КОЛИЧЕСТВО(ВложенныйЗапрос.Студент) КАК Студент,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Дата_Поступления КАК ДатаПоступления,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.ДатаОкончанияОбучения КАК ДатаОкончанияОбучения,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Наименование КАК Группа,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Специальность.Категория.Наименование КАК Категория,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.КолличествоЛюдейВГруппе КАК КолличествоЛюдейВГруппе,
| ЗаявкаВГИБДД.Ссылка
|ИЗ
| Документ.ЗаявкаВГИБДД КАК ЗаявкаВГИБДД
| ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ РАЗЛИЧНЫЕ
| КОЛИЧЕСТВО(ДвижениеКонтингентаСрезПоследних.Студент) КАК Студент,
| ДвижениеКонтингентаСрезПоследних.Группа КАК Группа
| ИЗ
| РегистрСведений.ДвижениеКонтингента.СрезПоследних КАК ДвижениеКонтингентаСрезПоследних
|
| СГРУППИРОВАТЬ ПО
| ДвижениеКонтингентаСрезПоследних.Группа) КАК ВложенныйЗапрос
| ПО ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа = ВложенныйЗапрос.Группа
| ЛЕВОЕ СОЕДИНЕНИЕ Документ.ЗаявкаВГИБДД.Преподователи КАК ЗаявкаВГИБДДПреподователи
| ПО ЗаявкаВГИБДД.Ссылка = ЗаявкаВГИБДДПреподователи.Ссылка
| ЛЕВОЕ СОЕДИНЕНИЕ Документ.ЗаявкаВГИБДД.Мастера КАК ЗаявкаВГИБДДМастера
| ПО ЗаявкаВГИБДД.Ссылка = ЗаявкаВГИБДДМастера.Ссылка
|ГДЕ
| ЗаявкаВГИБДД.Ссылка В(&МассивОбъектов)
|
|СГРУППИРОВАТЬ ПО
| ЗаявкаВГИБДД.ДолжностьГИБДД.Наименование,
| ЗаявкаВГИБДД.СотрудникГИБДД.Наименование,
| ЗаявкаВГИБДД.Сотрудник.Наименование,
| ЗаявкаВГИБДД.Должность.Наименование,
| ЗаявкаВГИБДД.ПриказОЗачислении.Номер,
| ЗаявкаВГИБДД.ПриказОЗачислении.Дата,
| ЗаявкаВГИБДДМастера.ФИО_Мастера,
| ЗаявкаВГИБДДПреподователи.ФИО_Преподователя,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Дата_Поступления,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.ДатаОкончанияОбучения,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Наименование,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Специальность.Категория.Наименование,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.КолличествоЛюдейВГруппе,
| ЗаявкаВГИБДД.Ссылка";


Запрос.УстановитьПараметр("МассивОбъектов",МассивОбъектов);
РезультатЗапроса = Запрос.Выполнить().Выбрать();
Макет = ПолучитьМакет("Заявка");

ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
РезультатЗапроса.Следующий();
ОбластьМакета.Параметры.Заполнить(РезультатЗапроса);
РезультатЗапроса.Сбросить();
ТабДок.Вывести(ОбластьМакета);

ОбластьМакета = Макет.ПолучитьОбласть("Абзац1");
РезультатЗапроса.Следующий();
ОбластьМакета.Параметры.Абзац1 = "        Прошу Вас зарегистрировать группу № "+РезультатЗапроса.Группа+" категории «"+РезультатЗапроса.Категория+"»  колличестве "+РезультатЗапроса.КолличествоЛюдейВГруппе+" чел";
РезультатЗапроса.Сбросить();
ТабДок.Вывести(ОбластьМакета);

ОбластьМакета = Макет.ПолучитьОбласть("Адрес");
РезультатЗапроса.Следующий();
ОбластьМакета.Параметры.Заполнить(РезультатЗапроса);
РезультатЗапроса.Сбросить();
ТабДок.Вывести(ОбластьМакета);

ОбластьМакета = Макет.ПолучитьОбласть("Занятия");
РезультатЗапроса.Следующий();
ОбластьМакета.Параметры.Заполнить(РезультатЗапроса);
РезультатЗапроса.Сбросить();
ТабДок.Вывести(ОбластьМакета);

ОбластьМакета=Макет.ПолучитьОбласть("Преподователи");
ОбластьМакета.Параметры.Заполнить(РезультатЗапроса);
ТабДок.Вывести(ОбластьМакета);

Пока РезультатЗапроса.Следующий() Цикл
ОбластьМакета=Макет.ПолучитьОбласть("СписокПреподователей");
ОбластьМакета.Параметры.Заполнить(РезультатЗапроса);
ТабДок.Вывести(ОбластьМакета);
КонецЦикла;
    РезультатЗапроса.Сбросить();

ОбластьМакета = Макет.ПолучитьОбласть("Мастера");
ОбластьМакета.Параметры.Заполнить(РезультатЗапроса);
ТабДок.Вывести(ОбластьМакета);

ОбластьМакета=Макет.ПолучитьОбласть("СписокМастеров");
ОбластьМакета.Параметры.Заполнить(РезультатЗапроса);
ТабДок.Вывести(ОбластьМакета);

ОбластьМакета = Макет.ПолучитьОбласть("Приказ");
ОбластьМакета.Параметры.Заполнить(РезультатЗапроса);
ТабДок.Вывести(ОбластьМакета);

ОбластьМакета = Макет.ПолучитьОбласть("Подвал");
ОбластьМакета.Параметры.Заполнить(РезультатЗапроса);
ТабДок.Вывести(ОбластьМакета);

//ОбластьМакета.Параметры.Сотрудник = ФамилияИнициалыФизЛица(Выборка.Сотрудник);

//УправлениеПечатью.ЗадатьОбластьПечатиДокумента(ТабДок,
//НомерСтрокиНачало, ОбъектыПечати, РезультатЗапроса.Ссылка);

Возврат ТабДок;
КонецФункции //Заявка



Оффлайн Space_minus

  • **
  • Регистрация: 2016-03-17
  • Сообщений: 98
  • РЕПУТАЦИЯ: 0
  • Профессия: Ученик 1С
Засунул две табличные части СписокПреподователей и СписокМастеров в цикл. Фигня получается
Пока РезультатЗапроса.Следующий() Цикл
ОбластьМакета=Макет.ПолучитьОбласть("СписокПреподователей");
ОбластьМакета.Параметры.Заполнить(РезультатЗапроса);
ТабДок.Вывести(ОбластьМакета);
КонецЦикла;

    РезультатЗапроса.Сбросить();

ОбластьМакета = Макет.ПолучитьОбласть("Мастера");
ОбластьМакета.Параметры.Заполнить(РезультатЗапроса);
ТабДок.Вывести(ОбластьМакета);

РезультатЗапроса.Сбросить();

Пока РезультатЗапроса.Следующий() Цикл
 
ОбластьМакета=Макет.ПолучитьОбласть("СписокМастеров");
ОбластьМакета.Параметры.Заполнить(РезультатЗапроса);
ТабДок.Вывести(ОбластьМакета);
КонецЦикла;



Оффлайн cska-fanat-kz

  • 1С:Специалист
  • *****
  • Регистрация: 2010-11-06
  • Сообщений: 5748
  • РЕПУТАЦИЯ: 1105
  • КПД: 19%
  • Красная армия всех сильней!
    • Skype: cska-fanat-kz81
  • Профессия: Разработчик 1С
это типа правильный ответ?

можно и не присоединять в запросе табличные части Преподов и Мастеров, а получить их через ссылку.

мТекДок = РезультатЗапроса.Ссылка;
Для каждого СтрокаТЧ Из мТекДок.Преподователи Цикл
        ОбластьМакета=Макет.ПолучитьОбласть("СписокПреподователей");
        ОбластьМакета.Параметры.Заполнить(СтрокаТЧ);
        ТабДок.Вывести(ОбластьМакета);
    КонецЦикла;
   
        ОбластьМакета = Макет.ПолучитьОбласть("Мастера");
        ОбластьМакета.Параметры.Заполнить(РезультатЗапроса);
        ТабДок.Вывести(ОбластьМакета);
         
        для каждого СтрокаТЧ Из мТекДок.Мастера Цикл
 
        ОбластьМакета=Макет.ПолучитьОбласть("СписокМастеров");
        ОбластьМакета.Параметры.Заполнить(СтрокаТЧ);
        ТабДок.Вывести(ОбластьМакета);
         КонецЦикла;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Space_minus

  • **
  • Регистрация: 2016-03-17
  • Сообщений: 98
  • РЕПУТАЦИЯ: 0
  • Профессия: Ученик 1С
Не, это все я не правильные мои попытки привел, нужно получить такие же данные как и на самой табличной части формы документа
Добавлено: 02 Авг 2016, 11:10


Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • *****
  • Регистрация: 2010-08-20
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Профессия: Программист 1С
Такое левое соединение прокатит только если табличная часть одна, с двумя получается не то - строки размножаются. Лучше всего разделить на три запроса, например так:
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    ЗаявкаВГИБДД.ДолжностьГИБДД.Наименование КАК ДолжностьГИБДД,
        |    ЗаявкаВГИБДД.СотрудникГИБДД.Наименование КАК СотрудникГИБДД,
        |    ЗаявкаВГИБДД.Сотрудник.Наименование КАК Сотрудник,
        |    ЗаявкаВГИБДД.Должность.Наименование КАК Должность,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.Номер КАК НомерПриказа,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.Дата КАК ДатаПриказа,
        |    КОЛИЧЕСТВО(ВложенныйЗапрос.Студент) КАК Студент,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Дата_Поступления КАК ДатаПоступления,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.ДатаОкончанияОбучения КАК ДатаОкончанияОбучения,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Наименование КАК Группа,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Специальность.Категория.Наименование КАК Категория,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.КолличествоЛюдейВГруппе КАК КолличествоЛюдейВГруппе,
        |    ЗаявкаВГИБДД.Ссылка
        |ИЗ
        |    Документ.ЗаявкаВГИБДД КАК ЗаявкаВГИБДД
        |        ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ РАЗЛИЧНЫЕ
        |            КОЛИЧЕСТВО(ДвижениеКонтингентаСрезПоследних.Студент) КАК Студент,
        |            ДвижениеКонтингентаСрезПоследних.Группа КАК Группа
        |        ИЗ
        |            РегистрСведений.ДвижениеКонтингента.СрезПоследних КАК ДвижениеКонтингентаСрезПоследних
        |       
        |        СГРУППИРОВАТЬ ПО
        |            ДвижениеКонтингентаСрезПоследних.Группа) КАК ВложенныйЗапрос
        |        ПО ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа = ВложенныйЗапрос.Группа
        |ГДЕ
        |    ЗаявкаВГИБДД.Ссылка В(&МассивОбъектов)
        |
        |СГРУППИРОВАТЬ ПО
        |    ЗаявкаВГИБДД.ДолжностьГИБДД.Наименование,
        |    ЗаявкаВГИБДД.СотрудникГИБДД.Наименование,
        |    ЗаявкаВГИБДД.Сотрудник.Наименование,
        |    ЗаявкаВГИБДД.Должность.Наименование,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.Номер,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.Дата,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Дата_Поступления,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.ДатаОкончанияОбучения,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Наименование,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Специальность.Категория.Наименование,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.КолличествоЛюдейВГруппе,
        |    ЗаявкаВГИБДД.Ссылка
| ;
|
|////////////////////////////////////////////////////////////////////////////////
        |ВЫБРАТЬ
|    ЗаявкаВГИБДДМастера.Ссылка,
|    ЗаявкаВГИБДДМастера.ФИО_Мастера КАК ФИО_Мастера
        |ИЗ
        |    Документ.ЗаявкаВГИБДД.Мастера КАК ЗаявкаВГИБДДМастера
        |ГДЕ
        |    ЗаявкаВГИБДДМастера.Ссылка В(&МассивОбъектов)
        |
        |СГРУППИРОВАТЬ ПО
        |    ЗаявкаВГИБДДМастера.Ссылка,
        |    ЗаявкаВГИБДДМастера.ФИО_Мастера
| ;
|
|////////////////////////////////////////////////////////////////////////////////
        |ВЫБРАТЬ
        |    ЗаявкаВГИБДДПреподователи.Ссылка,
|    ЗаявкаВГИБДДПреподователи.ФИО_Преподователя КАК ФИО_Преподавателя
        |ИЗ
        |    Документ.ЗаявкаВГИБДД.Преподователи КАК ЗаявкаВГИБДДПреподователи
        |ГДЕ
        |    ЗаявкаВГИБДДПреподователи.Ссылка В(&МассивОбъектов)
        |
        |СГРУППИРОВАТЬ ПО
  |    ЗаявкаВГИБДДПреподователи.Ссылка,
        |    ЗаявкаВГИБДДПреподователи.ФИО_Преподователя";

Запрос.УстановитьПараметр....
      
Дальше только обход пакета:      
Результат = Запрос.ВыполнитьПакет();
ВыборкаОсновная = Результат[0].Выбрать();
ВыборкаМастера = Результат[1].Выбрать();
ВыборкаПреподаватели = Результат[2].Выбрать();
      
Кстати, у вас псевдонимы мастеров и преподавателей перепутались      
      
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • *****
  • Регистрация: 2010-11-06
  • Сообщений: 5748
  • РЕПУТАЦИЯ: 1105
  • КПД: 19%
  • Красная армия всех сильней!
    • Skype: cska-fanat-kz81
  • Профессия: Разработчик 1С
Ну правильно. Потому что у вас "ПреподОватели"! :befhbt:
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Space_minus

  • **
  • Регистрация: 2016-03-17
  • Сообщений: 98
  • РЕПУТАЦИЯ: 0
  • Профессия: Ученик 1С
Ну правильно. Потому что у вас "ПреподОватели"! :befhbt:

Исправлюсь :nhsrm:
Добавлено: 02 Авг 2016, 11:50

Такое левое соединение прокатит только если табличная часть одна, с двумя получается не то - строки размножаются. Лучше всего разделить на три запроса, например так:
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    ЗаявкаВГИБДД.ДолжностьГИБДД.Наименование КАК ДолжностьГИБДД,
        |    ЗаявкаВГИБДД.СотрудникГИБДД.Наименование КАК СотрудникГИБДД,
        |    ЗаявкаВГИБДД.Сотрудник.Наименование КАК Сотрудник,
        |    ЗаявкаВГИБДД.Должность.Наименование КАК Должность,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.Номер КАК НомерПриказа,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.Дата КАК ДатаПриказа,
        |    КОЛИЧЕСТВО(ВложенныйЗапрос.Студент) КАК Студент,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Дата_Поступления КАК ДатаПоступления,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.ДатаОкончанияОбучения КАК ДатаОкончанияОбучения,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Наименование КАК Группа,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Специальность.Категория.Наименование КАК Категория,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.КолличествоЛюдейВГруппе КАК КолличествоЛюдейВГруппе,
        |    ЗаявкаВГИБДД.Ссылка
        |ИЗ
        |    Документ.ЗаявкаВГИБДД КАК ЗаявкаВГИБДД
        |        ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ РАЗЛИЧНЫЕ
        |            КОЛИЧЕСТВО(ДвижениеКонтингентаСрезПоследних.Студент) КАК Студент,
        |            ДвижениеКонтингентаСрезПоследних.Группа КАК Группа
        |        ИЗ
        |            РегистрСведений.ДвижениеКонтингента.СрезПоследних КАК ДвижениеКонтингентаСрезПоследних
        |       
        |        СГРУППИРОВАТЬ ПО
        |            ДвижениеКонтингентаСрезПоследних.Группа) КАК ВложенныйЗапрос
        |        ПО ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа = ВложенныйЗапрос.Группа
        |ГДЕ
        |    ЗаявкаВГИБДД.Ссылка В(&МассивОбъектов)
        |
        |СГРУППИРОВАТЬ ПО
        |    ЗаявкаВГИБДД.ДолжностьГИБДД.Наименование,
        |    ЗаявкаВГИБДД.СотрудникГИБДД.Наименование,
        |    ЗаявкаВГИБДД.Сотрудник.Наименование,
        |    ЗаявкаВГИБДД.Должность.Наименование,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.Номер,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.Дата,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Дата_Поступления,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.ДатаОкончанияОбучения,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Наименование,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Специальность.Категория.Наименование,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.КолличествоЛюдейВГруппе,
        |    ЗаявкаВГИБДД.Ссылка
| ;
|
|////////////////////////////////////////////////////////////////////////////////
        |ВЫБРАТЬ
|    ЗаявкаВГИБДДМастера.Ссылка,
|    ЗаявкаВГИБДДМастера.ФИО_Мастера КАК ФИО_Мастера
        |ИЗ
        |    Документ.ЗаявкаВГИБДД.Мастера КАК ЗаявкаВГИБДДМастера
        |ГДЕ
        |    ЗаявкаВГИБДДМастера.Ссылка В(&МассивОбъектов)
        |
        |СГРУППИРОВАТЬ ПО
        |    ЗаявкаВГИБДДМастера.Ссылка,
        |    ЗаявкаВГИБДДМастера.ФИО_Мастера
| ;
|
|////////////////////////////////////////////////////////////////////////////////
        |ВЫБРАТЬ
        |    ЗаявкаВГИБДДПреподователи.Ссылка,
|    ЗаявкаВГИБДДПреподователи.ФИО_Преподователя КАК ФИО_Преподавателя
        |ИЗ
        |    Документ.ЗаявкаВГИБДД.Преподователи КАК ЗаявкаВГИБДДПреподователи
        |ГДЕ
        |    ЗаявкаВГИБДДПреподователи.Ссылка В(&МассивОбъектов)
        |
        |СГРУППИРОВАТЬ ПО
  |    ЗаявкаВГИБДДПреподователи.Ссылка,
        |    ЗаявкаВГИБДДПреподователи.ФИО_Преподователя";

Запрос.УстановитьПараметр....
      
Дальше только обход пакета:      
Результат = Запрос.ВыполнитьПакет();
ВыборкаОсновная = Результат[0].Выбрать();
ВыборкаМастера = Результат[1].Выбрать();
ВыборкаПреподаватели = Результат[2].Выбрать();
      
Кстати, у вас псевдонимы мастеров и преподавателей перепутались

сделал 3 запроса
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ЗаявкаВГИБДД.ДолжностьГИБДД.Наименование КАК ДолжностьГИБДД,
| ЗаявкаВГИБДД.СотрудникГИБДД.Наименование КАК СотрудникГИБДД,
| ЗаявкаВГИБДД.Сотрудник.Наименование КАК Сотрудник,
| ЗаявкаВГИБДД.Должность.Наименование КАК Должность,
| ЗаявкаВГИБДД.ПриказОЗачислении.Номер КАК НомерПриказа,
| ЗаявкаВГИБДД.ПриказОЗачислении.Дата КАК ДатаПриказа,
| КОЛИЧЕСТВО(ВложенныйЗапрос.Студент) КАК Студент,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Дата_Поступления КАК ДатаПоступления,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.ДатаОкончанияОбучения КАК ДатаОкончанияОбучения,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Наименование КАК Группа,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Специальность.Категория.Наименование КАК Категория,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.КолличествоЛюдейВГруппе КАК КолличествоЛюдейВГруппе,
| ЗаявкаВГИБДД.Ссылка
|ИЗ
| Документ.ЗаявкаВГИБДД КАК ЗаявкаВГИБДД
| ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ РАЗЛИЧНЫЕ
| КОЛИЧЕСТВО(ДвижениеКонтингентаСрезПоследних.Студент) КАК Студент,
| ДвижениеКонтингентаСрезПоследних.Группа КАК Группа
| ИЗ
| РегистрСведений.ДвижениеКонтингента.СрезПоследних КАК ДвижениеКонтингентаСрезПоследних
|
| СГРУППИРОВАТЬ ПО
| ДвижениеКонтингентаСрезПоследних.Группа) КАК ВложенныйЗапрос
| ПО ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа = ВложенныйЗапрос.Группа
|ГДЕ
| ЗаявкаВГИБДД.Ссылка В(&МассивОбъектов)
|
|СГРУППИРОВАТЬ ПО
| ЗаявкаВГИБДД.ДолжностьГИБДД.Наименование,
| ЗаявкаВГИБДД.СотрудникГИБДД.Наименование,
| ЗаявкаВГИБДД.Сотрудник.Наименование,
| ЗаявкаВГИБДД.Должность.Наименование,
| ЗаявкаВГИБДД.ПриказОЗачислении.Номер,
| ЗаявкаВГИБДД.ПриказОЗачислении.Дата,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Дата_Поступления,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.ДатаОкончанияОбучения,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Наименование,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Специальность.Категория.Наименование,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.КолличествоЛюдейВГруппе,
| ЗаявкаВГИБДД.Ссылка";


//////////
"ВЫБРАТЬ
| ЗаявкаВГИБДДПреподователи.ФИО_Преподователя.Наименование КАК ФИО_Преподователя,
| ЗаявкаВГИБДД.Ссылка
|ИЗ
| Документ.ЗаявкаВГИБДД КАК ЗаявкаВГИБДД
| ЛЕВОЕ СОЕДИНЕНИЕ Документ.ЗаявкаВГИБДД.Преподователи КАК ЗаявкаВГИБДДПреподователи
| ПО ЗаявкаВГИБДД.Ссылка = ЗаявкаВГИБДДПреподователи.Ссылка
|ГДЕ
| ЗаявкаВГИБДД.Ссылка В(&МассивОбъектов)
|
|СГРУППИРОВАТЬ ПО
| ЗаявкаВГИБДДПреподователи.ФИО_Преподователя.Наименование,
| ЗаявкаВГИБДД.Ссылка"


//////////
"ВЫБРАТЬ
| ЗаявкаВГИБДД.Ссылка,
| ЗаявкаВГИБДДМастера.ФИО_Мастера.Наименование КАК ФИО_Мастера
|ИЗ
| Документ.ЗаявкаВГИБДД КАК ЗаявкаВГИБДД
| ЛЕВОЕ СОЕДИНЕНИЕ Документ.ЗаявкаВГИБДД.Мастера КАК ЗаявкаВГИБДДМастера
| ПО ЗаявкаВГИБДД.Ссылка = ЗаявкаВГИБДДМастера.Ссылка
|ГДЕ
| ЗаявкаВГИБДД.Ссылка В(&МассивОбъектов)
|
|СГРУППИРОВАТЬ ПО
| ЗаявкаВГИБДД.Ссылка,
| ЗаявкаВГИБДДМастера.ФИО_Мастера.Наименование"


Но не пойму как выводить в ПФ

Последний раз редактировалось: Space_minus; 02 Авг 2016, 11:50. Причина: Объединение сообщений

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • *****
  • Регистрация: 2010-08-20
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Профессия: Программист 1С
Так же, как и раньше, только пользуясь выборками
      Пока ВыборкаМастера.Следующий() Цикл
         ОбластьМакета=Макет.ПолучитьОбласть("СписокМастеров");
        ОбластьМакета.Параметры.Заполнить(ВыборкаМастера);
        ТабДок.Вывести(ОбластьМакета);
         КонецЦикла;
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн Space_minus

  • **
  • Регистрация: 2016-03-17
  • Сообщений: 98
  • РЕПУТАЦИЯ: 0
  • Профессия: Ученик 1С
Так же, как и раньше, только пользуясь выборками
      Пока ВыборкаМастера.Следующий() Цикл
         ОбластьМакета=Макет.ПолучитьОбласть("СписокМастеров");
        ОбластьМакета.Параметры.Заполнить(ВыборкаМастера);
        ТабДок.Вывести(ОбластьМакета);
         КонецЦикла;
Блин, а как выборку присвоить запросу?

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • *****
  • Регистрация: 2010-08-20
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Профессия: Программист 1С
эээ не поняла. я вроде все написала же...
Вот получаем из запроса результат и выборки:
Результат = Запрос.ВыполнитьПакет();
ВыборкаОсновная = Результат[0].Выбрать();
ВыборкаМастера = Результат[1].Выбрать();
ВыборкаПреподаватели = Результат[2].Выбрать();

и дальше каждую из них отдельно используем, как обычную выборку... Из ВыборкаОсновная - все основные реквизиты, из ВыборкаМастера и ВыборкаПреподаватели - ваши табличные части
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать


Теги:
 

Установить доступ к просмотру и редактированию некоторых реквизитов документа

Автор aleon1Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 194
Последний ответ 03 Дек 2020, 14:58
от aleon1
Создание документа "На основании"

Автор Funt ФунтиковРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 207
Последний ответ 24 Апр 2021, 08:54
от LexaK
Как сохранить макет печати документа для переноса и использования на другом компьютере?

Автор zork265Раздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 497
Последний ответ 04 Сен 2019, 14:00
от zork265
Нужна помощь в создании документа

Автор Дарья КрасноваРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 470
Последний ответ 26 Ноя 2019, 12:54
от alexandr_ll
Использование нескольких форм документа

Автор utkin295Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 645
Последний ответ 20 Авг 2018, 15:42
от utkin295

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
65 Сообщений
LexaK
62 Сообщений
antoneus antoneus
31 Сообщений
Ивашка
26 Сообщений
neek666
23 Сообщений
KATERINA 861
19 Сообщений
SSC
15 Сообщений
alexandr_ll
13 Сообщений
Алексей_1985_06
11 Сообщений
pouyo
8 Сообщений

* Кто онлайн

  • Точка Гостей: 173
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск