Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Июл 2017, 09:51
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вывести 2 табличной части на ПФ документа  (Прочитано 1150 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Space_minus

  • **
  • Сообщений: 92
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-03-17
  • Сайт: 
  • Профессия: Ученик 1С
На форме есть 2 табличной части, подскажите как правильно их выводить!

Как только я не извращался, не получилось адекватно их вывести

&НаСервере
Функция ПечатьЗаявка (МассивОбъектов,ОбъектыПечати)
ТабДок = Новый ТабличныйДокумент;
ТабДок.АвтоМасштаб = Истина;
ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Портрет;

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ЗаявкаВГИБДД.ДолжностьГИБДД.Наименование КАК ДолжностьГИБДД,
| ЗаявкаВГИБДД.СотрудникГИБДД.Наименование КАК СотрудникГИБДД,
| ЗаявкаВГИБДД.Сотрудник.Наименование КАК Сотрудник,
| ЗаявкаВГИБДД.Должность.Наименование КАК Должность,
| ЗаявкаВГИБДД.ПриказОЗачислении.Номер КАК НомерПриказа,
| ЗаявкаВГИБДД.ПриказОЗачислении.Дата КАК ДатаПриказа,
| ЗаявкаВГИБДДМастера.ФИО_Мастера КАК ФИО_Преподователя,
| ЗаявкаВГИБДДПреподователи.ФИО_Преподователя КАК ФИО_Мастера,
| КОЛИЧЕСТВО(ВложенныйЗапрос.Студент) КАК Студент,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Дата_Поступления КАК ДатаПоступления,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.ДатаОкончанияОбучения КАК ДатаОкончанияОбучения,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Наименование КАК Группа,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Специальность.Категория.Наименование КАК Категория,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.КолличествоЛюдейВГруппе КАК КолличествоЛюдейВГруппе,
| ЗаявкаВГИБДД.Ссылка
|ИЗ
| Документ.ЗаявкаВГИБДД КАК ЗаявкаВГИБДД
| ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ РАЗЛИЧНЫЕ
| КОЛИЧЕСТВО(ДвижениеКонтингентаСрезПоследних.Студент) КАК Студент,
| ДвижениеКонтингентаСрезПоследних.Группа КАК Группа
| ИЗ
| РегистрСведений.ДвижениеКонтингента.СрезПоследних КАК ДвижениеКонтингентаСрезПоследних
|
| СГРУППИРОВАТЬ ПО
| ДвижениеКонтингентаСрезПоследних.Группа) КАК ВложенныйЗапрос
| ПО ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа = ВложенныйЗапрос.Группа
| ЛЕВОЕ СОЕДИНЕНИЕ Документ.ЗаявкаВГИБДД.Преподователи КАК ЗаявкаВГИБДДПреподователи
| ПО ЗаявкаВГИБДД.Ссылка = ЗаявкаВГИБДДПреподователи.Ссылка
| ЛЕВОЕ СОЕДИНЕНИЕ Документ.ЗаявкаВГИБДД.Мастера КАК ЗаявкаВГИБДДМастера
| ПО ЗаявкаВГИБДД.Ссылка = ЗаявкаВГИБДДМастера.Ссылка
|ГДЕ
| ЗаявкаВГИБДД.Ссылка В(&МассивОбъектов)
|
|СГРУППИРОВАТЬ ПО
| ЗаявкаВГИБДД.ДолжностьГИБДД.Наименование,
| ЗаявкаВГИБДД.СотрудникГИБДД.Наименование,
| ЗаявкаВГИБДД.Сотрудник.Наименование,
| ЗаявкаВГИБДД.Должность.Наименование,
| ЗаявкаВГИБДД.ПриказОЗачислении.Номер,
| ЗаявкаВГИБДД.ПриказОЗачислении.Дата,
| ЗаявкаВГИБДДМастера.ФИО_Мастера,
| ЗаявкаВГИБДДПреподователи.ФИО_Преподователя,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Дата_Поступления,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.ДатаОкончанияОбучения,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Наименование,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Специальность.Категория.Наименование,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.КолличествоЛюдейВГруппе,
| ЗаявкаВГИБДД.Ссылка";


Запрос.УстановитьПараметр("МассивОбъектов",МассивОбъектов);
РезультатЗапроса = Запрос.Выполнить().Выбрать();
Макет = ПолучитьМакет("Заявка");

ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
РезультатЗапроса.Следующий();
ОбластьМакета.Параметры.Заполнить(РезультатЗапроса);
РезультатЗапроса.Сбросить();
ТабДок.Вывести(ОбластьМакета);

ОбластьМакета = Макет.ПолучитьОбласть("Абзац1");
РезультатЗапроса.Следующий();
ОбластьМакета.Параметры.Абзац1 = "        Прошу Вас зарегистрировать группу № "+РезультатЗапроса.Группа+" категории «"+РезультатЗапроса.Категория+"»  колличестве "+РезультатЗапроса.КолличествоЛюдейВГруппе+" чел";
РезультатЗапроса.Сбросить();
ТабДок.Вывести(ОбластьМакета);

ОбластьМакета = Макет.ПолучитьОбласть("Адрес");
РезультатЗапроса.Следующий();
ОбластьМакета.Параметры.Заполнить(РезультатЗапроса);
РезультатЗапроса.Сбросить();
ТабДок.Вывести(ОбластьМакета);

ОбластьМакета = Макет.ПолучитьОбласть("Занятия");
РезультатЗапроса.Следующий();
ОбластьМакета.Параметры.Заполнить(РезультатЗапроса);
РезультатЗапроса.Сбросить();
ТабДок.Вывести(ОбластьМакета);

ОбластьМакета=Макет.ПолучитьОбласть("Преподователи");
ОбластьМакета.Параметры.Заполнить(РезультатЗапроса);
ТабДок.Вывести(ОбластьМакета);

Пока РезультатЗапроса.Следующий() Цикл
ОбластьМакета=Макет.ПолучитьОбласть("СписокПреподователей");
ОбластьМакета.Параметры.Заполнить(РезультатЗапроса);
ТабДок.Вывести(ОбластьМакета);
КонецЦикла;
    РезультатЗапроса.Сбросить();

ОбластьМакета = Макет.ПолучитьОбласть("Мастера");
ОбластьМакета.Параметры.Заполнить(РезультатЗапроса);
ТабДок.Вывести(ОбластьМакета);

ОбластьМакета=Макет.ПолучитьОбласть("СписокМастеров");
ОбластьМакета.Параметры.Заполнить(РезультатЗапроса);
ТабДок.Вывести(ОбластьМакета);

ОбластьМакета = Макет.ПолучитьОбласть("Приказ");
ОбластьМакета.Параметры.Заполнить(РезультатЗапроса);
ТабДок.Вывести(ОбластьМакета);

ОбластьМакета = Макет.ПолучитьОбласть("Подвал");
ОбластьМакета.Параметры.Заполнить(РезультатЗапроса);
ТабДок.Вывести(ОбластьМакета);

//ОбластьМакета.Параметры.Сотрудник = ФамилияИнициалыФизЛица(Выборка.Сотрудник);

//УправлениеПечатью.ЗадатьОбластьПечатиДокумента(ТабДок,
//НомерСтрокиНачало, ОбъектыПечати, РезультатЗапроса.Ссылка);

Возврат ТабДок;
КонецФункции //Заявка



Оффлайн Space_minus

  • **
  • Сообщений: 92
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-03-17
  • Сайт: 
  • Профессия: Ученик 1С
Засунул две табличные части СписокПреподователей и СписокМастеров в цикл. Фигня получается
Пока РезультатЗапроса.Следующий() Цикл
ОбластьМакета=Макет.ПолучитьОбласть("СписокПреподователей");
ОбластьМакета.Параметры.Заполнить(РезультатЗапроса);
ТабДок.Вывести(ОбластьМакета);
КонецЦикла;

    РезультатЗапроса.Сбросить();

ОбластьМакета = Макет.ПолучитьОбласть("Мастера");
ОбластьМакета.Параметры.Заполнить(РезультатЗапроса);
ТабДок.Вывести(ОбластьМакета);

РезультатЗапроса.Сбросить();

Пока РезультатЗапроса.Следующий() Цикл
 
ОбластьМакета=Макет.ПолучитьОбласть("СписокМастеров");
ОбластьМакета.Параметры.Заполнить(РезультатЗапроса);
ТабДок.Вывести(ОбластьМакета);
КонецЦикла;



Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
это типа правильный ответ?

можно и не присоединять в запросе табличные части Преподов и Мастеров, а получить их через ссылку.

мТекДок = РезультатЗапроса.Ссылка;
Для каждого СтрокаТЧ Из мТекДок.Преподователи Цикл
        ОбластьМакета=Макет.ПолучитьОбласть("СписокПреподователей");
        ОбластьМакета.Параметры.Заполнить(СтрокаТЧ);
        ТабДок.Вывести(ОбластьМакета);
    КонецЦикла;
   
        ОбластьМакета = Макет.ПолучитьОбласть("Мастера");
        ОбластьМакета.Параметры.Заполнить(РезультатЗапроса);
        ТабДок.Вывести(ОбластьМакета);
         
        для каждого СтрокаТЧ Из мТекДок.Мастера Цикл
 
        ОбластьМакета=Макет.ПолучитьОбласть("СписокМастеров");
        ОбластьМакета.Параметры.Заполнить(СтрокаТЧ);
        ТабДок.Вывести(ОбластьМакета);
         КонецЦикла;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Space_minus

  • **
  • Сообщений: 92
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-03-17
  • Сайт: 
  • Профессия: Ученик 1С
Не, это все я не правильные мои попытки привел, нужно получить такие же данные как и на самой табличной части формы документа
Добавлено: 02 Авг 2016, 11:10


Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Такое левое соединение прокатит только если табличная часть одна, с двумя получается не то - строки размножаются. Лучше всего разделить на три запроса, например так:
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    ЗаявкаВГИБДД.ДолжностьГИБДД.Наименование КАК ДолжностьГИБДД,
        |    ЗаявкаВГИБДД.СотрудникГИБДД.Наименование КАК СотрудникГИБДД,
        |    ЗаявкаВГИБДД.Сотрудник.Наименование КАК Сотрудник,
        |    ЗаявкаВГИБДД.Должность.Наименование КАК Должность,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.Номер КАК НомерПриказа,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.Дата КАК ДатаПриказа,
        |    КОЛИЧЕСТВО(ВложенныйЗапрос.Студент) КАК Студент,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Дата_Поступления КАК ДатаПоступления,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.ДатаОкончанияОбучения КАК ДатаОкончанияОбучения,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Наименование КАК Группа,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Специальность.Категория.Наименование КАК Категория,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.КолличествоЛюдейВГруппе КАК КолличествоЛюдейВГруппе,
        |    ЗаявкаВГИБДД.Ссылка
        |ИЗ
        |    Документ.ЗаявкаВГИБДД КАК ЗаявкаВГИБДД
        |        ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ РАЗЛИЧНЫЕ
        |            КОЛИЧЕСТВО(ДвижениеКонтингентаСрезПоследних.Студент) КАК Студент,
        |            ДвижениеКонтингентаСрезПоследних.Группа КАК Группа
        |        ИЗ
        |            РегистрСведений.ДвижениеКонтингента.СрезПоследних КАК ДвижениеКонтингентаСрезПоследних
        |       
        |        СГРУППИРОВАТЬ ПО
        |            ДвижениеКонтингентаСрезПоследних.Группа) КАК ВложенныйЗапрос
        |        ПО ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа = ВложенныйЗапрос.Группа
        |ГДЕ
        |    ЗаявкаВГИБДД.Ссылка В(&МассивОбъектов)
        |
        |СГРУППИРОВАТЬ ПО
        |    ЗаявкаВГИБДД.ДолжностьГИБДД.Наименование,
        |    ЗаявкаВГИБДД.СотрудникГИБДД.Наименование,
        |    ЗаявкаВГИБДД.Сотрудник.Наименование,
        |    ЗаявкаВГИБДД.Должность.Наименование,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.Номер,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.Дата,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Дата_Поступления,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.ДатаОкончанияОбучения,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Наименование,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Специальность.Категория.Наименование,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.КолличествоЛюдейВГруппе,
        |    ЗаявкаВГИБДД.Ссылка
| ;
|
|////////////////////////////////////////////////////////////////////////////////
        |ВЫБРАТЬ
|    ЗаявкаВГИБДДМастера.Ссылка,
|    ЗаявкаВГИБДДМастера.ФИО_Мастера КАК ФИО_Мастера
        |ИЗ
        |    Документ.ЗаявкаВГИБДД.Мастера КАК ЗаявкаВГИБДДМастера
        |ГДЕ
        |    ЗаявкаВГИБДДМастера.Ссылка В(&МассивОбъектов)
        |
        |СГРУППИРОВАТЬ ПО
        |    ЗаявкаВГИБДДМастера.Ссылка,
        |    ЗаявкаВГИБДДМастера.ФИО_Мастера
| ;
|
|////////////////////////////////////////////////////////////////////////////////
        |ВЫБРАТЬ
        |    ЗаявкаВГИБДДПреподователи.Ссылка,
|    ЗаявкаВГИБДДПреподователи.ФИО_Преподователя КАК ФИО_Преподавателя
        |ИЗ
        |    Документ.ЗаявкаВГИБДД.Преподователи КАК ЗаявкаВГИБДДПреподователи
        |ГДЕ
        |    ЗаявкаВГИБДДПреподователи.Ссылка В(&МассивОбъектов)
        |
        |СГРУППИРОВАТЬ ПО
  |    ЗаявкаВГИБДДПреподователи.Ссылка,
        |    ЗаявкаВГИБДДПреподователи.ФИО_Преподователя";

Запрос.УстановитьПараметр....
      
Дальше только обход пакета:      
Результат = Запрос.ВыполнитьПакет();
ВыборкаОсновная = Результат[0].Выбрать();
ВыборкаМастера = Результат[1].Выбрать();
ВыборкаПреподаватели = Результат[2].Выбрать();
      
Кстати, у вас псевдонимы мастеров и преподавателей перепутались      
      
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Ну правильно. Потому что у вас "ПреподОватели"! :befhbt:
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Space_minus

  • **
  • Сообщений: 92
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-03-17
  • Сайт: 
  • Профессия: Ученик 1С
Ну правильно. Потому что у вас "ПреподОватели"! :befhbt:

Исправлюсь :nhsrm:
Добавлено: 02 Авг 2016, 11:50

Такое левое соединение прокатит только если табличная часть одна, с двумя получается не то - строки размножаются. Лучше всего разделить на три запроса, например так:
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    ЗаявкаВГИБДД.ДолжностьГИБДД.Наименование КАК ДолжностьГИБДД,
        |    ЗаявкаВГИБДД.СотрудникГИБДД.Наименование КАК СотрудникГИБДД,
        |    ЗаявкаВГИБДД.Сотрудник.Наименование КАК Сотрудник,
        |    ЗаявкаВГИБДД.Должность.Наименование КАК Должность,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.Номер КАК НомерПриказа,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.Дата КАК ДатаПриказа,
        |    КОЛИЧЕСТВО(ВложенныйЗапрос.Студент) КАК Студент,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Дата_Поступления КАК ДатаПоступления,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.ДатаОкончанияОбучения КАК ДатаОкончанияОбучения,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Наименование КАК Группа,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Специальность.Категория.Наименование КАК Категория,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.КолличествоЛюдейВГруппе КАК КолличествоЛюдейВГруппе,
        |    ЗаявкаВГИБДД.Ссылка
        |ИЗ
        |    Документ.ЗаявкаВГИБДД КАК ЗаявкаВГИБДД
        |        ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ РАЗЛИЧНЫЕ
        |            КОЛИЧЕСТВО(ДвижениеКонтингентаСрезПоследних.Студент) КАК Студент,
        |            ДвижениеКонтингентаСрезПоследних.Группа КАК Группа
        |        ИЗ
        |            РегистрСведений.ДвижениеКонтингента.СрезПоследних КАК ДвижениеКонтингентаСрезПоследних
        |       
        |        СГРУППИРОВАТЬ ПО
        |            ДвижениеКонтингентаСрезПоследних.Группа) КАК ВложенныйЗапрос
        |        ПО ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа = ВложенныйЗапрос.Группа
        |ГДЕ
        |    ЗаявкаВГИБДД.Ссылка В(&МассивОбъектов)
        |
        |СГРУППИРОВАТЬ ПО
        |    ЗаявкаВГИБДД.ДолжностьГИБДД.Наименование,
        |    ЗаявкаВГИБДД.СотрудникГИБДД.Наименование,
        |    ЗаявкаВГИБДД.Сотрудник.Наименование,
        |    ЗаявкаВГИБДД.Должность.Наименование,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.Номер,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.Дата,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Дата_Поступления,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.ДатаОкончанияОбучения,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Наименование,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Специальность.Категория.Наименование,
        |    ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.КолличествоЛюдейВГруппе,
        |    ЗаявкаВГИБДД.Ссылка
| ;
|
|////////////////////////////////////////////////////////////////////////////////
        |ВЫБРАТЬ
|    ЗаявкаВГИБДДМастера.Ссылка,
|    ЗаявкаВГИБДДМастера.ФИО_Мастера КАК ФИО_Мастера
        |ИЗ
        |    Документ.ЗаявкаВГИБДД.Мастера КАК ЗаявкаВГИБДДМастера
        |ГДЕ
        |    ЗаявкаВГИБДДМастера.Ссылка В(&МассивОбъектов)
        |
        |СГРУППИРОВАТЬ ПО
        |    ЗаявкаВГИБДДМастера.Ссылка,
        |    ЗаявкаВГИБДДМастера.ФИО_Мастера
| ;
|
|////////////////////////////////////////////////////////////////////////////////
        |ВЫБРАТЬ
        |    ЗаявкаВГИБДДПреподователи.Ссылка,
|    ЗаявкаВГИБДДПреподователи.ФИО_Преподователя КАК ФИО_Преподавателя
        |ИЗ
        |    Документ.ЗаявкаВГИБДД.Преподователи КАК ЗаявкаВГИБДДПреподователи
        |ГДЕ
        |    ЗаявкаВГИБДДПреподователи.Ссылка В(&МассивОбъектов)
        |
        |СГРУППИРОВАТЬ ПО
  |    ЗаявкаВГИБДДПреподователи.Ссылка,
        |    ЗаявкаВГИБДДПреподователи.ФИО_Преподователя";

Запрос.УстановитьПараметр....
      
Дальше только обход пакета:      
Результат = Запрос.ВыполнитьПакет();
ВыборкаОсновная = Результат[0].Выбрать();
ВыборкаМастера = Результат[1].Выбрать();
ВыборкаПреподаватели = Результат[2].Выбрать();
      
Кстати, у вас псевдонимы мастеров и преподавателей перепутались

сделал 3 запроса
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ЗаявкаВГИБДД.ДолжностьГИБДД.Наименование КАК ДолжностьГИБДД,
| ЗаявкаВГИБДД.СотрудникГИБДД.Наименование КАК СотрудникГИБДД,
| ЗаявкаВГИБДД.Сотрудник.Наименование КАК Сотрудник,
| ЗаявкаВГИБДД.Должность.Наименование КАК Должность,
| ЗаявкаВГИБДД.ПриказОЗачислении.Номер КАК НомерПриказа,
| ЗаявкаВГИБДД.ПриказОЗачислении.Дата КАК ДатаПриказа,
| КОЛИЧЕСТВО(ВложенныйЗапрос.Студент) КАК Студент,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Дата_Поступления КАК ДатаПоступления,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.ДатаОкончанияОбучения КАК ДатаОкончанияОбучения,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Наименование КАК Группа,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Специальность.Категория.Наименование КАК Категория,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.КолличествоЛюдейВГруппе КАК КолличествоЛюдейВГруппе,
| ЗаявкаВГИБДД.Ссылка
|ИЗ
| Документ.ЗаявкаВГИБДД КАК ЗаявкаВГИБДД
| ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ РАЗЛИЧНЫЕ
| КОЛИЧЕСТВО(ДвижениеКонтингентаСрезПоследних.Студент) КАК Студент,
| ДвижениеКонтингентаСрезПоследних.Группа КАК Группа
| ИЗ
| РегистрСведений.ДвижениеКонтингента.СрезПоследних КАК ДвижениеКонтингентаСрезПоследних
|
| СГРУППИРОВАТЬ ПО
| ДвижениеКонтингентаСрезПоследних.Группа) КАК ВложенныйЗапрос
| ПО ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа = ВложенныйЗапрос.Группа
|ГДЕ
| ЗаявкаВГИБДД.Ссылка В(&МассивОбъектов)
|
|СГРУППИРОВАТЬ ПО
| ЗаявкаВГИБДД.ДолжностьГИБДД.Наименование,
| ЗаявкаВГИБДД.СотрудникГИБДД.Наименование,
| ЗаявкаВГИБДД.Сотрудник.Наименование,
| ЗаявкаВГИБДД.Должность.Наименование,
| ЗаявкаВГИБДД.ПриказОЗачислении.Номер,
| ЗаявкаВГИБДД.ПриказОЗачислении.Дата,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Дата_Поступления,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.ДатаОкончанияОбучения,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Наименование,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.Специальность.Категория.Наименование,
| ЗаявкаВГИБДД.ПриказОЗачислении.УчебнаяГруппа.КолличествоЛюдейВГруппе,
| ЗаявкаВГИБДД.Ссылка";


//////////
"ВЫБРАТЬ
| ЗаявкаВГИБДДПреподователи.ФИО_Преподователя.Наименование КАК ФИО_Преподователя,
| ЗаявкаВГИБДД.Ссылка
|ИЗ
| Документ.ЗаявкаВГИБДД КАК ЗаявкаВГИБДД
| ЛЕВОЕ СОЕДИНЕНИЕ Документ.ЗаявкаВГИБДД.Преподователи КАК ЗаявкаВГИБДДПреподователи
| ПО ЗаявкаВГИБДД.Ссылка = ЗаявкаВГИБДДПреподователи.Ссылка
|ГДЕ
| ЗаявкаВГИБДД.Ссылка В(&МассивОбъектов)
|
|СГРУППИРОВАТЬ ПО
| ЗаявкаВГИБДДПреподователи.ФИО_Преподователя.Наименование,
| ЗаявкаВГИБДД.Ссылка"


//////////
"ВЫБРАТЬ
| ЗаявкаВГИБДД.Ссылка,
| ЗаявкаВГИБДДМастера.ФИО_Мастера.Наименование КАК ФИО_Мастера
|ИЗ
| Документ.ЗаявкаВГИБДД КАК ЗаявкаВГИБДД
| ЛЕВОЕ СОЕДИНЕНИЕ Документ.ЗаявкаВГИБДД.Мастера КАК ЗаявкаВГИБДДМастера
| ПО ЗаявкаВГИБДД.Ссылка = ЗаявкаВГИБДДМастера.Ссылка
|ГДЕ
| ЗаявкаВГИБДД.Ссылка В(&МассивОбъектов)
|
|СГРУППИРОВАТЬ ПО
| ЗаявкаВГИБДД.Ссылка,
| ЗаявкаВГИБДДМастера.ФИО_Мастера.Наименование"


Но не пойму как выводить в ПФ

Последний раз редактировалось: Space_minus; 02 Авг 2016, 11:50. Причина: Объединение сообщений

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Так же, как и раньше, только пользуясь выборками
      Пока ВыборкаМастера.Следующий() Цикл
         ОбластьМакета=Макет.ПолучитьОбласть("СписокМастеров");
        ОбластьМакета.Параметры.Заполнить(ВыборкаМастера);
        ТабДок.Вывести(ОбластьМакета);
         КонецЦикла;
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн Space_minus

  • **
  • Сообщений: 92
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-03-17
  • Сайт: 
  • Профессия: Ученик 1С
Так же, как и раньше, только пользуясь выборками
      Пока ВыборкаМастера.Следующий() Цикл
         ОбластьМакета=Макет.ПолучитьОбласть("СписокМастеров");
        ОбластьМакета.Параметры.Заполнить(ВыборкаМастера);
        ТабДок.Вывести(ОбластьМакета);
         КонецЦикла;
Блин, а как выборку присвоить запросу?

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
эээ не поняла. я вроде все написала же...
Вот получаем из запроса результат и выборки:
Результат = Запрос.ВыполнитьПакет();
ВыборкаОсновная = Результат[0].Выбрать();
ВыборкаМастера = Результат[1].Выбрать();
ВыборкаПреподаватели = Результат[2].Выбрать();

и дальше каждую из них отдельно используем, как обычную выборку... Из ВыборкаОсновная - все основные реквизиты, из ВыборкаМастера и ВыборкаПреподаватели - ваши табличные части
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4189
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7225
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4271
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 7221
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 6874
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
116 Сообщений
alex0402
102 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
73 Сообщений
AIFrame
50 Сообщений
ilyay ilyay
49 Сообщений
Golickoff Golickoff
49 Сообщений
ab30ru
38 Сообщений
wise wise
34 Сообщений
Амал
30 Сообщений
lansy
22 Сообщений

* Кто онлайн

  • Точка Гостей: 221
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal