Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Июл 2017, 07:36
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Значение не является значением объектного типа (НастройкиСтраницыМакета)  (Прочитано 444 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн viru1978

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-02
  • Сайт: 
  • Профессия: Ученик 1С
дело в том что мне нужно сделать так чтобы программа выводила акт приемки передачи в ворде, для это я скопировал команду ПечатьКоммерческоеПредложениеMicrosoftWord и назвал ПечатьАктПриемаПередачиMicrosoftWord и в самом модуле поменял это

МакетИДанныеОбъекта = УправлениеПечатьюВызовСервера.ПолучитьМакетыИДанныеОбъектов("Документ.КоммерческоеПредложениеКлиенту",

    "КоммерческоеПредложение(MSWord)",
    СтруктураДокументыИВариант);
   
    Для Каждого ДокументСсылка Из ПараметрКоманды Цикл
        НапечататьСчетНаОплатуПокупателю(ДокументСсылка, МакетИДанныеОбъекта, "КоммерческоеПредложение(MSWord)", МакетИДанныеОбъекта.ЛокальныйКаталогФайловПечати);
    КонецЦикла;

на это

МакетИДанныеОбъекта = УправлениеПечатьюВызовСервера.ПолучитьМакетыИДанныеОбъектов("Документ.КоммерческоеПредложениеКлиенту",
    "АктПриемаПередачи(MSWord)",
    СтруктураДокументыИВариант);
   
    Для Каждого ДокументСсылка Из ПараметрКоманды Цикл
        НапечататьСчетНаОплатуПокупателю(ДокументСсылка, МакетИДанныеОбъекта, "АктПриемаПередачи(MSWord)", МакетИДанныеОбъекта.ЛокальныйКаталогФайловПечати);
    КонецЦикла;

В итоге выводит ошибку которую я указал в названии темы


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Глобальным поиском ищем то, что вы написали в названии темы...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн viru1978

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-02
  • Сайт: 
  • Профессия: Ученик 1С
Глобальным поиском ищем то, что вы написали в названии темы...

Искал, ничиго похожего не находит. Именно чего касается моего вопроса

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
я имел ввиду ищем "НастройкиСтраницыМакета"
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн viru1978

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-02
  • Сайт: 
  • Профессия: Ученик 1С
я имел ввиду ищем "НастройкиСтраницыМакета"

Глобальный поиск находит только твой ответ и больше ничиго (

Оффлайн Летящий в даль

  • **
  • Сообщений: 56
  • РЕПУТАЦИЯ: 12
  • КПД: 21%
  • 1с - это диагенез :D
  • Регистрация: 2016-05-16
  • Сайт: 
  • Профессия: Программист 1С

МакетИДанныеОбъекта = УправлениеПечатьюВызовСервера.ПолучитьМакетыИДанныеОбъектов("Документ.КоммерческоеПредложениеКлиенту",
    "АктПриемаПередачи(MSWord)",
    СтруктураДокументыИВариант);
   
    Для Каждого ДокументСсылка Из ПараметрКоманды Цикл
        НапечататьСчетНаОплатуПокупателю(ДокументСсылка, МакетИДанныеОбъекта, "АктПриемаПередачи(MSWord)", МакетИДанныеОбъекта.ЛокальныйКаталогФайловПечати);
    КонецЦикла;

В итоге выводит ошибку которую я указал в названии темы
Добавлено: 02 Авг 2016, 14:57

Мне так кажется что для этого нужно не просто заменить одно на другое, а реально прописать процедуру вывода акта в ворд<_<


Теги:
 

Значение "00000000001" поля "Код" не уникально

Автор gigsonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 5713
Последний ответ 24 Ноя 2014, 12:21
от gigson
Значение поля "Владелец" не заполнено или заполнено неверно

Автор ReclaimРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2446
Последний ответ 16 Ноя 2015, 09:36
от cska-fanat-kz
Как в СКД вычислить значение ресурса для группировки по значениям ресурса нижестоящей группировки

Автор ОтцовскийРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 647
Последний ответ 23 Ноя 2016, 12:53
от sertak
как получить значение реквизита "Код" в обработке "ПодборНоменклатуры" в УТ10.3

Автор JalibРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 806
Последний ответ 02 Дек 2016, 12:58
от Jalib
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 7209
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
122 Сообщений
alex0402
104 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
73 Сообщений
ilyay ilyay
50 Сообщений
Golickoff Golickoff
49 Сообщений
AIFrame
46 Сообщений
ab30ru
38 Сообщений
wise wise
36 Сообщений
Амал
32 Сообщений
Dethmontt Dethmontt
25 Сообщений

* Кто онлайн

  • Точка Гостей: 351
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal