Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Янв 2017, 04:35
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Запрет на проведение документа  (Прочитано 1132 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн gm35

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-29
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте, подскажите есть справочник с клиентами в нем есть форма в которой есть объект Черный список: да или нет. Есть документ в строке которого указывается клиент. Как сделать так что если клиент в черном списке то есть да, документ не будет проводиться а будет выдавать ошибку.

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1095
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
в ОбработкаПроведения()
Если Контрагент.ЧерныйСписок Тогда
    Отказ = ИСТИНА;
КонецЕсли;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн gm35

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-29
  • Сайт: 
  • Профессия: Программист 1С
в ОбработкаПроведения()
Если Контрагент.ЧерныйСписок Тогда
    Отказ = ИСТИНА;
КонецЕсли;
Правильно ли я вам объясняю вот скрины как у меня в базе
http://pixs.ru/showimage/43234png_9895674_22791952.png
http://pixs.ru/showimage/5632png_8166875_22791968.png
Процедура ОбработкаПроведения(ДокументЗаселения)
Если Клиент.ЧерныйСписок Тогда
    Отказ = ИСТИНА;
КонецЕсли;
КонецПроцедуры

Добавлено: 02 Авг 2016, 01:18

в ОбработкаПроведения()
Если Контрагент.ЧерныйСписок Тогда
    Отказ = ИСТИНА;
КонецЕсли;
Правильно ли я вам объясняю вот скрины как у меня в базе
http://pixs.ru/showimage/43234png_9895674_22791952.png
http://pixs.ru/showimage/5632png_8166875_22791968.png
Процедура ОбработкаПроведения(ДокументЗаселения)
Если Клиент.ЧерныйСписок Тогда
    Отказ = ИСТИНА;
КонецЕсли;
КонецПроцедуры

или так

Процедура ОбработкаПроведения(ДокументЗаселения)
Если Реквизит.Клиент.СправочникСсылка.Клиенты.Объект.ЧерныйСписок = Да(Да), Тогда
    Отказ = ИСТИНА;
КонецЕсли;
КонецПроцедуры

Последний раз редактировалось: gm35; 02 Авг 2016, 01:18. Причина: Объединение сообщений

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1095
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
1) предполагалось что "ЧерныйСписок" - типа БУЛЕВО! :befhbt:
2) "Если Реквизит.Клиент.СправочникСсылка.Клиенты.Объект.ЧерныйСписок = Да(Да), Тогда"
сами додумались или подсказал кто?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Вам нужно перебором прогнать строки документа, и на каждой строке проверять клиента.
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1095
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Вам нужно перебором прогнать строки документа, и на каждой строке проверять клиента.

шепотом...
у него клиент в шапке
;)
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Есть документ в строке которого указывается клиент.
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1095
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Klyacksa, ТС языками не владеет, Ваше благородие )
скрины показывают обратное.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Ок, я не настаиваю :)
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн gm35

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-29
  • Сайт: 
  • Профессия: Программист 1С
Klyacksa, ТС языками не владеет, Ваше благородие )
скрины показывают обратное.
Я просто новичок в этом деле, делаю под себя. Черный список нужно переделать как Булево?


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3108
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 12648
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2591
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4837
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2888
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
155 Сообщений
alex0402
74 Сообщений
alexandr_ll
38 Сообщений
crow1983
31 Сообщений
LexaK
29 Сообщений
MuI_I_Ika MuI_I_Ika
26 Сообщений
sertak sertak
23 Сообщений
BuhRust
18 Сообщений
дфтын дфтын
17 Сообщений
Vzonder
16 Сообщений

* Кто онлайн

  • Точка Гостей: 181
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal