Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Июл 2017, 09:41
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Запрет на проведение документа  (Прочитано 1535 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн gm35

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-29
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте, подскажите есть справочник с клиентами в нем есть форма в которой есть объект Черный список: да или нет. Есть документ в строке которого указывается клиент. Как сделать так что если клиент в черном списке то есть да, документ не будет проводиться а будет выдавать ошибку.


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
в ОбработкаПроведения()
Если Контрагент.ЧерныйСписок Тогда
    Отказ = ИСТИНА;
КонецЕсли;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн gm35

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-29
  • Сайт: 
  • Профессия: Программист 1С
в ОбработкаПроведения()
Если Контрагент.ЧерныйСписок Тогда
    Отказ = ИСТИНА;
КонецЕсли;
Правильно ли я вам объясняю вот скрины как у меня в базе
http://pixs.ru/showimage/43234png_9895674_22791952.png
http://pixs.ru/showimage/5632png_8166875_22791968.png
Процедура ОбработкаПроведения(ДокументЗаселения)
Если Клиент.ЧерныйСписок Тогда
    Отказ = ИСТИНА;
КонецЕсли;
КонецПроцедуры

Добавлено: 02 Авг 2016, 01:18

в ОбработкаПроведения()
Если Контрагент.ЧерныйСписок Тогда
    Отказ = ИСТИНА;
КонецЕсли;
Правильно ли я вам объясняю вот скрины как у меня в базе
http://pixs.ru/showimage/43234png_9895674_22791952.png
http://pixs.ru/showimage/5632png_8166875_22791968.png
Процедура ОбработкаПроведения(ДокументЗаселения)
Если Клиент.ЧерныйСписок Тогда
    Отказ = ИСТИНА;
КонецЕсли;
КонецПроцедуры

или так

Процедура ОбработкаПроведения(ДокументЗаселения)
Если Реквизит.Клиент.СправочникСсылка.Клиенты.Объект.ЧерныйСписок = Да(Да), Тогда
    Отказ = ИСТИНА;
КонецЕсли;
КонецПроцедуры

Последний раз редактировалось: gm35; 02 Авг 2016, 01:18. Причина: Объединение сообщений

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
1) предполагалось что "ЧерныйСписок" - типа БУЛЕВО! :befhbt:
2) "Если Реквизит.Клиент.СправочникСсылка.Клиенты.Объект.ЧерныйСписок = Да(Да), Тогда"
сами додумались или подсказал кто?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Вам нужно перебором прогнать строки документа, и на каждой строке проверять клиента.
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Вам нужно перебором прогнать строки документа, и на каждой строке проверять клиента.

шепотом...
у него клиент в шапке
;)
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Есть документ в строке которого указывается клиент.
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Klyacksa, ТС языками не владеет, Ваше благородие )
скрины показывают обратное.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Ок, я не настаиваю :)
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн gm35

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-29
  • Сайт: 
  • Профессия: Программист 1С
Klyacksa, ТС языками не владеет, Ваше благородие )
скрины показывают обратное.
Я просто новичок в этом деле, делаю под себя. Черный список нужно переделать как Булево?


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4193
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 14682
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3771
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 300
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7232
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alex0402
91 Сообщений
oleg-x
83 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
67 Сообщений
Golickoff Golickoff
51 Сообщений
ilyay ilyay
44 Сообщений
AIFrame
42 Сообщений
Амал
30 Сообщений
Dethmontt Dethmontt
22 Сообщений
lansy
22 Сообщений
xproh
21 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal