Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
30 Май 2017, 06:11
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Условие даты в запросе  (Прочитано 822 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн RoDi

  • *
  • Сообщений: 37
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-07-05
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте, очередной глупый вопрос, который я уверен легко решается, но не мной, столкнулся с проблемой, что в запросе не работает условие даты вот код:
Процедура КнопкаВыполнитьНажатие(Кнопка)


МассивКлассовМетаданных = Новый Массив;
МассивКлассовМетаданных.Добавить("Документы");
Для каждого КлассМетаданных Из МассивКлассовМетаданных Цикл

Для Каждого ОбъектМетаданных Из Метаданные[КлассМетаданных] Цикл

   
    Запрос = Новый Запрос();
 Запрос.УстановитьПараметр("Дата",'20160101');

          Запрос = Новый Запрос;
 
Запрос.Текст =
"ВЫБРАТЬ

| "+ОбъектМетаданных.Имя+".Ссылка
|ИЗ
| Документ."+ОбъектМетаданных.Имя+" КАК "+ОбъектМетаданных.Имя+"
|ГДЕ
|    "+ОбъектМетаданных.Имя+".Дата>&Дата и
| "+ОбъектМетаданных.Имя+".Номер В
| (ВЫБРАТЬ
| Список.Номер
| ИЗ
| (ВЫБРАТЬ
| "+ОбъектМетаданных.Имя+".Номер КАК Номер,
| КОЛИЧЕСТВО("+ОбъектМетаданных.Имя+".Номер) КАК Количество
| ИЗ
| Документ."+ОбъектМетаданных.Имя+" КАК "+ОбъектМетаданных.Имя+"
| СГРУППИРОВАТЬ ПО
| "+ОбъектМетаданных.Имя+".Номер
| ) КАК Список
| ГДЕ
| Список.Количество > 1)";

Запрос.УстановитьПараметр("Дата",'20160101');
Результат = Запрос.Выполнить().Выгрузить();


   

Таблица = ЭлементыФормы.ТЗ;
Таблица.Значение = Результат;
Таблица.СоздатьКолонки();
Для каждого ТекущаяСтрока из ТЗ цикл

Сообщить((ОбъектМетаданных.Имя)+" "+(ТекущаяСтрока.Ссылка.Номер));

КонецЦикла 
КонецЦикла;
КонецЦикла;
 
КонецПроцедуры
Тоесть программа находит документы с одинаковыми номерами, но не только за 2016 год, а за все года


Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
У вас запрос выбирает документы за 2016 год, но при этом номера определяются за весь период.

Оффлайн RoDi

  • *
  • Сообщений: 37
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-07-05
  • Сайт: 
  • Профессия: Программист 1С
Не подскажите как поступить в данной ситуации?

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Я же вам писала запрос целиком в другой ветке!
Вам нужно во вложенном запросе тоже ограничение по дате поставить.
И вместо двойного вложения используйте конструкцию ИМЕЮЩИЕ (в моем ответе используется)
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн RoDi

  • *
  • Сообщений: 37
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-07-05
  • Сайт: 
  • Профессия: Программист 1С
если ты мне найдешь это сообщение, тоя я больше никогда не буду заниматься 1С, просто потому что вы его не писали!!!
Добавлено: 01 Авг 2016, 15:32

я не нахожу вашего сообщения нигде обсалютно

Онлайн Kironten

  • *****
  • Сообщений: 795
  • РЕПУТАЦИЯ: 169
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
если ты мне найдешь это сообщение, тоя я больше никогда не буду заниматься 1С, просто потому что вы его не писали!!!
Добавлено: 01 Авг 2016, 15:32

я не нахожу вашего сообщения нигде обсалютно

cska-fanat-kz, лучше бы заметил, что во внешнем запросе тоже надо отбор по дате ставить, иначе могут попасться документы других периодов.
ВЫБРАТЬ
 "+НужныйДокумент+".Ссылка
ИЗ
 Документ."+ НужныйДокумент+" КАК "+ НужныйДокумент+"   
ГДЕ
 "+ НужныйДокумент+".Номер В
          (ВЫБРАТЬ
               "+ НужныйДокумент+".Номер КАК Номер,
              КОЛИЧЕСТВО("+ НужныйДокумент+".Номер) КАК Количество
              ИЗ  Документ."+ НужныйДокумент+" КАК "+ НужныйДокумент+"
              ГДЕ
                  "+ НужныйДокумент+".Дата >= ДатаВремя(2016,1,1)
                  и "+ НужныйДокумент+".Дата <= ДатаВремя(2016,12,31)
             СГРУППИРОВАТЬ ПО
             "+ НужныйДокумент+".Номер
            ИМЕЮЩИЕ
            КОЛИЧЕСТВО("+ НужныйДокумент+".Номер)>1)
и
  "+ НужныйДокумент+".Дата >= ДатаВремя(2016,1,1)
 и "+ НужныйДокумент+".Дата <= ДатаВремя(2016,12,31)

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Kironten, :ooifh:
Ну зачем, теперь человек не будет никогда 1С заниматься.
RoDi, зачем столько агрессии? У вас почти правильный запрос, немного условий на периоды добавить и все будет корректно работать. Можно и с вложенными запросами оставить.
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн RoDi

  • *
  • Сообщений: 37
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-07-05
  • Сайт: 
  • Профессия: Программист 1С
Вооооот вот это я понимаю, спасибо всё прописал код с датой в нужные места теперь всё идеально работает)
Добавлено: 01 Авг 2016, 15:48

клякса, это не вы мне писали запрос

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
клякса, это не вы мне писали запрос
Да лааааадно! Чо, правда, что ли? А внимательней посмотреть?
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Онлайн Kironten

  • *****
  • Сообщений: 795
  • РЕПУТАЦИЯ: 169
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
клякса, это не вы мне писали запрос
:xfbnsdfb: Эм.... Ну воообще то это она писала.
Ну да ладно. Не хотите - не верьте. Я не настаиваю :D


Теги:
 

Получить номер недели в месяце в запросе [номер недели]

Автор MuI_I_IkaРаздел Алгоритмы

Ответов: 0
Просмотров: 3110
Последний ответ 15 Июл 2015, 18:24
от MuI_I_Ika
РС "СостояниеОСОрганизаций" в запросе

Автор ILLUMIРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 906
Последний ответ 07 Янв 2015, 05:33
от ILLUMI
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1566
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Поле не найдено" в запросе, но оно есть.

Автор ferrari314Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1825
Последний ответ 27 Окт 2015, 10:29
от vitasw
Оставить в запросе только те поля, у которых тип значение "Номенклатура"

Автор DirecTwiXРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 2933
Последний ответ 16 Апр 2012, 02:00
от DirecTwiX

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
89 Сообщений
wise wise
68 Сообщений
MuI_I_Ika MuI_I_Ika
51 Сообщений
alex0402
49 Сообщений
Dethmontt Dethmontt
48 Сообщений
Сергей Федоров Сергей Федоров
29 Сообщений
ilyay ilyay
28 Сообщений
ilnur75
25 Сообщений
Дмитрий Медведков Дмитрий Медведков
19 Сообщений
DmitriyF DmitriyF
17 Сообщений

* Кто онлайн

  • Точка Гостей: 348
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal