Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 21:05
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: План счетов  (Прочитано 1692 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sasha198407

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-24
  • Сайт: 
      Доброго времени суток. Поставили задачу. Что бы один из пользователей в 1С7.7Бухгалтерия имел доступ к Справочники->Материалы, Журналы->Учет материалов, Отчёты->Оборотно-сальдовая ведомость по счеты. Ну, не вопрос мы создали нового пользователя и для него соответствующий интерфейс, а также права. А дальше интересно, надо что бы этот пользователь видел и мог работать только с счетми 10, 20.0, 26.0, 60.1, 91.2. А, у нас получается только либо видет всё, либо просматривает, но тоже всё. Что делать?


Оффлайн Mitay_D

  • **
  • Сообщений: 85
  • РЕПУТАЦИЯ: 14
  • КПД: 16%
  • Регистрация: 2011-02-02
  • Сайт: 
  • Профессия: Программист 7.7
Re: План счетов
« Ответ #1: 03 Фев 2011, 11:00 »
можно в модуле отчета в процедуре
Процедура ПриВыбореСчета()
. написать условие
Если НазваниеНабораПрав() = "Урезанные" Тогда
// вы не можете выбрать этот счет
КонецЕсли

Оффлайн Mitay_D

  • **
  • Сообщений: 85
  • РЕПУТАЦИЯ: 14
  • КПД: 16%
  • Регистрация: 2011-02-02
  • Сайт: 
  • Профессия: Программист 7.7
Re: План счетов
« Ответ #2: 03 Фев 2011, 11:42 »
Если НазваниеНабораПрав() = "Манагер" Тогда    
Если (Счет.ПолнНаименование = "Материалы") или (Счет.ПолнНаименование = "Сырье и материалы")  Тогда
Сообщить("Не имеете право");
Счет = "";
КонецЕсли;
КонецЕсли;
вот мой пример


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
69 Сообщений
alex0402
54 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 273
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal