Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 июн 2021, 07:47

Вывод на печать объектов по ссылкам

Автор Paranoik0007, 28 июл 2016, 17:08

0 Пользователей и 1 гость просматривают эту тему.

Paranoik0007

Добрый день! помогите пожалуйста реализовать решение:
Редакция 3.0 (3.0.43.252), внешняя обработка, формируется список, получаю ссылки на полученные объекты, при нажатии на команду нужно вывести на печать все объекты каждой строки. Ткните пальцем где копать, уже весь интернет облазил... я надеялся что всё будет просто, наподобие ...ПолучитьОбъект().Печать("названиемакета")... а на деле всё слишком замудрёно надо делать... :dfbsdfbsdf:

Процедура, на которой остановился:

&НаСервере
Процедура ПечатьДокументовЛИЦНаСервере()
Для каждого Строка из Объект.СписокЗагружаемыхДокументовЛИЦ Цикл
Если ЗначениеЗаполнено(Строка.Документ) И ЗначениеЗаполнено(Строка.ДокументСФ) И ЗначениеЗаполнено(Строка.ДокументСчет) Тогда Иначе Продолжить КонецЕсли;
Документ = Строка.Документ.ПолучитьОбъект();
ДокументСФ = Строка.ДокументСФ.ПолучитьОбъект();
ДокументСчет = Строка.ДокументСчет.ПолучитьОбъект();
//ФормаДокумента = Документ.ПолучитьФорму("Документ.РеализацияТоваровУслуг.ФормаОбъекта");
//ФормаДокументаСФ = ДокументСФ.ПолучитьФорму("Документ.СчетФактураВыданный.ФормаОбъекта");
//ФормаДокументаСчет = ДокументСчет.ПолучитьФорму("Документ.СчетНаОплатуПокупателю.ФормаОбъекта");
КонеЦцикла;
КонецПроцедуры

cska-fanat-kz

пока на уровне теории...

в 3.0 процедуры печати - это не процедуры в модуле объекта как было раньше,
а процедуры модуля менеджера.
то есть вызывать их надо что то вроде
    ДОкументы.Реализация.Печать(<<МассивСсылокНаРеализации>>);
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Paranoik0007

Друзья, пытаюсь вывести вот таким кодом:

&НаСервере

Процедура ПечатьДокументовЛИЦНаСервере()

Для каждого Строка из Объект.СписокЗагружаемыхДокументовЛИЦ Цикл

Если ЗначениеЗаполнено(Строка.Документ) И ЗначениеЗаполнено(Строка.ДокументСФ) И ЗначениеЗаполнено(Строка.ДокументСчет) Тогда Иначе Продолжить КонецЕсли;

Документ = Строка.Документ.ПолучитьОбъект();

ДокументСФ = Строка.ДокументСФ.ПолучитьОбъект();

ДокументСчет = Строка.ДокументСчет.ПолучитьОбъект();

//потом печатаем акты

МассивДокумента = Новый Массив();

МассивДокумента.Добавить(Документ);

ПараметрыПечати = Новый Структура;

КоллекцияПечатныхФормДокумента = Новый ТаблицаЗначений;

КоллекцияПечатныхФормДокумента.Колонки.Добавить("ИмяВРЕГ");

КоллекцияПечатныхФормДокумента.Колонки.Добавить("ИмяМакета");

КоллекцияПечатныхФормДокумента.Колонки.Добавить("ИмяФайлаПечатнойФормы");

КоллекцияПечатныхФормДокумента.Колонки.Добавить("Картинка");

КоллекцияПечатныхФормДокумента.Колонки.Добавить("Экземпляров");

КоллекцияПечатныхФормДокумента.Колонки.Добавить("ПолныйПутьКМакету");

КоллекцияПечатныхФормДокумента.Колонки.Добавить("СинонимМакета");

КоллекцияПечатныхФормДокумента.Колонки.Добавить("ТабличныйДокумент");

КоллекцияПечатныхФормДокументаСтрока = КоллекцияПечатныхФормДокумента.Добавить();

КоллекцияПечатныхФормДокументаСтрока.ИмяВРЕГ = "Акт";

КоллекцияПечатныхФормДокументаСтрока.ИмяМакета = "Акт";

КоллекцияПечатныхФормДокументаСтрока.Экземпляров = 2;

КоллекцияПечатныхФормДокументаТабДок = КоллекцияПечатныхФормДокумента.Получить(0).ТабличныйДокумент;

КоллекцияПечатныхФормДокументаТабДок.Напечатать(РежимИспользованияДиалогаПечати.НеИспользовать);

ОбъектыПечатиДокумента = Новый СписокЗначений;

ПараметрыВыводаДокумента = Новый Структура("ДоступнаПечатьПоКомплектно,ПараметрыОтправки");

ПараметрыВыводаДокумента.ПараметрыОтправки = Новый Структура("Получатель,Текст,Тема");

//и вот наконец выводим все параметры на печать...

Документы.РеализацияТоваровУслуг.Печать(МассивДокумента, ПараметрыПечати, КоллекцияПечатныхФормДокумента, ОбъектыПечатиДокумента, ПараметрыВыводаДокумента)

КонеЦцикла;

КонецПроцедуры





И в итоге выдает вот такую ошибку, не могу понять что не так....

{Форма.Форма.Форма(847)}: Значение не является значением объектного типа (Напечатать)

КоллекцияПечатныхФормДокументаТабДок.Напечатать(РежимИспользованияДиалогаПечати.НеИспользовать);







что это может быть?

Kironten

Цитата: Paranoik0007 от 01 авг 2016, 15:59
И в итоге выдает вот такую ошибку, не могу понять что не так....

{Форма.Форма.Форма(847)}: Значение не является значением объектного типа (Напечатать)

КоллекцияПечатныхФормДокументаТабДок.Напечатать(РежимИспользованияДиалогаПечати.НеИспользовать);

что это может быть?

Как минимум ошибка тут:
КоллекцияПечатныхФормДокументаТабДок = КоллекцияПечатныхФормДокумента.Получить(0).ТабличныйДокумент;
Вы пытаетесь получить значение из колонки "ТабличныйДокумент", а вы его туда до этого помещали?

Paranoik0007

Думаю эти две строки вообще не нужны
А если их убрать то всё равно не печатает, ничего не происходит вообще...
по шагам, вижу что заходит на перебор имения макета,  и нужный макет проскакивает. и в итоге ничего не происходит. не пойму как заставить е\е работать...


вот это "если", процедура Печать проскакивает....

Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "Акт") Тогда
ТаблицаСведенийАктаОбОказанииУслуг = ПолучитьТаблицуСведенийАктаОбОказанииУслуг(МассивОбъектов);
СтруктураПараметровПечати = Новый Структура;
СтруктураПараметровПечати.Вставить("ВидДокументаПечати",  "РеализацияТоваровУслуг");
СтруктураПараметровПечати.Вставить("ИмяПараметровПечати", "ПАРАМЕТРЫ_ПЕЧАТИ_РеализацияТоваровУслуг_Акт");
СтруктураПараметровПечати.Вставить("ИмяМакетаПечати",     "Документ.РеализацияТоваровУслуг.ПФ_MXL_Акт");
УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "Акт", "Акт об оказании услуг",
ПечатьТорговыхДокументов.ПечатьАктаОбОказанииУслуг(ТаблицаСведенийАктаОбОказанииУслуг, ОбъектыПечати, СтруктураПараметровПечати),,
"Документ.РеализацияТоваровУслуг.ПФ_MXL_Акт");
ПараметрыВывода.Вставить("ФормироватьЭД", Истина);
КонецЕсли;

Kironten

Цитата: Paranoik0007 от 01 авг 2016, 18:32
Думаю эти две строки вообще не нужны
А если их убрать то всё равно не печатает, ничего не происходит вообще...
по шагам, вижу что заходит на перебор имения макета,  и нужный макет проскакивает. и в итоге ничего не происходит. не пойму как заставить е\е работать...


вот это "если", процедура Печать проскакивает....

Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "Акт") Тогда
ТаблицаСведенийАктаОбОказанииУслуг = ПолучитьТаблицуСведенийАктаОбОказанииУслуг(МассивОбъектов);
СтруктураПараметровПечати = Новый Структура;
СтруктураПараметровПечати.Вставить("ВидДокументаПечати",  "РеализацияТоваровУслуг");
СтруктураПараметровПечати.Вставить("ИмяПараметровПечати", "ПАРАМЕТРЫ_ПЕЧАТИ_РеализацияТоваровУслуг_Акт");
СтруктураПараметровПечати.Вставить("ИмяМакетаПечати",     "Документ.РеализацияТоваровУслуг.ПФ_MXL_Акт");
УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "Акт", "Акт об оказании услуг",
ПечатьТорговыхДокументов.ПечатьАктаОбОказанииУслуг(ТаблицаСведенийАктаОбОказанииУслуг, ОбъектыПечати, СтруктураПараметровПечати),,
"Документ.РеализацияТоваровУслуг.ПФ_MXL_Акт");
ПараметрыВывода.Вставить("ФормироватьЭД", Истина);
КонецЕсли;

А я и не говорил, что эти строки нужны.
Вопрос стоял как?
Цитата: Paranoik0007 от 01 авг 2016, 15:59
И в итоге выдает вот такую ошибку, не могу понять что не так....
что это может быть?
Я вам и описал, почему у вас такая ошибка.
По поводу "проскакивает", ну значит в Коллекции печатных форм не найдено "Акт". Поэтому возвращает ложь, и как следствие условие не выполняется.

Теги:

Похожие темы (5)

70476

Ответов: 8
Просмотров: 1108

7922

Ответов: 6
Просмотров: 8935

42152

Ответов: 16
Просмотров: 14729

64065

Ответов: 2
Просмотров: 3467

Рейтинг@Mail.ru Rambler's Top100

Поиск