Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Янв 2017, 02:41
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вывод на печать объектов по ссылкам  (Прочитано 397 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Paranoik0007

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-07-28
  • Сайт: 
  • Профессия: ГлавБух
Добрый день! помогите пожалуйста реализовать решение:
Редакция 3.0 (3.0.43.252), внешняя обработка, формируется список, получаю ссылки на полученные объекты, при нажатии на команду нужно вывести на печать все объекты каждой строки. Ткните пальцем где копать, уже весь интернет облазил... я надеялся что всё будет просто, наподобие ...ПолучитьОбъект().Печать("названиемакета")... а на деле всё слишком замудрёно надо делать... :dfbsdfbsdf:

Процедура, на которой остановился:

&НаСервере
Процедура ПечатьДокументовЛИЦНаСервере()
Для каждого Строка из Объект.СписокЗагружаемыхДокументовЛИЦ Цикл
Если ЗначениеЗаполнено(Строка.Документ) И ЗначениеЗаполнено(Строка.ДокументСФ) И ЗначениеЗаполнено(Строка.ДокументСчет) Тогда Иначе Продолжить КонецЕсли;
Документ = Строка.Документ.ПолучитьОбъект();
ДокументСФ = Строка.ДокументСФ.ПолучитьОбъект();
ДокументСчет = Строка.ДокументСчет.ПолучитьОбъект();
//ФормаДокумента = Документ.ПолучитьФорму("Документ.РеализацияТоваровУслуг.ФормаОбъекта");
//ФормаДокументаСФ = ДокументСФ.ПолучитьФорму("Документ.СчетФактураВыданный.ФормаОбъекта");
//ФормаДокументаСчет = ДокументСчет.ПолучитьФорму("Документ.СчетНаОплатуПокупателю.ФормаОбъекта");
КонеЦцикла;
КонецПроцедуры


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1095
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
пока на уровне теории...

в 3.0 процедуры печати - это не процедуры в модуле объекта как было раньше,
а процедуры модуля менеджера.
то есть вызывать их надо что то вроде
    ДОкументы.Реализация.Печать(<<МассивСсылокНаРеализации>>);
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Paranoik0007

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-07-28
  • Сайт: 
  • Профессия: ГлавБух
Друзья, пытаюсь вывести вот таким кодом:

&НаСервере

Процедура ПечатьДокументовЛИЦНаСервере()

 Для каждого Строка из Объект.СписокЗагружаемыхДокументовЛИЦ Цикл

 Если ЗначениеЗаполнено(Строка.Документ) И ЗначениеЗаполнено(Строка.ДокументСФ) И ЗначениеЗаполнено(Строка.ДокументСчет) Тогда Иначе Продолжить КонецЕсли;

 Документ = Строка.Документ.ПолучитьОбъект();

 ДокументСФ = Строка.ДокументСФ.ПолучитьОбъект();

 ДокументСчет = Строка.ДокументСчет.ПолучитьОбъект();

 //потом печатаем акты

 МассивДокумента = Новый Массив();

 МассивДокумента.Добавить(Документ);

 ПараметрыПечати = Новый Структура;

 КоллекцияПечатныхФормДокумента = Новый ТаблицаЗначений;

 КоллекцияПечатныхФормДокумента.Колонки.Добавить("ИмяВРЕГ");

 КоллекцияПечатныхФормДокумента.Колонки.Добавить("ИмяМакета");

 КоллекцияПечатныхФормДокумента.Колонки.Добавить("ИмяФайлаПечатнойФормы");

 КоллекцияПечатныхФормДокумента.Колонки.Добавить("Картинка");

 КоллекцияПечатныхФормДокумента.Колонки.Добавить("Экземпляров");

 КоллекцияПечатныхФормДокумента.Колонки.Добавить("ПолныйПутьКМакету");

 КоллекцияПечатныхФормДокумента.Колонки.Добавить("СинонимМакета");

 КоллекцияПечатныхФормДокумента.Колонки.Добавить("ТабличныйДокумент");

 КоллекцияПечатныхФормДокументаСтрока = КоллекцияПечатныхФормДокумента.Добавить();

 КоллекцияПечатныхФормДокументаСтрока.ИмяВРЕГ = "Акт";

 КоллекцияПечатныхФормДокументаСтрока.ИмяМакета = "Акт";

 КоллекцияПечатныхФормДокументаСтрока.Экземпляров = 2;

 КоллекцияПечатныхФормДокументаТабДок = КоллекцияПечатныхФормДокумента.Получить(0).ТабличныйДокумент;

 КоллекцияПечатныхФормДокументаТабДок.Напечатать(РежимИспользованияДиалогаПечати.НеИспользовать);

 ОбъектыПечатиДокумента = Новый СписокЗначений;

 ПараметрыВыводаДокумента = Новый Структура("ДоступнаПечатьПоКомплектно,ПараметрыОтправки");

 ПараметрыВыводаДокумента.ПараметрыОтправки = Новый Структура("Получатель,Текст,Тема");

 //и вот наконец выводим все параметры на печать...

 Документы.РеализацияТоваровУслуг.Печать(МассивДокумента, ПараметрыПечати, КоллекцияПечатныхФормДокумента, ОбъектыПечатиДокумента, ПараметрыВыводаДокумента)

 КонеЦцикла;

КонецПроцедуры




И в итоге выдает вот такую ошибку, не могу понять что не так....

{Форма.Форма.Форма(847)}: Значение не является значением объектного типа (Напечатать)

 КоллекцияПечатныхФормДокументаТабДок.Напечатать(РежимИспользованияДиалогаПечати.НеИспользовать);







что это может быть?

Оффлайн Kironten

  • *****
  • Сообщений: 716
  • РЕПУТАЦИЯ: 153
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
И в итоге выдает вот такую ошибку, не могу понять что не так....

{Форма.Форма.Форма(847)}: Значение не является значением объектного типа (Напечатать)

 КоллекцияПечатныхФормДокументаТабДок.Напечатать(РежимИспользованияДиалогаПечати.НеИспользовать);

что это может быть?

Как минимум ошибка тут:
КоллекцияПечатныхФормДокументаТабДок = КоллекцияПечатныхФормДокумента.Получить(0).ТабличныйДокумент;
Вы пытаетесь получить значение из колонки "ТабличныйДокумент", а вы его туда до этого помещали?

Оффлайн Paranoik0007

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-07-28
  • Сайт: 
  • Профессия: ГлавБух
Думаю эти две строки вообще не нужны
А если их убрать то всё равно не печатает, ничего не происходит вообще...
по шагам, вижу что заходит на перебор имения макета,  и нужный макет проскакивает. и в итоге ничего не происходит. не пойму как заставить е\е работать...


вот это "если", процедура Печать проскакивает....

	Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "Акт") Тогда
ТаблицаСведенийАктаОбОказанииУслуг = ПолучитьТаблицуСведенийАктаОбОказанииУслуг(МассивОбъектов);
СтруктураПараметровПечати = Новый Структура;
СтруктураПараметровПечати.Вставить("ВидДокументаПечати",  "РеализацияТоваровУслуг");
СтруктураПараметровПечати.Вставить("ИмяПараметровПечати", "ПАРАМЕТРЫ_ПЕЧАТИ_РеализацияТоваровУслуг_Акт");
СтруктураПараметровПечати.Вставить("ИмяМакетаПечати",     "Документ.РеализацияТоваровУслуг.ПФ_MXL_Акт");
УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "Акт", "Акт об оказании услуг",
ПечатьТорговыхДокументов.ПечатьАктаОбОказанииУслуг(ТаблицаСведенийАктаОбОказанииУслуг, ОбъектыПечати, СтруктураПараметровПечати),,
"Документ.РеализацияТоваровУслуг.ПФ_MXL_Акт");
ПараметрыВывода.Вставить("ФормироватьЭД", Истина);
КонецЕсли;

Оффлайн Kironten

  • *****
  • Сообщений: 716
  • РЕПУТАЦИЯ: 153
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Думаю эти две строки вообще не нужны
А если их убрать то всё равно не печатает, ничего не происходит вообще...
по шагам, вижу что заходит на перебор имения макета,  и нужный макет проскакивает. и в итоге ничего не происходит. не пойму как заставить е\е работать...


вот это "если", процедура Печать проскакивает....

	Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "Акт") Тогда
ТаблицаСведенийАктаОбОказанииУслуг = ПолучитьТаблицуСведенийАктаОбОказанииУслуг(МассивОбъектов);
СтруктураПараметровПечати = Новый Структура;
СтруктураПараметровПечати.Вставить("ВидДокументаПечати",  "РеализацияТоваровУслуг");
СтруктураПараметровПечати.Вставить("ИмяПараметровПечати", "ПАРАМЕТРЫ_ПЕЧАТИ_РеализацияТоваровУслуг_Акт");
СтруктураПараметровПечати.Вставить("ИмяМакетаПечати",     "Документ.РеализацияТоваровУслуг.ПФ_MXL_Акт");
УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "Акт", "Акт об оказании услуг",
ПечатьТорговыхДокументов.ПечатьАктаОбОказанииУслуг(ТаблицаСведенийАктаОбОказанииУслуг, ОбъектыПечати, СтруктураПараметровПечати),,
"Документ.РеализацияТоваровУслуг.ПФ_MXL_Акт");
ПараметрыВывода.Вставить("ФормироватьЭД", Истина);
КонецЕсли;
А я и не говорил, что эти строки нужны.
Вопрос стоял как?
И в итоге выдает вот такую ошибку, не могу понять что не так....
что это может быть?
Я вам и описал, почему у вас такая ошибка.
По поводу "проскакивает", ну значит в Коллекции печатных форм не найдено "Акт". Поэтому возвращает ложь, и как следствие условие не выполняется.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
159 Сообщений
alex0402
63 Сообщений
MuI_I_Ika MuI_I_Ika
47 Сообщений
crow1983
35 Сообщений
LexaK
32 Сообщений
alexandr_ll
30 Сообщений
sertak sertak
25 Сообщений
Vzonder
22 Сообщений
дфтын дфтын
17 Сообщений
BuhRust
17 Сообщений

* Кто онлайн

  • Точка Гостей: 136
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal