Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
20 Сен 2017, 06:53
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Удаление Серий из регистра накопление  (Прочитано 428 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн NIL

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-04-14
  • Сайт: 
  • Профессия: Ученик 1С
Подскажите пожалуйста как мне убрать из записи регистра назначения запись серии причем все остальное надо чтоб не изменилось т.е. удалить только серии.

&НаСервере
Процедура ИзменитьНаСервере()
   Для каждого СтрВыборки Из ТаблицаРегистров Цикл
        Если НЕ СтрВыборки.Пометка Тогда
         Продолжить;
         КонецЕсли;
           НаборЗаписей = РегистрыНакопления.ТоварыНаСкладах.СоздатьНаборЗаписей();
             НаборЗаписей.Отбор.Регистратор.Значение = СтрВыборки.Регистратор;
             НаборЗаписей.Прочитать();
           Для каждого Запись Из НаборЗаписей Цикл
            Запись.Серия = "";
             КонецЦикла;
            НаборЗаписей.Записать();
    КонецЦикла;   
КонецПроцедуры

Вообще как записать пустое значение не в саму запись регистра а именно в серию что использовать NULL или ""
Заранее спасибо


Оффлайн ilnur75

  • ***
  • Сообщений: 111
  • РЕПУТАЦИЯ: 10
  • КПД: 9%
  • Регистрация: 2016-03-13
  • Сайт: 
  • Профессия: Ученик 1С
может поможет
в модуле набора записей регистра накопления ТоварыНаСкладах пропишите обработчик ПередЗаписью

Процедура ПередЗаписью(Отказ, Замещение)
// определение значения документа-регистратора
Документ = ЭтотОбъект.Отбор.Регистратор.Значение;

//обход записей набора записей
Для каждого ТекЗапись Из ЭтотОбъект  Цикл
ТекЗапись.Серия = "";
КонецЦикла; 

КонецПроцедуры


Теги:
 

Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8685
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
Удаление помеченных объектов ("Не удалось записать "Контактная информация"")

Автор SnakeyРаздел Пользователям "1С - Предприятие 8"

Ответов: 5
Просмотров: 6536
Последний ответ 08 Янв 2015, 09:15
от Sanario
Можно ли програмно изменить одну из колонок таблицы формы регистра сведений при создании формы

Автор RassvetniyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1122
Последний ответ 21 Фев 2016, 17:00
от vitasw
Заполнение регистра сведений "Авансы сотрудникам организаций"

Автор rielter_alРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1334
Последний ответ 02 Дек 2015, 11:50
от rielter_al
Верно ли, что при соединении с виртуальной таблицей остатков регистра накопления отбираются остатки по измерениям, перечисленным в условии соединения таблиц?

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 541
Последний ответ 25 Ноя 2016, 11:25
от Zeed

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
174 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
84 Сообщений
alex0402
82 Сообщений
AsadRoman
36 Сообщений
Kironten
34 Сообщений
Golickoff Golickoff
31 Сообщений
ilyay ilyay
30 Сообщений
AIFrame
27 Сообщений
BuhRust
26 Сообщений
Варвар
20 Сообщений

* Кто онлайн

  • Точка Гостей: 364
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal