Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 16:15
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Удаление Серий из регистра накопление  (Прочитано 506 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн NIL

  • *
  • Сообщений: 27
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-04-14
  • Сайт: 
  • Профессия: Ученик 1С
Подскажите пожалуйста как мне убрать из записи регистра назначения запись серии причем все остальное надо чтоб не изменилось т.е. удалить только серии.

&НаСервере
Процедура ИзменитьНаСервере()
   Для каждого СтрВыборки Из ТаблицаРегистров Цикл
        Если НЕ СтрВыборки.Пометка Тогда
         Продолжить;
         КонецЕсли;
           НаборЗаписей = РегистрыНакопления.ТоварыНаСкладах.СоздатьНаборЗаписей();
             НаборЗаписей.Отбор.Регистратор.Значение = СтрВыборки.Регистратор;
             НаборЗаписей.Прочитать();
           Для каждого Запись Из НаборЗаписей Цикл
            Запись.Серия = "";
             КонецЦикла;
            НаборЗаписей.Записать();
    КонецЦикла;   
КонецПроцедуры

Вообще как записать пустое значение не в саму запись регистра а именно в серию что использовать NULL или ""
Заранее спасибо


Оффлайн ilnur75

  • ***
  • Сообщений: 111
  • РЕПУТАЦИЯ: 10
  • КПД: 9%
  • Регистрация: 2016-03-13
  • Сайт: 
  • Профессия: Ученик 1С
может поможет
в модуле набора записей регистра накопления ТоварыНаСкладах пропишите обработчик ПередЗаписью

Процедура ПередЗаписью(Отказ, Замещение)
// определение значения документа-регистратора
Документ = ЭтотОбъект.Отбор.Регистратор.Значение;

//обход записей набора записей
Для каждого ТекЗапись Из ЭтотОбъект  Цикл
ТекЗапись.Серия = "";
КонецЦикла; 

КонецПроцедуры


Теги:
 

Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 9362
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
Удаление помеченных объектов ("Не удалось записать "Контактная информация"")

Автор SnakeyРаздел Пользователям "1С - Предприятие 8"

Ответов: 5
Просмотров: 6981
Последний ответ 08 Янв 2015, 09:15
от Sanario
Можно ли програмно изменить одну из колонок таблицы формы регистра сведений при создании формы

Автор RassvetniyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1293
Последний ответ 21 Фев 2016, 17:00
от vitasw
Запрос к виртуальной таблице регистра накопления: что писать в "Произвольном Выражении"?

Автор Светлана РождественскаяРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 159
Последний ответ 27 Окт 2017, 21:02
от MuI_I_Ika
Заполнение регистра сведений "Авансы сотрудникам организаций"

Автор rielter_alРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1547
Последний ответ 02 Дек 2015, 11:50
от rielter_al

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 249
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal