Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Окт 2017, 17:37
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Подтягивание данных из другого справочника  (Прочитано 1028 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Provodnik

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-16
  • Сайт: 
Здравствуйте.
Не могу решить 2 проблемы
1-
Есть 2 справочника- слушатели и профессии
Для слушателей создана форма группы (см.вложение 02)
на которой есть после выбора профессии и стоимости
Справочник профессии содержит реквизиты - Наименование и стоимость
Как сделать так, чтобы при работе с формой при выборе профессии, автоматически в поле стоимость заносились соответствующие данные из справочника профессии?

2-
Как получить список элементов, который содержит группа? (см.вложение 01)




Оффлайн Provodnik

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-16
  • Сайт: 
Пробовал сделать для первого так:
 
Процедура СтоимостьОбучения();
Объект.СтоимостьОбуч = Справочники.ПрофессииСпецильности.НайтиПоРеквизиту(Объект.СтоимостьОбучения);
 КонецПроцедуры
 

&НаКлиенте
Процедура ПрофессияСпециальностьПриИзменении(Элемент)
СтоимостьОбучения();
КонецПроцедуры
Не прокатило
Здравствуйте.
Не могу решить 2 проблемы
1-
Есть 2 справочника- слушатели и профессии
Для слушателей создана форма группы (см.вложение 02)
на которой есть после выбора профессии и стоимости
Справочник профессии содержит реквизиты - Наименование и стоимость
Как сделать так, чтобы при работе с формой при выборе профессии, автоматически в поле стоимость заносились соответствующие данные из справочника профессии?

2-
Как получить список элементов, который содержит группа? (см.вложение 01)

Оффлайн Fedor_Safonchik

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 8
  • КПД: 17%
  • Регистрация: 2016-06-16
  • Сайт: 
  • Профессия: Ученик 1С
&НаСервере
Процедура СтоимостьОбучения();
     НайденнаяЗаписьВСправочникеПрофессииСпецильности = Справочники.ПрофессииСпецильности.НайтиПоНаименованию(Объект.ПрофессияСпециальность);
           Объект.СтоимостьОбуч = НайденнаяЗаписьВСправочникеПрофессииСпецильности.РеквизитСоСТоимостьюОбученияВСправочнике[ПрофессииСпецильности];
 КонецПроцедуры
 

&НаКлиенте
Процедура ПрофессияСпециальностьПриИзменении(Элемент)
    СтоимостьОбучения();
КонецПроцедуры

Попробуйте конечно так, должно работать, но это всё таки извращение какое-то,

Оффлайн Provodnik

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-16
  • Сайт: 
Благодарю за ответ, но ошибка
{Справочник.Слушатели.Форма.ФормаГруппы.Форма(5)}: Получение элемента по индексу для значения не определено
     Объект.СтоимостьОбуч = НайденЗапВСправочникеПрофСпец.СтоимостьОбучения[Справочники.ПрофессииСпецильности];
&НаСервере
Процедура СтоимостьОбучения();
     НайденнаяЗаписьВСправочникеПрофессииСпецильности = Справочники.ПрофессииСпецильности.НайтиПоНаименованию(Объект.ПрофессияСпециальность);
           Объект.СтоимостьОбуч = НайденнаяЗаписьВСправочникеПрофессииСпецильности.РеквизитСоСТоимостьюОбученияВСправочнике[ПрофессииСпецильности];
 КонецПроцедуры
 

&НаКлиенте
Процедура ПрофессияСпециальностьПриИзменении(Элемент)
    СтоимостьОбучения();
КонецПроцедуры

Попробуйте конечно так, должно работать, но это всё таки извращение какое-то,

Оффлайн Fedor_Safonchik

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 8
  • КПД: 17%
  • Регистрация: 2016-06-16
  • Сайт: 
  • Профессия: Ученик 1С
Объект.СтоимостьОбуч = НайденЗапВСправочникеПрофСпец.СтоимостьОбучения;

Вот так напишите и будет счастье)

Оффлайн Provodnik

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-16
  • Сайт: 
:zebzdr: я определенно счастлив. Спасибо большое
А по второму вопросу ничего не подскажете?
Объект.СтоимостьОбуч = НайденЗапВСправочникеПрофСпец.СтоимостьОбучения;

Вот так напишите и будет счастье)

Оффлайн Fedor_Safonchik

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 8
  • КПД: 17%
  • Регистрация: 2016-06-16
  • Сайт: 
  • Профессия: Ученик 1С
А по второму вопросу ничего не подскажете?

А где Вам необходимо получить список элементов группы ?

Оффлайн Provodnik

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-16
  • Сайт: 
При нажатии на кнопку должен открыться макет, который будет содержать список
Пока добился только этого (см. вложение 03).
Естественно, если выбрать человека то таблица будет заполняться полностью. На скриншоте была выбрана группа
А по второму вопросу ничего не подскажете?

А где Вам необходимо получить список элементов группы ?
Добавлено: 27 Июл 2016, 17:27

Собственно макет
А по второму вопросу ничего не подскажете?

А где Вам необходимо получить список элементов группы ?

Последний раз редактировалось: Provodnik; 27 Июл 2016, 17:27. Причина: Объединение сообщений

Оффлайн Fedor_Safonchik

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 8
  • КПД: 17%
  • Регистрация: 2016-06-16
  • Сайт: 
  • Профессия: Ученик 1С
Я так понимаю, печатная форма была создана конструктором печатных форм,

Можно увидеть код из модуля менеджера ?

Оффлайн Provodnik

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-16
  • Сайт: 
Да, Вы абсолютно правы. Вот код.
Процедура СписокСлушателей(ТабДок, Ссылка) Экспорт
//{{_КОНСТРУКТОР_ПЕЧАТИ(СписокСлушателей)     

Макет = Справочники.Слушатели.ПолучитьМакет("СписокСлушателей");
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Слушатели.ДатаНачала,
| Слушатели.ДатаОкончания,
| Слушатели.Имя,
| Слушатели.Отчество,
| Слушатели.ПаспортДатаВыдачи,
| Слушатели.ПаспортКемВыдан,
| Слушатели.ПаспортНомер,
| Слушатели.ПаспортСерия,
| Слушатели.Преподаватель,
| Слушатели.ПрофессияСпециальность,
| Слушатели.Телефон,
| Слушатели.Фамилия,
| Слушатели.ШифрГруппы,
| Слушатели.ДатаНачала,
| Слушатели.ДатаОкончания
|ИЗ
| Справочник.Слушатели КАК Слушатели
|ГДЕ
| Слушатели.Ссылка В (&Ссылка)";
Запрос.Параметры.Вставить("Ссылка", Ссылка);
Выборка = Запрос.Выполнить().Выбрать();
   
ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
Шапка = Макет.ПолучитьОбласть("Шапка");
ТабДок.Очистить();

ВставлятьРазделительСтраниц = Ложь;
Пока Выборка.Следующий() Цикл
Если ВставлятьРазделительСтраниц Тогда
ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
КонецЕсли;

ТабДок.Вывести(ОбластьЗаголовок);

Шапка.Параметры.Заполнить(Выборка);
ТабДок.Вывести(Шапка, Выборка.Уровень());

ВставлятьРазделительСтраниц = Истина;
КонецЦикла;
//}}
КонецПроцедуры
Я так понимаю, печатная форма была создана конструктором печатных форм,

Можно увидеть код из модуля менеджера ?


Теги:
 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7215
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3798
Последний ответ 19 Май 2014, 15:40
от kot_oo
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1980
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 6957
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
Как вызвать "Анализ субконто" из справочника "Контрагенты"

Автор EnigManРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 6353
Последний ответ 06 Фев 2012, 10:46
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
90 Сообщений
alex0402
54 Сообщений
AIFrame
42 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
38 Сообщений
Oldman06
31 Сообщений
Golickoff Golickoff
30 Сообщений
vitasw
29 Сообщений
MuI_I_Ika MuI_I_Ika
19 Сообщений
DmitriyF DmitriyF
14 Сообщений
BuhRust
14 Сообщений

* Кто онлайн

  • Точка Гостей: 644
  • Точка Скрытых: 0
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal