Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Июл 2017, 01:32
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Сложение строк ТЧ  (Прочитано 1802 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Каримдат

  • ***
  • Сообщений: 244
  • РЕПУТАЦИЯ: 19
  • КПД: 8%
  • Регистрация: 2014-04-06
    • Skype: winkarollo
  • Сайт: 
  • Профессия: Ученик 1С
Подскажите пожалуйста, как осуществить сложение строк в табличной части, с последующим выводом общей суммы в ПолеВвода?

Процедура ТоварыПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)

РаботаСДиалогами.ПоказатьКоэффициентМест(мКолонкиТовары, ОформлениеСтроки.Ячейки, ДанныеСтроки.ЕдиницаИзмеренияМест);
РаботаСДиалогами.ПоказатьКодАртикул(мКолонкиТовары, ОформлениеСтроки.Ячейки, ДанныеСтроки.Номенклатура);
//конкретно вот эта строка
РаботаСДиалогами.ПоказатьВесИзделия(мКолонкиТовары, ОформлениеСтроки.Ячейки, ДанныеСтроки.Номенклатура);

КонецПроцедуры
Эта процедура, выводит в колонку вес номенклатуры. А мне нужно чтобы функция или процедура в новое ПолеВвода выводила общую сумму всех строк из колонки ВесИзделия.
Я так понимаю надо Для Каждого ВесИзделия Цикл
а дальше не знаю как. Может кто подсказать?


Оффлайн ilnur75

  • ***
  • Сообщений: 111
  • РЕПУТАЦИЯ: 10
  • КПД: 9%
  • Регистрация: 2016-03-13
  • Сайт: 
  • Профессия: Ученик 1С
до цикла объявите переменную , например СуммаИтогоВес = 0
потом в цикле накапливать сумму в переменной "СуммаИтогоВес"
что-то типа СуммаИтогоВес = СуммаИтогоВес+Выборка.Вес

надеюсь идея понятна

Оффлайн Каримдат

  • ***
  • Сообщений: 244
  • РЕПУТАЦИЯ: 19
  • КПД: 8%
  • Регистрация: 2014-04-06
    • Skype: winkarollo
  • Сайт: 
  • Профессия: Ученик 1С
к сожалению, я не настолько продвинутый программист((( Я хоть и читаю Радченко 8.3, до РИБ дошёл, но выходит только по учебнику делать.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
ОбщийВес = ТабличнаяЧасть.Итог("ВесИзделия");
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Каримдат

  • ***
  • Сообщений: 244
  • РЕПУТАЦИЯ: 19
  • КПД: 8%
  • Регистрация: 2014-04-06
    • Skype: winkarollo
  • Сайт: 
  • Профессия: Ученик 1С
Процедура РассчитатьОбщийВес(ВесИзделия);//вес изделия так называется реквизит в номенклатуре
Для Каждого ВесИзделия Из Товары   Цикл
СуммаОбщийВес = ВесПеремещения.Итого;//ВесПеремещения - так назвал ПолеВвода в котором должна выводиться сумма
КонецЦикла;
КонецПроцедуры

Что я неправильно делаю? ((

Оффлайн ilnur75

  • ***
  • Сообщений: 111
  • РЕПУТАЦИЯ: 10
  • КПД: 9%
  • Регистрация: 2016-03-13
  • Сайт: 
  • Профессия: Ученик 1С
Что я неправильно делаю?
внимательно читать совет выше: ОбщийВес = ТабличнаяЧасть.Итог("ВесИзделия")
Ваша запись выглядит: СуммаОбщийВес = ВесПеремещения.Итого;
чего не хватает.
Думаю должно быть ВесПеремещения = Товары.Итог("ВесИзделия");
К сожалению Радченко этот момент в своих книгах не упоминает.
в ответе на ваш вопрос применили функцию Итог(), в данном случае Итог по колонке ВесИзделия таб.части Товары.

Оффлайн Каримдат

  • ***
  • Сообщений: 244
  • РЕПУТАЦИЯ: 19
  • КПД: 8%
  • Регистрация: 2014-04-06
    • Skype: winkarollo
  • Сайт: 
  • Профессия: Ученик 1С
Перем ОбщийИтог;
Перем ТабЗнач;

Процедура РассчитатьОбщийВес();
Для Каждого ВесИзделия Из Товары  Цикл
        ОбщийИтог = ТабЗнач.Итог("ВесИзделия");
КонецЦикла;
КонецПроцедуры
Не работает метод ((((

Оффлайн ilnur75

  • ***
  • Сообщений: 111
  • РЕПУТАЦИЯ: 10
  • КПД: 9%
  • Регистрация: 2016-03-13
  • Сайт: 
  • Профессия: Ученик 1С
в каком модуле прописываете процедуру?

Добавлено: 27 Июл 2016, 21:01

Перем ТабЗнач;
у Вас же реальная таблица Товары.
это не то.


Оффлайн Каримдат

  • ***
  • Сообщений: 244
  • РЕПУТАЦИЯ: 19
  • КПД: 8%
  • Регистрация: 2014-04-06
    • Skype: winkarollo
  • Сайт: 
  • Профессия: Ученик 1С
Код в модуле ФормаДокумента ПеремещениеТоваров

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Перем ОбщийИтог;
Перем ТабЗнач;

Процедура РассчитатьОбщийВес();
Для Каждого ВесИзделия Из Товары  Цикл
        ОбщийИтог = ТабЗнач.Итог("ВесИзделия");
КонецЦикла;
КонецПроцедуры
Не работает метод ((((

метод ТЧ.Итог("ИмяКолонки") получает сумму по колонке "ИмяКолонки" табличной части "ТЧ"
цикл в этом случае нафиг не нужен
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


 

(Копирование строк из ТЧ документа в ТЧ другого документа в Обычном приложении)

Автор GanG031Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1156
Последний ответ 25 Янв 2016, 19:01
от cska-fanat-kz
Рассчет НДФЛ в документе "Начисление зарплаты" при вводе строк вручную

Автор AzgerdРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 3159
Последний ответ 28 Янв 2013, 08:33
от Azgerd
как настроить реглам.отчетность, чтобы из расшифровок строк попадать в оборотно-сальдовые ведомости

Автор ВофисРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 1399
Последний ответ 06 Авг 2015, 09:36
от vitasw
Что значит пунктир в макетах? И как изменить ширину ячейки в одной строк?

Автор DirecTwiXРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 6290
Последний ответ 19 Апр 2012, 12:05
от evialen
Подсчет количества ремонта (сколько строк в табличной части документа)

Автор GoldMenРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 6977
Последний ответ 18 Сен 2012, 10:06
от GoldMen

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
122 Сообщений
alex0402
104 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
73 Сообщений
ilyay ilyay
50 Сообщений
Golickoff Golickoff
49 Сообщений
AIFrame
43 Сообщений
ab30ru
38 Сообщений
wise wise
36 Сообщений
Амал
32 Сообщений
Dethmontt Dethmontt
25 Сообщений

* Кто онлайн

  • Точка Гостей: 188
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal