Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Янв 2017, 09:59
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Автозаполнение данными  (Прочитано 390 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Provodnik

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-16
  • Сайт: 
Приветствую.
Прошу помощи.
Имеется справочник
Для справочника созданы форма элемента и форма группы.
Обе формы имеют парочку одинаковых полей. Как сделать так, чтобы при заполнении полей для группы, они автоматически заполнялись и для формы элемента.
Допустим:
При создании группы в форме группы заполняется поле Шифр группы. (см вложение)
При создании элемента в этой группе для последующих элементов в этой группе ему автоматически присваивается шифр группы

как это реализовать?

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1095
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
ОбработкаЗаполнения()

Если не ЭтоГруппа, то из Родителя получайте ШифрГруппы и присваивайте ШифруГруппы этого нового элемента.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Provodnik

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-16
  • Сайт: 
Проблема как раз в том, что я прекрасно понимаю как это должно выглядеть. И как должен алгоритм работать. но как его реализовать без понятия.

ОбработкаЗаполнения()

Если не ЭтоГруппа, то из Родителя получайте ШифрГруппы и присваивайте ШифруГруппы этого нового элемента.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1095
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Если НЕ ЭтоГруппа Тогда
    ШифрГруппы = Родитель.ШифрГруппы;
КонецЕсли;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Provodnik

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-16
  • Сайт: 
Простите, я не так выражаюсь.
Благодаря Вам, получился вот такой код:
&НаСервере
Процедура ОбработкаПроверкиЗаполненияНаСервере(Отказ, ПроверяемыеРеквизиты)
Если не ЭтоГруппа Тогда
    Объект.ШифрГруппы = Родитель.ШифрГруппы;
Объект.ДатаНачала = Родитель.ДатаНачала;
Объект.ДатаОкончания = Родитель.ДатаОкончания;
КонецЕсли;
КонецПроцедуры
Устанавливаю эту обработку для формыЭлемента в ОбработкаПроверкиЗаполненияНаСервере.
Выдает список ошибок:
{Справочник.Слушатели.Форма.ФормаЭлемента.Форма(57,10)}: Переменная не определена (ЭтоГруппа)
Если не <<?>>ЭтоГруппа Тогда (Проверка: Сервер)
{Справочник.Слушатели.Форма.ФормаЭлемента.Форма(58,25)}: Переменная не определена (Родитель)
    Объект.ШифрГруппы = <<?>>Родитель.ШифрГруппы; (Проверка: Сервер)
{Справочник.Слушатели.Форма.ФормаЭлемента.Форма(59,22)}: Переменная не определена (Родитель)
Объект.ДатаНачала = <<?>>Родитель.ДатаНачала;  (Проверка: Сервер)
{Справочник.Слушатели.Форма.ФормаЭлемента.Форма(60,25)}: Переменная не определена (Родитель)
Объект.ДатаОкончания = <<?>>Родитель.ДатаОкончания;  (Проверка: Сервер)

Что я делаю не так?
Кстати, большое спасибо что отвечаете.
Если НЕ ЭтоГруппа Тогда
    ШифрГруппы = Родитель.ШифрГруппы;
КонецЕсли;

Оффлайн Fedor_Safonchik

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 4
  • КПД: 12%
  • Регистрация: 2016-06-16
  • Сайт: 
  • Профессия: Ученик 1С
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Если не ЭтоГруппа Тогда
        Объект.ШифрГруппы = Объект.Родитель.ШифрГруппы;
        Объект.ДатаНачала = Объект.Родитель.ДатаНачала;
        Объект.ДатаОкончания = Объект.Родитель.ДатаОкончания;
    КонецЕсли;
КонецПроцедуры

Я конечно не уверен, но попробуйте так

Оффлайн Provodnik

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-16
  • Сайт: 
Благодарю!
Да. Пробовал сам так сделать. не получилось. видимо где-то ошибку допустил. Большое спасибо.
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Если не ЭтоГруппа Тогда
        Объект.ШифрГруппы = Объект.Родитель.ШифрГруппы;
        Объект.ДатаНачала = Объект.Родитель.ДатаНачала;
        Объект.ДатаОкончания = Объект.Родитель.ДатаОкончания;
    КонецЕсли;
КонецПроцедуры

Я конечно не уверен, но попробуйте так

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1095
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
НЕ
ОбработкаПроверкиЗаполнения()
а
ОбработкаЗаполнения()

совершенно разные обработчики!

и не на форме, а в модуле объекта.
хотя вариантов конечно на самом деле - масса.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Provodnik

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-16
  • Сайт: 
Благодарю. Уже разобрался. Спасибо большое
НЕ
ОбработкаПроверкиЗаполнения()
а
ОбработкаЗаполнения()

совершенно разные обработчики!

и не на форме, а в модуле объекта.
хотя вариантов конечно на самом деле - масса.


 

Обмен данными между 1С УТ (базовая) 8.2 редакция 10.3 и Розница (базовая) редакция 1.0

Автор Андрей ОлимпиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 3124
Последний ответ 17 Мар 2015, 20:16
от дфтын
Автозаполнение поля табличной части документа при изменении другого поля табличной части документа

Автор dimanpspРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 17
Просмотров: 2001
Последний ответ 02 Июн 2015, 15:53
от dimanpsp
Обмен РИБ, обмен данными между организациями

Автор Azamat FaizovРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 903
Последний ответ 18 Сен 2014, 11:48
от Azamat Faizov
Обмен УТ 11 и БП 3.0 через универсальный обмен данными

Автор magnifico61Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 4980
Последний ответ 25 Дек 2014, 13:40
от cska-fanat-kz
обмен данными между 1с Розница и 1с Розница

Автор maksdemonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 1251
Последний ответ 23 Мар 2015, 13:53
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
alex0402
56 Сообщений
MuI_I_Ika MuI_I_Ika
49 Сообщений
crow1983
35 Сообщений
LexaK
32 Сообщений
alexandr_ll
28 Сообщений
sertak sertak
25 Сообщений
Vzonder
21 Сообщений
BuhRust
17 Сообщений
дфтын дфтын
17 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal