Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 июн 2021, 08:37

Не могу найти код программы

Автор TDA, 26 июл 2016, 10:09

0 Пользователей и 1 гость просматривают эту тему.

TDA

К 1с бухгалтерии есть epf-файл внешней обработки. Обработка содержит одну форму. Вот фрагмент кода.

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

ИдентификаторКоманды = Параметры.ИдентификаторКоманды;

КонецПроцедуры

&НаКлиенте
Процедура Выгрузить(Команда)
ВыгрузитьНаСервере();
КонецПроцедуры

&НаСервере
Процедура ВыгрузитьНаСервере()

ОбъектЗн = РеквизитФормыВЗначение("Объект");

ОбъектЗн.ВыполнитьКоманду(ИдентификаторКоманды);

КонецПроцедуры

Где найти код, который спрятан в Параметры.ИдентификаторКоманды?

MuI_I_Ika

а что за параметры, о которых вы говорите?

TDA

Во вложении скриншот. Там указан этот параметр.

MuI_I_Ika

На скриншоте ИдентификаторКоманды это просто реквизит формы. О каком обработчике идет речь?

TDA

Это внешний обработчик. Он в виде файла подключается к 1с-бухгалтерия. При подключении файла открывается данная форма. Мне нужно найти код действий, которые выполняются при нажатии на кнопку Выгрузить.

MuI_I_Ika

На закладку команды переходите. Ищете там команду выгрузить и смотрите какой там обработчик.

TDA

Там выполняется команда Выгрузить (код выше), эта команда запускает процедуру ВыгрузитьНаСервере, а уже она запускает команду ИдентификаторКоманды, значение которой объявляется в процедуре ПриСозданииНаСервере. Она присваивает переменной ИдентификаторКоманды значение Параметры.ИдентификаторКоманды. И у меня соответствующий вопрос, что это за команда такая?

MuI_I_Ika

В параметрах передается какая-то текстовая переменная. Нужно просто посмотреть отладчиком что там, и сделать вывод.

cska-fanat-kz

Цитата: TDA от 26 июл 2016, 10:09ОбъектЗн.ВыполнитьКоманду(ИдентификаторКоманды);

в модуле объекта этой обработки ищите экспортную процедуру ВыполнитьКоманду()
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

TDA

Спасибо.:) Нашел. А я смотрел только модуль формы.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск