Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Янв 2017, 23:10
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не могу найти код программы  (Прочитано 562 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн TDA

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-07-26
  • Сайт: 
  • Профессия: Ученик 1С
К 1с бухгалтерии есть epf-файл внешней обработки. Обработка содержит одну форму. Вот фрагмент кода.
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

ИдентификаторКоманды = Параметры.ИдентификаторКоманды;

КонецПроцедуры

&НаКлиенте
Процедура Выгрузить(Команда)
ВыгрузитьНаСервере();
КонецПроцедуры

&НаСервере
Процедура ВыгрузитьНаСервере()

ОбъектЗн = РеквизитФормыВЗначение("Объект");

ОбъектЗн.ВыполнитьКоманду(ИдентификаторКоманды);

КонецПроцедуры
Где найти код, который спрятан в Параметры.ИдентификаторКоманды?


Онлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6075
  • РЕПУТАЦИЯ: 712
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
а что за параметры, о которых вы говорите?

Оффлайн TDA

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-07-26
  • Сайт: 
  • Профессия: Ученик 1С
Во вложении скриншот. Там указан этот параметр.

Онлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6075
  • РЕПУТАЦИЯ: 712
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
На скриншоте ИдентификаторКоманды это просто реквизит формы. О каком обработчике идет речь?

Оффлайн TDA

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-07-26
  • Сайт: 
  • Профессия: Ученик 1С
Это внешний обработчик. Он в виде файла подключается к 1с-бухгалтерия. При подключении файла открывается данная форма. Мне нужно найти код действий, которые выполняются при нажатии на кнопку Выгрузить.

Онлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6075
  • РЕПУТАЦИЯ: 712
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
На закладку команды переходите. Ищете там команду выгрузить и смотрите какой там обработчик.

Оффлайн TDA

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-07-26
  • Сайт: 
  • Профессия: Ученик 1С
Там выполняется команда Выгрузить (код выше), эта команда запускает процедуру ВыгрузитьНаСервере, а уже она запускает команду ИдентификаторКоманды, значение которой объявляется в процедуре ПриСозданииНаСервере. Она присваивает переменной ИдентификаторКоманды значение Параметры.ИдентификаторКоманды. И у меня соответствующий вопрос, что это за команда такая?

Онлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6075
  • РЕПУТАЦИЯ: 712
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
В параметрах передается какая-то текстовая переменная. Нужно просто посмотреть отладчиком что там, и сделать вывод.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1095
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
ОбъектЗн.ВыполнитьКоманду(ИдентификаторКоманды);

в модуле объекта этой обработки ищите экспортную процедуру ВыполнитьКоманду()
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн TDA

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-07-26
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо.:) Нашел. А я смотрел только модуль формы.


Теги:
 

не могу вывести отображение цен в "подборе" документ "Заявка покупателя" УТ 10.3

Автор Виталий ЕмельяновРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 1926
Последний ответ 05 Окт 2015, 19:22
от Виталий Емельянов
не могу заполнить поле "Соглашение"

Автор aprnРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2675
Последний ответ 05 Май 2011, 18:17
от Maxim
Если у счёта есть признак учёта "Количество", то я могу писать Двж.КоличествоДт?

Автор DirecTwiXРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 4168
Последний ответ 25 Апр 2012, 10:39
от Vit1501
Не могу ввести значение в поле "цена" в заказе покупателя и счете

Автор Анатолий161Раздел Пользователям "1С - Предприятие 8"

Ответов: 4
Просмотров: 3520
Последний ответ 14 Ноя 2013, 20:51
от Анатолий161
Снова "Структура данных". Помогите, не могу сообразить

Автор JohnDoe144Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 18
Просмотров: 1422
Последний ответ 15 Май 2016, 01:04
от JohnDoe144

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
165 Сообщений
alex0402
74 Сообщений
alexandr_ll
38 Сообщений
MuI_I_Ika MuI_I_Ika
36 Сообщений
LexaK
32 Сообщений
crow1983
31 Сообщений
sertak sertak
26 Сообщений
BuhRust
18 Сообщений
Vzonder
17 Сообщений
дфтын дфтын
17 Сообщений

* Кто онлайн

  • Точка Гостей: 342
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal