Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
29 Мар 2017, 20:04
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Запрос к бухгалтерским итогам по месяцам  (Прочитано 396 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн damir-it

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-06-26
  • Сайт: 
  • Профессия: Программист 7.7
Привет Всем
Столкнулся с такой задачей, нужно было составить запрос к бухгалтерским итогам по Сотрудникам, вот код:

   Налог = глПолучитьНалог("ПФизЗП");
   Таб = СоздатьОбъект("Таблица");
   Таб.ИсходнаяТаблица("Таблица");
   Таб.ВывестиСекцию("Шапка");
   Би = СоздатьОбъект("БухгалтерскиеИтоги");

   Би.ИспользоватьСубконто(ВидыСубконто.Сотрудники);
   Би.ВыполнитьЗапрос(НачДата,КонДата,Налог.Счет,глПолучитьНалог("ПФизЗП").Счет,,3,7);
   Би.ВыбратьСубконто();
   Номер = 0;
   ИтогПлат = 0;
   ИтогДоход = 0;
   
   Пока Би.ПолучитьСубконто() = 1 Цикл
      Фамилия = ""; Имя = ""; Отчество = "";
   
      ФИО(Би.Субконто(),Фамилия,Имя,Отчество);
   
      Номер = Номер+1;       
      Если Би.ПолучитьКорСчет(,глПолучитьНалог("ПодНал").Счет) = 1 Тогда
         ОбПлат = Би.КорКО();     
      Иначе
         ОбПлат = 0;
      КонецЕсли;
      ДобрПлат = Би.КО(); 
   
      Таб.ВывестиСекцию("Строка");
   
      ИтогПлат = ИтогПлат+Би.КО();
      
      ИтогДоход = ИтогДоход+Доход;
   КонецЦикла;

   Таб.ВывестиСекцию("Подвал");
   Таб.ПовторятьПриПечатиСтроки(8,8);
   Таб.Опции(0,0,0,0);
   Таб.Показать("Реестр ИНПС");
КонецПроцедуры 

все работает как надо и в таблице в колонке с формулой ДобрПлат выгружаются суммированные итоги по месяцам, возникла необходимость выгружать в соседнюю колонку этиже данные только за один текущий месяц, как это можно реализовать подскажите пожалуйста
с Уважением Дамир 


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
alex0402
127 Сообщений
MuI_I_Ika MuI_I_Ika
57 Сообщений
Norfolk
52 Сообщений
LexaK
49 Сообщений
друган
20 Сообщений
alexandr_ll
20 Сообщений
AsadRoman
18 Сообщений
Константин5825
18 Сообщений
MrLvovsky MrLvovsky
16 Сообщений

* Кто онлайн

  • Точка Гостей: 456
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal