Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Сен 2017, 13:36
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Запрос к бухгалтерским итогам по месяцам  (Прочитано 561 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн damir-it

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-06-26
  • Сайт: 
  • Профессия: Программист 7.7
Привет Всем
Столкнулся с такой задачей, нужно было составить запрос к бухгалтерским итогам по Сотрудникам, вот код:

   Налог = глПолучитьНалог("ПФизЗП");
   Таб = СоздатьОбъект("Таблица");
   Таб.ИсходнаяТаблица("Таблица");
   Таб.ВывестиСекцию("Шапка");
   Би = СоздатьОбъект("БухгалтерскиеИтоги");

   Би.ИспользоватьСубконто(ВидыСубконто.Сотрудники);
   Би.ВыполнитьЗапрос(НачДата,КонДата,Налог.Счет,глПолучитьНалог("ПФизЗП").Счет,,3,7);
   Би.ВыбратьСубконто();
   Номер = 0;
   ИтогПлат = 0;
   ИтогДоход = 0;
   
   Пока Би.ПолучитьСубконто() = 1 Цикл
      Фамилия = ""; Имя = ""; Отчество = "";
   
      ФИО(Би.Субконто(),Фамилия,Имя,Отчество);
   
      Номер = Номер+1;       
      Если Би.ПолучитьКорСчет(,глПолучитьНалог("ПодНал").Счет) = 1 Тогда
         ОбПлат = Би.КорКО();     
      Иначе
         ОбПлат = 0;
      КонецЕсли;
      ДобрПлат = Би.КО(); 
   
      Таб.ВывестиСекцию("Строка");
   
      ИтогПлат = ИтогПлат+Би.КО();
      
      ИтогДоход = ИтогДоход+Доход;
   КонецЦикла;

   Таб.ВывестиСекцию("Подвал");
   Таб.ПовторятьПриПечатиСтроки(8,8);
   Таб.Опции(0,0,0,0);
   Таб.Показать("Реестр ИНПС");
КонецПроцедуры 

все работает как надо и в таблице в колонке с формулой ДобрПлат выгружаются суммированные итоги по месяцам, возникла необходимость выгружать в соседнюю колонку этиже данные только за один текущий месяц, как это можно реализовать подскажите пожалуйста
с Уважением Дамир 


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
165 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
88 Сообщений
alex0402
87 Сообщений
Golickoff Golickoff
32 Сообщений
ilyay ilyay
30 Сообщений
Kironten
29 Сообщений
AIFrame
26 Сообщений
AsadRoman
26 Сообщений
BuhRust
26 Сообщений
Варвар
20 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal