Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 июн 2021, 10:48

Обработка внешнего события (считывание штрихкода) во внешней обработке

Автор Sanario, 21 июл 2016, 15:02

0 Пользователей и 1 гость просматривают эту тему.

Sanario

Пишу обработку для ТиС9.2, чтобы можно было исходя из остатков продавать контрагенту от двух фирм. Не могу подхватить внешнее событие. Процедуру прописал в модуле - но обработка "алле" не говорит :(

//**************************************************************************************
Процедура ОбработкаВнешнегоСобытия(Источник,Событие,Данные)
// Процедура разбирает штрих-код, считанный сканером
// и заполняет строки накладной
Перем Упаковка,ТекКоличество, Спецификация;
Перем ВремТовар, ВремЕдиница, ВремКоличество;
Перем ВремЦена, ЕдЦены;
Если Событие = "BarCodeValue" Тогда
        Если Форма.ТолькоПросмотр() = 0 Тогда
Если глПолучитьТоварПоШтрихкоду(Данные, ВремТовар, ВремЕдиница, ВремКоличество) <> 0 Тогда
ТаблицаПодбора = СоздатьОбъект("ТаблицаЗначений");
ТаблицаПодбора.НоваяКолонка("Номенклатура");
ТаблицаПодбора.НоваяКолонка("Единица");
ТаблицаПодбора.НоваяКолонка("Количество", "Число");
ТаблицаПодбора.НоваяКолонка("Цена", "Число");

ТаблицаПодбора.НоваяСтрока();
ТаблицаПодбора.Номенклатура = ВремТовар;
ТаблицаПодбора.Единица      = ВремЕдиница;
ТаблицаПодбора.Количество   = ВремКоличество;
ТаблицаПодбора.Цена = глПолучитьЦену(ВремТовар, ТипЦенВПодборе, РабочаяДата(), ВремЕдиница, глРубли, 1);

ПараметрыПодбора = СоздатьОбъект("СписокЗначений");
ПараметрыПодбора.ДобавитьЗначение(0              , "ЕстьВидТМЦ");
ПараметрыПодбора.ДобавитьЗначение("ИзСправочника", "ЦенаВподборе");
ПараметрыПодбора.ДобавитьЗначение(ТипЦенВПодборе , "ТипЦен");     
ПараметрыПодбора.ДобавитьЗначение(ТаблицаПодбора , "ТаблицаПодбора");

глОбработкаПодбора(Контекст, ПараметрыПодбора, 1, 1, 1);
КонецЕсли;
КонецЕсли;
// Обработка закончена. Готовы к получению нового штрихкода.
глСканерПосылкаДанных(1);
Иначе
глОбработкаВнешнегоСобытия(Источник, Событие, Данные);
КонецЕсли;

КонецПроцедуры

Теги:
Рейтинг@Mail.ru Rambler's Top100

Поиск