Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Июл 2017, 15:36
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Обработка внешнего события (считывание штрихкода) во внешней обработке  (Прочитано 665 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Sanario

  • Sanario
  • *
  • Сообщений: 30
  • РЕПУТАЦИЯ: 2
  • КПД: 7%
  • Регистрация: 2010-12-23
    • Skype: Zenyukov1981
  • Сайт: 
  • Профессия: Программист 1С
Пишу обработку для ТиС9.2, чтобы можно было исходя из остатков продавать контрагенту от двух фирм. Не могу подхватить внешнее событие. Процедуру прописал в модуле - но обработка "алле" не говорит :(

//**************************************************************************************
Процедура ОбработкаВнешнегоСобытия(Источник,Событие,Данные)
// Процедура разбирает штрих-код, считанный сканером
// и заполняет строки накладной
Перем Упаковка,ТекКоличество, Спецификация;
Перем ВремТовар, ВремЕдиница, ВремКоличество;
Перем ВремЦена, ЕдЦены;
Если Событие = "BarCodeValue" Тогда
        Если Форма.ТолькоПросмотр() = 0 Тогда
Если глПолучитьТоварПоШтрихкоду(Данные, ВремТовар, ВремЕдиница, ВремКоличество) <> 0 Тогда
ТаблицаПодбора = СоздатьОбъект("ТаблицаЗначений");
ТаблицаПодбора.НоваяКолонка("Номенклатура");
ТаблицаПодбора.НоваяКолонка("Единица");
ТаблицаПодбора.НоваяКолонка("Количество", "Число");
ТаблицаПодбора.НоваяКолонка("Цена", "Число");

ТаблицаПодбора.НоваяСтрока();
ТаблицаПодбора.Номенклатура = ВремТовар;
ТаблицаПодбора.Единица      = ВремЕдиница;
ТаблицаПодбора.Количество   = ВремКоличество;
ТаблицаПодбора.Цена = глПолучитьЦену(ВремТовар, ТипЦенВПодборе, РабочаяДата(), ВремЕдиница, глРубли, 1);

ПараметрыПодбора = СоздатьОбъект("СписокЗначений");
ПараметрыПодбора.ДобавитьЗначение(0              , "ЕстьВидТМЦ");
ПараметрыПодбора.ДобавитьЗначение("ИзСправочника", "ЦенаВподборе");
ПараметрыПодбора.ДобавитьЗначение(ТипЦенВПодборе , "ТипЦен");     
ПараметрыПодбора.ДобавитьЗначение(ТаблицаПодбора , "ТаблицаПодбора");

глОбработкаПодбора(Контекст, ПараметрыПодбора, 1, 1, 1);
КонецЕсли;
КонецЕсли;
// Обработка закончена. Готовы к получению нового штрихкода.
глСканерПосылкаДанных(1);
Иначе
глОбработкаВнешнегоСобытия(Источник, Событие, Данные);
КонецЕсли;

КонецПроцедуры


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
93 Сообщений
alex0402
93 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
64 Сообщений
Golickoff Golickoff
51 Сообщений
ilyay ilyay
45 Сообщений
AIFrame
41 Сообщений
wise wise
31 Сообщений
Амал
30 Сообщений
ab30ru
24 Сообщений
lansy
22 Сообщений

* Кто онлайн

  • Точка Гостей: 948
  • Точка Скрытых: 0
  • Точка Пользователей: 20
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal