Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Июл 2017, 11:51
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Штрихкод вместо артикула в ТОРГ12  (Прочитано 667 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Илья Ворожбит

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-07-20
  • Сайт: 
Здравствуйте!

Подскажите, пожалуйста, как можно реализовать замену поля "артикул" на "штрихкод" (из карточки товара) в накладной ТОРГ12?

Или же, можно попробовать написать процедуру, которая заменит артикулы на штрихкоды.

Есть база на 900 товаров, вручную менять не сильно хотелось бы.

Нашел такую процедуру:
Код:
Процедура КнопкаВыполнитьНажатие(Кнопка)
    НаборЗаписей = РегистрыСведений.Штрихкоды.СоздатьНаборЗаписей();
    НаборЗаписей.Прочитать();
    Для Каждого Запись Из НаборЗаписей Цикл
        Если ЗначениеЗаполнено(Запись.Штрихкод) Тогда
            //тут нужно выбрать товар из Справочники.Номенклатура по коду
            //заменить поле артикул на штрихкод
            //сохранить :)
        КонецЕсли;
    КонецЦикла;
    НаборЗаписей.Записать();
КонецПроцедуры
С 1С-кой только начал знакомиться, так что буду рад любой помощи. Благодарю)


Теги:
 

Галочка вместо "ДаНЕТ"

Автор fiftystarsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4255
Последний ответ 05 Дек 2011, 15:24
от fiftystars
Вместо ссылки получается строка с наименованием ссылки

Автор МаксБУХРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 138
Последний ответ 04 Июл 2017, 12:56
от ilyay
Перенесено: Книга покупок. На выданные авансы вместо контрагента выводит "нас"

Автор progmikonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1746
Последний ответ 30 Ноя 2010, 22:36
от progmikon
Печать "Поля ввода" вместо наименования товара

Автор AXTAZYРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 1167
Последний ответ 14 Фев 2016, 14:24
от AXTAZY
Книга покупок. На выданные авансы вместо контрагента выводит "нас"

Автор mormarisРаздел Пользователям "1С - Предприятие 8"

Ответов: 4
Просмотров: 3389
Последний ответ 30 Ноя 2010, 22:53
от mormaris

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
93 Сообщений
alex0402
93 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
64 Сообщений
Golickoff Golickoff
51 Сообщений
ilyay ilyay
45 Сообщений
AIFrame
41 Сообщений
wise wise
31 Сообщений
Амал
30 Сообщений
ab30ru
24 Сообщений
lansy
22 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal