Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Янв 2017, 02:33
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Штрихкод вместо артикула в ТОРГ12  (Прочитано 353 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Илья Ворожбит

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-07-20
  • Сайт: 
Здравствуйте!

Подскажите, пожалуйста, как можно реализовать замену поля "артикул" на "штрихкод" (из карточки товара) в накладной ТОРГ12?

Или же, можно попробовать написать процедуру, которая заменит артикулы на штрихкоды.

Есть база на 900 товаров, вручную менять не сильно хотелось бы.

Нашел такую процедуру:
Код:
Процедура КнопкаВыполнитьНажатие(Кнопка)
    НаборЗаписей = РегистрыСведений.Штрихкоды.СоздатьНаборЗаписей();
    НаборЗаписей.Прочитать();
    Для Каждого Запись Из НаборЗаписей Цикл
        Если ЗначениеЗаполнено(Запись.Штрихкод) Тогда
            //тут нужно выбрать товар из Справочники.Номенклатура по коду
            //заменить поле артикул на штрихкод
            //сохранить :)
        КонецЕсли;
    КонецЦикла;
    НаборЗаписей.Записать();
КонецПроцедуры
С 1С-кой только начал знакомиться, так что буду рад любой помощи. Благодарю)

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Теги:
 

Галочка вместо "ДаНЕТ"

Автор fiftystarsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3545
Последний ответ 05 Дек 2011, 15:24
от fiftystars
Перенесено: Книга покупок. На выданные авансы вместо контрагента выводит "нас"

Автор progmikonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1562
Последний ответ 30 Ноя 2010, 22:36
от progmikon
Печать "Поля ввода" вместо наименования товара

Автор AXTAZYРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 700
Последний ответ 14 Фев 2016, 14:24
от AXTAZY
Книга покупок. На выданные авансы вместо контрагента выводит "нас"

Автор mormarisРаздел Пользователям "1С - Предприятие 8"

Ответов: 4
Просмотров: 3065
Последний ответ 30 Ноя 2010, 22:53
от mormaris
Как выгрузить в 1с файл Excel если вместо Excel стоит LibreOffice Calс

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 567
Последний ответ 04 Апр 2016, 17:44
от Rasty

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
alex0402
58 Сообщений
MuI_I_Ika MuI_I_Ika
51 Сообщений
crow1983
37 Сообщений
alexandr_ll
27 Сообщений
LexaK
24 Сообщений
sertak sertak
22 Сообщений
BuhRust
19 Сообщений
Vzonder
18 Сообщений
дфтын дфтын
17 Сообщений

* Кто онлайн

  • Точка Гостей: 177
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal