Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Окт 2017, 04:13
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Штрихкод вместо артикула в ТОРГ12  (Прочитано 820 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Илья Ворожбит

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-07-20
  • Сайт: 
Здравствуйте!

Подскажите, пожалуйста, как можно реализовать замену поля "артикул" на "штрихкод" (из карточки товара) в накладной ТОРГ12?

Или же, можно попробовать написать процедуру, которая заменит артикулы на штрихкоды.

Есть база на 900 товаров, вручную менять не сильно хотелось бы.

Нашел такую процедуру:
Код:
Процедура КнопкаВыполнитьНажатие(Кнопка)
    НаборЗаписей = РегистрыСведений.Штрихкоды.СоздатьНаборЗаписей();
    НаборЗаписей.Прочитать();
    Для Каждого Запись Из НаборЗаписей Цикл
        Если ЗначениеЗаполнено(Запись.Штрихкод) Тогда
            //тут нужно выбрать товар из Справочники.Номенклатура по коду
            //заменить поле артикул на штрихкод
            //сохранить :)
        КонецЕсли;
    КонецЦикла;
    НаборЗаписей.Записать();
КонецПроцедуры
С 1С-кой только начал знакомиться, так что буду рад любой помощи. Благодарю)


Теги:
 

Галочка вместо "ДаНЕТ"

Автор fiftystarsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4720
Последний ответ 05 Дек 2011, 15:24
от fiftystars
Вместо ссылки получается строка с наименованием ссылки

Автор МаксБУХРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 210
Последний ответ 04 Июл 2017, 12:56
от ilyay
Перенесено: Книга покупок. На выданные авансы вместо контрагента выводит "нас"

Автор progmikonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1829
Последний ответ 30 Ноя 2010, 22:36
от progmikon
Печать "Поля ввода" вместо наименования товара

Автор AXTAZYРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 1453
Последний ответ 14 Фев 2016, 14:24
от AXTAZY
Книга покупок. На выданные авансы вместо контрагента выводит "нас"

Автор mormarisРаздел Пользователям "1С - Предприятие 8"

Ответов: 4
Просмотров: 3601
Последний ответ 30 Ноя 2010, 22:53
от mormaris

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

1С HRIS от goldi77
[18 Окт 2017, 11:58]

* Топ 10 авторов за месяц

oleg-x
88 Сообщений
alex0402
50 Сообщений
AIFrame
43 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
37 Сообщений
Oldman06
31 Сообщений
Golickoff Golickoff
30 Сообщений
vitasw
29 Сообщений
MuI_I_Ika MuI_I_Ika
18 Сообщений
DmitriyF DmitriyF
14 Сообщений
Св Ч Св Ч
12 Сообщений

* Кто онлайн

  • Точка Гостей: 102
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal