Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Янв 2018, 13:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Штрихкод вместо артикула в ТОРГ12  (Прочитано 951 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Илья Ворожбит

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-07-20
  • Сайт: 
Здравствуйте!

Подскажите, пожалуйста, как можно реализовать замену поля "артикул" на "штрихкод" (из карточки товара) в накладной ТОРГ12?

Или же, можно попробовать написать процедуру, которая заменит артикулы на штрихкоды.

Есть база на 900 товаров, вручную менять не сильно хотелось бы.

Нашел такую процедуру:
Код:
Процедура КнопкаВыполнитьНажатие(Кнопка)
    НаборЗаписей = РегистрыСведений.Штрихкоды.СоздатьНаборЗаписей();
    НаборЗаписей.Прочитать();
    Для Каждого Запись Из НаборЗаписей Цикл
        Если ЗначениеЗаполнено(Запись.Штрихкод) Тогда
            //тут нужно выбрать товар из Справочники.Номенклатура по коду
            //заменить поле артикул на штрихкод
            //сохранить :)
        КонецЕсли;
    КонецЦикла;
    НаборЗаписей.Записать();
КонецПроцедуры
С 1С-кой только начал знакомиться, так что буду рад любой помощи. Благодарю)


Теги:
 

Галочка вместо "ДаНЕТ"

Автор fiftystarsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 5117
Последний ответ 05 Дек 2011, 15:24
от fiftystars
Вместо ссылки получается строка с наименованием ссылки

Автор МаксБУХРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 294
Последний ответ 04 Июл 2017, 12:56
от ilyay
Перенесено: Книга покупок. На выданные авансы вместо контрагента выводит "нас"

Автор progmikonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1932
Последний ответ 30 Ноя 2010, 22:36
от progmikon
Печать "Поля ввода" вместо наименования товара

Автор AXTAZYРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 1764
Последний ответ 14 Фев 2016, 14:24
от AXTAZY
Книга покупок. На выданные авансы вместо контрагента выводит "нас"

Автор mormarisРаздел Пользователям "1С - Предприятие 8"

Ответов: 4
Просмотров: 3845
Последний ответ 30 Ноя 2010, 22:53
от mormaris

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
99 Сообщений
AIFrame
65 Сообщений
alex0402
32 Сообщений
kiksi
26 Сообщений
pavl_vs
24 Сообщений
alexandr_ll
18 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
KOI8-R
14 Сообщений
MuI_I_Ika MuI_I_Ika
13 Сообщений

* Кто онлайн

  • Точка Гостей: 303
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal