Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
20 Сен 2017, 03:11
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: СКД снова расшифровка  (Прочитано 812 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Urupa

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-07-20
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте! Затертая до дыр тема: расшифровка скд. Но все же, может кто глянет, я чего-то не догоняю, укажите чего.

На произвольной форме есть табличный документ в который вывожу отчет. Отчет формируется на основе СКД, которую предварительно настроил в макете.

По сути что делаю:
1. При создании формы сразу все подготовил.
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

СхемаКомпоновки = Документы.ВнутреннийЗаказ.ПолучитьМакет("АнализРабочийСтол");
ХранилищеСхемы = ПоместитьВоВременноеХранилище(СхемаКомпоновки, ЭтаФорма.УникальныйИдентификатор);
КомпоновщикНастроек.ЗагрузитьНастройки(СхемаКомпоновки.НастройкиПоУмолчанию);

ДанныеРасшифровки = Новый ДанныеРасшифровкиКомпоновкиДанных;
ХранилищеДанныхРасшифровки = ПоместитьВоВременноеХранилище(ДанныеРасшифровки, ЭтаФорма.УникальныйИдентификатор);

КонецПроцедуры
КомпоновщикНастроек - реквизит формы с соответствующим типом.

2. Формируем сам отчет
&НаСервере
Процедура ОбновитьНоменклатуруЗаказа(ВнутреннийЗаказ)

//Установим параметр
ПараметрВнутреннийЗаказ = Новый ПараметрКомпоновкиДанных("ВнутреннийЗаказ");
ЗначениеПараметраВнутреннийЗаказ = КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра(ПараметрВнутреннийЗаказ);
ЗначениеПараметраВнутреннийЗаказ.Значение = ВнутреннийЗаказ;
ЗначениеПараметраВнутреннийЗаказ.Использование = Истина;

Настройки = КомпоновщикНастроек.Настройки;

//Вытащим из хранилища Схему и ДанныеРасшифровки
СхемаКомпановки = ПолучитьИзВременногоХранилища(ХранилищеСхемы);
ДанныеРасшифровки = ПолучитьИзВременногоХранилища(ХранилищеДанныхРасшифровки);

//Дальше все стандартно (вроде)
КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпановки, Настройки, ДанныеРасшифровки);

ПроцессорКомпоновкиДанных = Новый ПроцессорКомпоновкиДанных;
ПроцессорКомпоновкиДанных.Инициализировать(МакетКомпоновки, ,ДанныеРасшифровки);

АнализЗаказа.Очистить();

ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
ПроцессорВывода.УстановитьДокумент(АнализЗаказа);
ПроцессорВывода.Вывести(ПроцессорКомпоновкиДанных);

КонецПроцедуры

3. Отчет работает, всё нормально, но вот когда пытаюсь получить расшифровку
&НаКлиенте
Процедура АнализЗаказаОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)

Перем ВыбранноеДействие, ПараметрыВыбранногоДействия;

СтандартнаяОбработка = Ложь;

ОбработкаРасшифровки = Новый ОбработкаРасшифровкиКомпоновкиДанных(ХранилищеДанныхРасшифровки,Новый ИсточникДоступныхНастроекКомпоновкиДанных(ХранилищеСхемы));
ОбработкаРасшифровки.ВыбратьДействие(Расшифровка, ВыбранноеДействие, ПараметрыВыбранногоДействия);

ДоступныеДействия=Новый СписокЗначений;
ДоступныеДействия.Добавить(ДействиеОбработкиРасшифровкиКомпоновкиДанных.ОткрытьЗначение, "Открыть");

ОбработкаРасшифровки.Выполнить(Расшифровка, ВыбранноеДействие, ПараметрыВыбранногоДействия, ДоступныеДействия);
ОткрытьЗначение(ПараметрыВыбранногоДействия);

КонецПроцедуры

Проблема: Ошибка информации расшифровки: не найден элемент расшифровки.
В отладчике вижу, что ЭлементыРасшифровкиКомпановкиДанных пустые, ничего нет. Подозреваю, что в этом причина ошибки. От чего зависит содержание элементов расшифровки. Настройки расшифровки кстати содержат адекватные данные. а вот элементов нет. Что делаю не так?

Последний раз редактировалось: Urupa; 20 Июл 2016, 13:18


 

Отчет - расшифровка по статье затрат "услуги автотранспорта"

Автор marismurРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2645
Последний ответ 22 Авг 2014, 14:36
от morph1991
Расшифровка в отчете на СКД, который вызывается из формы справочника(управляемые формы)

Автор anna_vsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 19
Просмотров: 5225
Последний ответ 09 Дек 2015, 14:39
от vitasw
Снова "Структура данных". Помогите, не могу сообразить

Автор JohnDoe144Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 18
Просмотров: 2462
Последний ответ 15 Май 2016, 01:04
от JohnDoe144
ОСВ по 20 счету (отсутствует расшифровка статей затрат на конец месяца )

Автор ирина56Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4136
Последний ответ 02 Апр 2013, 17:23
от MuI_I_Ika
Расшифровка по Регистратору на СКД не получается оформить макет

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 483
Последний ответ 29 Сен 2016, 15:19
от ZSS

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
174 Сообщений
alex0402
82 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
80 Сообщений
AsadRoman
36 Сообщений
Kironten
34 Сообщений
ilyay ilyay
30 Сообщений
Golickoff Golickoff
29 Сообщений
AIFrame
27 Сообщений
BuhRust
26 Сообщений
Варвар
20 Сообщений

* Кто онлайн

  • Точка Гостей: 238
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal