Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
28 Май 2017, 13:22
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Внешняя обработка  (Прочитано 638 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн RoDi

  • *
  • Сообщений: 37
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-07-05
  • Сайт: 
  • Профессия: Программист 1С
Подскажите что не так с кодом вроде всё пропиписано правильно, но при выводе на печать не выводится область данные
Если Склад = Справочники.Склады.ПустаяСсылка() Тогда
Сообщить("Вы не ввели никакго значения в поле склад!", СтатусСообщения.ОченьВажное);
КонецЕсли;

Если Подразделение = Справочники.Подразделения.ПустаяСсылка() Тогда
Сообщить("Вы не ввели никакго значения в поле подразделения!", СтатусСообщения.Обычное);
КонецЕсли;

Массив=Новый Массив;
//МояСтруктура=Новый Структура("группа");
Запрос = Новый Запрос;

Запрос.Текст ="ВЫБРАТЬ
              | РаспределениеНоменклатурыПоККТ.ГруппаНоменклатуры КАК группа
              |ИЗ
              | Справочник.РаспределениеНоменклатурыПоККТ КАК РаспределениеНоменклатурыПоККТ
              |ГДЕ
              | РаспределениеНоменклатурыПоККТ.Владелец = &Владелец";

Запрос.УстановитьПараметр("Владелец", Подразделение);




Выборка = Запрос.Выполнить ();

ВыборкаДетальныеЗаписи = Выборка.Выбрать();
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
Массив.Добавить(ВыборкаДетальныеЗаписи.группа);
КонецЦикла;

Для  Каждого Элемент из Массив Цикл
Сообщить(Элемент);
КонецЦикла;

// Список = Новый СписокЗначений;
//Пока Результат.Следующий() Цикл
//      Список.Добавить(Результат.Наименование);


//Вытащить группу товара в массив



ТабДок = новый ТабличныйДокумент;
Макет = ПолучитьМакет("Макет");
ОбластьШапки   = Макет.ПолучитьОбласть("Шапка");
ОбластьДанные  = Макет.ПолучитьОбласть("Данные");
ОбластьПодвал  = Макет.ПолучитьОбласть("Подвал");


ОбластьШапки.Параметры.Склад = Склад;
ОбластьШапки.Параметры.Ип = Подразделение;



ТабДок.Вывести(ОбластьШапки);

Запрос = Новый Запрос;

Запрос.Текст = "ВЫБРАТЬ
               | ТоварыВРозницеОстатки.КоличествоОстаток,
               | ТоварыВРозницеОстатки.СуммаПродажнаяОстаток,
               | ТоварыВРозницеОстатки.Номенклатура.Артикул,
               | ТоварыВРозницеОстатки.Склад,
               | ТоварыВРозницеОстатки.Номенклатура.Наименование КАК НоменклатураНаименование
               |ИЗ
               | РегистрНакопления.ТоварыВРознице.Остатки КАК ТоварыВРозницеОстатки
               |ГДЕ
               | ТоварыВРозницеОстатки.Склад = &Склад
               | И ТоварыВРозницеОстатки.Номенклатура В ИЕРАРХИИ(&Владелец)
               |
               |УПОРЯДОЧИТЬ ПО
               | НоменклатураНаименование";
               
             



Запрос.УстановитьПараметр("Склад", Склад);

    Запрос.УстановитьПараметр("Владелец", Подразделение);



//&Массив

Выборка = Запрос.Выполнить ().Выбрать ();

НомерПП = 1;
ИтогоСумма=0;
ИтогоКоличество =0;
Пока Выборка.Следующий() Цикл


ЗаполнитьЗначенияСвойств(ОбластьДанные.Параметры,Выборка);

ОбластьДанные.Параметры.НомерПП = НомерПП;
НомерПП = НомерПП + 1;




ИтогоСумма = ИтогоСумма + Выборка.СуммаПродажнаяОстаток;

ИтогоКоличество = ИтогоКоличество + Выборка.КоличествоОстаток;

Если Выборка.КоличествоОстаток = 0 Тогда
ОбластьДанные.Параметры.Цена = 0
Иначе
ОбластьДанные.Параметры.Цена= ОбластьДанные.Параметры.СуммаПродажнаяОстаток / ОбластьДанные.Параметры.КоличествоОстаток;
КонецЕсли;




ТабДок.Вывести(ОбластьДанные);
КонецЦикла;
ОбластьПодвал.Параметры.ИтогоСумма      = ИтогоСумма;
ОбластьПодвал.Параметры.ИтогоКоличество      = ИтогоКоличество;

ТабДок.Вывести(ОбластьПодвал);

ТабДок.Показать();

КонецПроцедуры


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
что понимается под "не выводит на печать"
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн RoDi

  • *
  • Сообщений: 37
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-07-05
  • Сайт: 
  • Профессия: Программист 1С
Внешняя печатная форма, то есть при нажатии на кнопку выполнить нажатие должна появляться внешняя печатная форма, где область данные не выводится почему-то
Добавлено: 15 Июл 2016, 10:46


Добавлено: 15 Июл 2016, 10:47


Добавлено: 15 Июл 2016, 10:49

вот картинка того что получается https://yadi.sk/i/qnVwy2VetKMDQ

Последний раз редактировалось: RoDi; 15 Июл 2016, 10:49. Причина: Объединение сообщений

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Видимо, здесь проблема:
Номенклатура В ИЕРАРХИИ(&Владелец)
.........                 
Запрос.УстановитьПараметр("Владелец", Подразделение)

Владелец - должна быть Номенклатура или группа Номенклатуры, а не Подразделение.
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн RoDi

  • *
  • Сообщений: 37
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-07-05
  • Сайт: 
  • Профессия: Программист 1С
Да проблема действительно здесь, но когда ставлю вместо подразделения группу номенклатуры или просто номенклатура, программа ругается говорит переменная не определена

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
По какой группе номенклатуры, собстно, вам надо выводить данные? Вот ее и укажите в параметрах
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн RoDi

  • *
  • Сообщений: 37
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-07-05
  • Сайт: 
  • Профессия: Программист 1С
а можно получить образец кода как это прописывается
Добавлено: 15 Июл 2016, 12:13

как то так?
	Запрос.УстановитьПараметр("Группа", Массив.Получить(Номенклатура);
Добавлено: 15 Июл 2016, 12:35

Нужно по группе которая есть в данном Подразделение

Последний раз редактировалось: RoDi; 15 Июл 2016, 12:35. Причина: Объединение сообщений

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Видимо, как-то так:
Номенклатура В ИЕРАРХИИ(&сзНоменклатура)
.........                 
Запрос.УстановитьПараметр("сзНоменклатура", Массив)
Только проверьте, в справочнике РаспределениеНоменклатурыПоККТ, какой тип у ГруппаНоменклатуры? Если СправочникСсылка.Номенклатура - то все хорошо, а если СправочникСсылка.ГруппыНоменклатуры, то второй запрос придется переписывать.
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн RoDi

  • *
  • Сообщений: 37
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-07-05
  • Сайт: 
  • Профессия: Программист 1С
Спасибо огромное))
всё работает))))


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
83 Сообщений
wise wise
63 Сообщений
Dethmontt Dethmontt
60 Сообщений
MuI_I_Ika MuI_I_Ika
51 Сообщений
alex0402
49 Сообщений
ilyay ilyay
32 Сообщений
Сергей Федоров Сергей Федоров
32 Сообщений
ilnur75
23 Сообщений
Дмитрий Медведков
19 Сообщений
magnifico61
18 Сообщений

* Кто онлайн

  • Точка Гостей: 326
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal