Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
28 Июл 2017, 15:43
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как сложить две переменных типа время  (Прочитано 487 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Семен Гетун

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-07-14
  • Сайт: 
:dfbsdfbsdf:

Как сложить две переменные типа время и кинуть их в реквизит ВремяПо???



Перем Время1 Экспорт;

&НаКлиенте
Процедура ВрачПриИзменении(Элемент)
   ВрачПриИзмененииНаСервере();
   
КонецПроцедуры

&НаСервере
Процедура ВрачПриИзмененииНаСервере()
      
Время1=объект.Врач.ИнтервалПриемаВМинутах;   
   
   
   
КонецПроцедуры


&НаКлиенте
Процедура ВремяСПриИзменении(Элемент)
   ВремяСПриИзмененииНаСервере();
КонецПроцедуры


&НаСервере
Процедура ВремяСПриИзмененииНаСервере()
   Объект.ВремяПо = окр((Время1+объект.ВремяС),1);
КонецПроцедуры



Оффлайн pavl_vs

  • *****
  • Сообщений: 1007
  • РЕПУТАЦИЯ: 160
  • КПД: 16%
  • Регистрация: 2011-05-09
  • Сайт: 
  • Профессия: Программист 7.7
Семен Гетун, как понимаю, речь идет типа о времени приема.
Переводите всё в секунды (целочисленный формат) - складывайте, вычитайте и т.п., а результат переводите в минуты.


Теги:
 

Значение поля "Лицевой счет" содержит недопустимое значение типа лицевого счета

Автор unantedРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 3561
Последний ответ 24 Июл 2012, 05:02
от unanted
При старте системы выдает ошибку ВнешняяОбработка.Платформа.МодульОбъекта(111):Значение не является значением объектного типа(ТипМножественноеЧисло) конфигурация Полный учет в отделе ИТ(2017.3.1)

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 174
Последний ответ 05 Июл 2017, 10:25
от Dethmontt
Значение не является значением объектного типа (Значение)

Автор НикитaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2627
Последний ответ 05 Мар 2014, 09:56
от KrivosheevEV
"Свой метод" типа Свернуть

Автор beztrudРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 3501
Последний ответ 17 Окт 2014, 12:44
от beztrud
Очистить значение типа "Хранилище значения"

Автор ЛеонидРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4423
Последний ответ 22 Ноя 2009, 17:45
от Никитина

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alex0402
96 Сообщений
oleg-x
75 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
66 Сообщений
Golickoff Golickoff
53 Сообщений
AIFrame
46 Сообщений
ilyay ilyay
40 Сообщений
Амал
30 Сообщений
MuI_I_Ika MuI_I_Ika
27 Сообщений
Dethmontt Dethmontt
22 Сообщений
lansy
22 Сообщений

* Кто онлайн

  • Точка Гостей: 789
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal