Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
28 Мар 2017, 07:23
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как сложить две переменных типа время  (Прочитано 344 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Семен Гетун

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-07-14
  • Сайт: 
:dfbsdfbsdf:

Как сложить две переменные типа время и кинуть их в реквизит ВремяПо???



Перем Время1 Экспорт;

&НаКлиенте
Процедура ВрачПриИзменении(Элемент)
   ВрачПриИзмененииНаСервере();
   
КонецПроцедуры

&НаСервере
Процедура ВрачПриИзмененииНаСервере()
      
Время1=объект.Врач.ИнтервалПриемаВМинутах;   
   
   
   
КонецПроцедуры


&НаКлиенте
Процедура ВремяСПриИзменении(Элемент)
   ВремяСПриИзмененииНаСервере();
КонецПроцедуры


&НаСервере
Процедура ВремяСПриИзмененииНаСервере()
   Объект.ВремяПо = окр((Время1+объект.ВремяС),1);
КонецПроцедуры



Оффлайн pavl_vs

  • *****
  • Сообщений: 943
  • РЕПУТАЦИЯ: 150
  • КПД: 16%
  • Регистрация: 2011-05-09
  • Сайт: 
  • Профессия: Программист 7.7
Семен Гетун, как понимаю, речь идет типа о времени приема.
Переводите всё в секунды (целочисленный формат) - складывайте, вычитайте и т.п., а результат переводите в минуты.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
153 Сообщений
alex0402
117 Сообщений
Norfolk
52 Сообщений
MuI_I_Ika MuI_I_Ika
50 Сообщений
LexaK
46 Сообщений
друган
20 Сообщений
alexandr_ll
20 Сообщений
AsadRoman
20 Сообщений
Константин5825
18 Сообщений
MrLvovsky MrLvovsky
16 Сообщений

* Кто онлайн

  • Точка Гостей: 430
  • Точка Скрытых: 0
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal