Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
21 июн 2021, 03:07

Как сложить две переменных типа время

Автор Семен Гетун, 14 июл 2016, 16:34

0 Пользователей и 1 гость просматривают эту тему.

Семен Гетун

:dfbsdfbsdf:

Как сложить две переменные типа время и кинуть их в реквизит ВремяПо???



Перем Время1 Экспорт;

&НаКлиенте
Процедура ВрачПриИзменении(Элемент)
   ВрачПриИзмененииНаСервере();
   
КонецПроцедуры

&НаСервере
Процедура ВрачПриИзмененииНаСервере()
      
Время1=объект.Врач.ИнтервалПриемаВМинутах;   
   
   
   
КонецПроцедуры


&НаКлиенте
Процедура ВремяСПриИзменении(Элемент)
   ВремяСПриИзмененииНаСервере();
КонецПроцедуры


&НаСервере
Процедура ВремяСПриИзмененииНаСервере()
   Объект.ВремяПо = окр((Время1+объект.ВремяС),1);
КонецПроцедуры


pavl_vs

Семен Гетун, как понимаю, речь идет типа о времени приема.
Переводите всё в секунды (целочисленный формат) - складывайте, вычитайте и т.п., а результат переводите в минуты.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск