Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Окт 2017, 09:21
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выгрузка в XML  (Прочитано 853 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн xdto

  • ***
  • Сообщений: 101
  • РЕПУТАЦИЯ: 7
  • КПД: 7%
  • Регистрация: 2015-10-01
  • Сайт: 
  • Профессия: Программист 1С
Друзья подскажите как выгрузить в XML формат данные
есть справочник с ревизитами код, наименование, пол, форме списка
и в нижней части формы списка есть динамический список с таблицей
регистра сведений с полями тип,вид, представление увидите на скрине ниже
так вот как мне выгрузить данные этих полей а именно код, наименование,пол тип, вид представление
Списибо


Вот та я выгружаю Код ,Наименование, Пол    -- поля справочника
 
ЗаписьXML = Новый ЗаписьXML;
ЗаписьXML.ОткрытьФайл("Z:\client.xml");
ЗаписьXML.ЗаписатьОбъявлениеXML();
ЗаписьXML.ЗаписатьНачалоЭлемента("Корневой");
ЗаписьXML.ЗаписатьАтрибут("ИмяСправочника", "Клиенты");
ЗаписьXML.ЗаписатьКомментарий("Выгрузка элементов справочника");
СтрокиКлиенты = ПолучитьСтрокиКлиенты();
Для Каждого Строка Из СтрокиКлиенты Цикл      Значение = РазобратьСтроку(Строка);
ЗаписьXML.ЗаписатьНачалоЭлемента("ЭлементСправочника");

ЗаписьXML.ЗаписатьНачалоЭлемента("Наименование");
ЗаписьXML.ЗаписатьТекст(Значение.Наименование);
ЗаписьXML.ЗаписатьКонецЭлемента();

ЗаписьXML.ЗаписатьНачалоЭлемента("Код");
ЗаписьXML.ЗаписатьТекст(Значение.Код);
ЗаписьXML.ЗаписатьКонецЭлемента();

ЗаписьXML.ЗаписатьНачалоЭлемента("Пол");
ЗаписьXML.ЗаписатьТекст(Значение.Пол);
ЗаписьXML.ЗаписатьКонецЭлемента();

КонецЦикла;     
ЗаписьXML.ЗаписатьКонецЭлемента();
ЗаписьXML.Закрыть()

А как остальные поля выгрузить не знаю поля из регистра сведений



Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1098
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: Выгрузка в XML
« Ответ #1: 14 Июл 2016, 09:48 »
повторение - мать заикания? :angry: :^454^: :thwrt: ui;;t;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн xdto

  • ***
  • Сообщений: 101
  • РЕПУТАЦИЯ: 7
  • КПД: 7%
  • Регистрация: 2015-10-01
  • Сайт: 
  • Профессия: Программист 1С
Re: Выгрузка в XML
« Ответ #2: 14 Июл 2016, 10:16 »
Да:D:D:D:D

А так не получил ответа адекватного просто
Добавлено: 14 Июл 2016, 10:17

Прощу помочь мне с этим делом

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1098
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Re: Выгрузка в XML
« Ответ #3: 14 Июл 2016, 11:06 »
вполне себе адекватно LexaK отвечал... :kmtu:
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн LexaK

  • *****
  • Сообщений: 1259
  • РЕПУТАЦИЯ: 345
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
Re: Выгрузка в XML
« Ответ #4: 14 Июл 2016, 11:16 »
cska-fanat-kz,
Просто пользователь перепутал раздел форума! Ему надо в раздел фрилансеров, там ему сразу сделают готовое решение!
В этом разделе, пользователю подсказывают решение, показывают пути решения, остальное надо додумать/доделать задачу самому пользователю.
Просто xdto не умеет / не хочет думать/программировать. :dfbbdrfb: 
Такое тоже бывает. :D
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн xdto

  • ***
  • Сообщений: 101
  • РЕПУТАЦИЯ: 7
  • КПД: 7%
  • Регистрация: 2015-10-01
  • Сайт: 
  • Профессия: Программист 1С
Re: Выгрузка в XML
« Ответ #5: 14 Июл 2016, 11:33 »
Если LexaK ответил адекватно тогда скажите почему этот код LexaK выгружает данные без остановки пока не прервешь работу программы  через диспетчер задач??
Добавлено: 14 Июл 2016, 11:34

Я не ищу готовое решение хочу что бы подсказали где копать
Добавлено: 14 Июл 2016, 11:42

Вот таким кодом еще работает
ЗаписьXML = Новый ЗаписьXML;
ЗаписьXML.ОткрытьФайл("c:\document.xml");

// Записать директиву
ЗаписьXML.ЗаписатьОбъявлениеXML();

// Записать начало корневого элемента
ЗаписьXML.ЗаписатьНачалоЭлемента("Корневой");

// Записать атрибут корневого элемента
ЗаписьXML.ЗаписатьАтрибут("ИмяСправочника", "Клиенты");

ЗаписьXML.ЗаписатьКомментарий("Выгрузка элементов справочника");

СтрокиКлиенты = ПолучитьСтрокиКлиенты();
Для Каждого Строка Из СтрокиКлиенты Цикл
    Значение = РазобратьСтроку(Строка);
   
ЗаписьXML.ЗаписатьНачалоЭлемента("ЭлементСправочника");
               
ЗаписьXML.ЗаписатьНачалоЭлемента("Наименование");
ЗаписьXML.ЗаписатьТекст(Значение.Наименование);
ЗаписьXML.ЗаписатьКонецЭлемента();

ЗаписьXML.ЗаписатьНачалоЭлемента("Код");
ЗаписьXML.ЗаписатьТекст(Значение.Код);
ЗаписьXML.ЗаписатьКонецЭлемента();

ЗаписьXML.ЗаписатьНачалоЭлемента("Пол");
ЗаписьXML.ЗаписатьТекст(Значение.Пол);
ЗаписьXML.ЗаписатьКонецЭлемента();

ЗаписьXML.ЗаписатьКонецЭлемента();
     КонецЦикла;



          СтрокиКИ = ПолучитьСтрокиКИ();
  Для Каждого СтрокаКИ Из СтрокиКИ Цикл
ЗначениеКИ = РазобратьСтрокуКИ(СтрокаКИ);


//Начало записи КИ
ЗаписьXML.ЗаписатьНачалоЭлемента("КонтактнаяИнформация");

ЗаписьXML.ЗаписатьНачалоЭлемента("Тип");
ЗаписьXML.ЗаписатьТекст(ЗначениеКИ.Тип);
ЗаписьXML.ЗаписатьКонецЭлемента();

ЗаписьXML.ЗаписатьНачалоЭлемента("Вид");
ЗаписьXML.ЗаписатьТекст(ЗначениеКИ.Вид);
ЗаписьXML.ЗаписатьКонецЭлемента();

ЗаписьXML.ЗаписатьНачалоЭлемента("Представление");
ЗаписьXML.ЗаписатьТекст(ЗначениеКИ.Представление);
ЗаписьXML.ЗаписатьКонецЭлемента();
             

ЗаписьXML.ЗаписатьКонецЭлемента();
      КонецЦикла;
    ЗаписьXML.Закрыть();
Но в файле он сперва выгружает код наименование пол

-<ЭлементСправочника>

<Наименование>Алексей</Наименование>

<Код>00004741</Код>

<Пол>Мужской</Пол>

................

в конец
<КонтактнаяИнформация>
      <Тип>Телефон</Тип>
      <Вид>Сотовый телефон</Вид>
      <Представление>95718351112</Представление>

А мне нужно что это было вместе
типа как бы так

<Наименование>Алексей</Наименование>
<Код>00004741</Код>
<Пол>Мужской</Пол>
<Тип>Телефон</Тип>
<Вид>Сотовый телефон</Вид>
<Представление>95718351112</Представление>

Последний раз редактировалось: xdto; 14 Июл 2016, 11:44

Оффлайн LexaK

  • *****
  • Сообщений: 1259
  • РЕПУТАЦИЯ: 345
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
Re: Выгрузка в XML
« Ответ #6: 14 Июл 2016, 12:09 »
xdto, а может ну его на фиг, это программирование?
вы даже код примера правильно скопировать не можете!
при этом САМИ делаете кучу ошибок, и говорите что кто-то виноват что у вас все криво работает! :befhbt:

Вот код примера, как в детской задачке найдите несколько отличий!


...

СтрокиКлиенты = ПолучитьСтрокиКлиенты();
Для Каждого Строка Из СтрокиКлиенты Цикл
Значение = РазобратьСтроку(Строка);
ЗаписьXML.ЗаписатьНачалоЭлемента("ЭлементСправочника");

ЗаписьXML.ЗаписатьНачалоЭлемента("Наименование");
ЗаписьXML.ЗаписатьТекст(Значение.Наименование);
ЗаписьXML.ЗаписатьКонецЭлемента();

ЗаписьXML.ЗаписатьНачалоЭлемента("Код");
ЗаписьXML.ЗаписатьТекст(Значение.Код);
ЗаписьXML.ЗаписатьКонецЭлемента();

ЗаписьXML.ЗаписатьНачалоЭлемента("Пол");
ЗаписьXML.ЗаписатьТекст(Значение.Пол);
ЗаписьXML.ЗаписатьКонецЭлемента();

    //здесь дополнительный код по выводу КИ, почти все тоже самое что и при выводе Контрагента
    СтрокиКИ = ПолучитьСтрокиКИ(Строка); //получаем строки РС по текущему контрагенту Строка.Контрагент
    Для Каждого СтрокаКИ Из СтрокиКИ Цикл
    ЗначениеКИ = РазобратьСтрокуКИ(СтрокаКИ);

    //Начало записи КИ
    ЗаписьXML.ЗаписатьНачалоЭлемента("КонтактнаяИнформация");

    ЗаписьXML.ЗаписатьНачалоЭлемента("Тип");
    ЗаписьXML.ЗаписатьТекст(ЗначениеКИ.Тип);
    ЗаписьXML.ЗаписатьКонецЭлемента();

    ЗаписьXML.ЗаписатьНачалоЭлемента("Вип");
    ЗаписьXML.ЗаписатьТекст(ЗначениеКИ.Вип);
    ЗаписьXML.ЗаписатьКонецЭлемента();

    ЗаписьXML.ЗаписатьНачалоЭлемента("Представление");
    ЗаписьXML.ЗаписатьТекст(ЗначениеКИ.Представление);
    ЗаписьXML.ЗаписатьКонецЭлемента();

    //завершение записи КИ
    ЗаписьXML.ЗаписатьКонецЭлемента();
    КонецЦикла;     

//перенесено в цикл, как пара элементу
ЗаписьXML.ЗаписатьКонецЭлемента();

КонецЦикла;     
//обрано, возможна ошибка
//ЗаписьXML.ЗаписатьКонецЭлемента();

...

Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн xdto

  • ***
  • Сообщений: 101
  • РЕПУТАЦИЯ: 7
  • КПД: 7%
  • Регистрация: 2015-10-01
  • Сайт: 
  • Профессия: Программист 1С
Re: Выгрузка в XML
« Ответ #7: 14 Июл 2016, 13:06 »
Уважаемый LexaK причем тут скопировать я же не маленький ребенок
дело в том что Ваш код выгружает файлы без остановки понимаете меня
Как это понимать
А этот код подправленный мной который выкладывал
 


Теги:
 

выгрузка из "Платежные документы" выборочно в "Бухгалтерию предприятия"

Автор hkvРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 3879
Последний ответ 09 Окт 2014, 15:58
от дфтын
Выгрузка Бух учет из "Зарплаты и управления персоналом 8" в "1С:Бухгалтерию 8"

Автор KazakOFFРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2281
Последний ответ 10 Ноя 2015, 16:20
от vitasw
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8338
Последний ответ 26 Апр 2012, 23:08
от Dethmontt
Модуль "выгрузка в банк"

Автор Dima IgnatovРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 878
Последний ответ 11 Май 2016, 13:23
от Rasty
Выгрузка из "Зарплата и кажпы" платеж за три месяца

Автор vlasssov71Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 1159
Последний ответ 07 Июл 2015, 15:19
от vlasssov71

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
86 Сообщений
alex0402
49 Сообщений
AIFrame
43 Сообщений
Oldman06
31 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
30 Сообщений
vitasw
29 Сообщений
Golickoff Golickoff
28 Сообщений
MuI_I_Ika MuI_I_Ika
18 Сообщений
DmitriyF DmitriyF
14 Сообщений
BuhRust
13 Сообщений

* Кто онлайн

  • Точка Гостей: 215
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal