Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
28 Май 2017, 03:59
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ошибка в коде при вводе на основания  (Прочитано 273 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн demon1650

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-09-09
  • Сайт: 
кто поможет?
При вводе из внутреннего заказа но основании заказ поставщику выдает ошибку. ({Документ.ЗаказПоставщику.МодульОбъекта(2634,1)}: Ожидается ключевое слово 'КонецПроцедуры' ('EndProcedure')
<<?>>ИначеЕсли ТипЗнч(Основание) = Тип("ДокументСсылка.ВнутреннийЗаказ") Тогда
{Документ.ЗаказПоставщику.МодульОбъекта(2652,14)}: Обнаружено логическое завершение исходного текста модуля
    КонецЦикла;<<?>>
)
//////////////////////////////////////////////////////////////////////////

Процедура ОбработкаЗаполнения(Основание)
    ДокументОснование = Основание;
   ВидОперации = Перечисления.ВидыОперацийЗаказПоставщику.ПокупкаКомиссия;
   Если ТипЗнч(Основание) = Тип("ДокументСсылка.Событие") Тогда
      // Заполнение шапки
      КонтактноеЛицоКонтрагента = Основание.КонтактноеЛицо;
      Контрагент     = Основание.Контрагент;
      Организация      = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию( глЗначениеПеременной("глТекущийПользователь"), "ОсновнаяОрганизация");
      ЗаполнениеДокументов.ПриИзмененииЗначенияКонтрагента(ЭтотОбъект);

   ИначеЕсли ТипЗнч(Основание) = Тип("ДокументСсылка.ЗаказПокупателя") Тогда
      
      // Заполнение шапки
      ВалютаДокумента                   = Основание.ВалютаДокумента;
      ИспользоватьПлановуюСебестоимость = Основание.ИспользоватьПлановуюСебестоимость;
      ИтогПлановаяСебестоимость         = Основание.ИтогПлановаяСебестоимость;
      Комментарий                       = Основание.Комментарий;
      КратностьВзаиморасчетов           = Основание.КратностьВзаиморасчетов;
      КурсВзаиморасчетов                = Основание.КурсВзаиморасчетов;
      Подразделение                     = Основание.Подразделение;
      СтруктурнаяЕдиница                = Основание.СтруктурнаяЕдиница;
      СуммаВключаетНДС                  = Основание.СуммаВключаетНДС;
      СуммаДокумента                    = Основание.СуммаДокумента;
      УчитыватьНДС                      = Основание.УчитыватьНДС;
      
      Склад = ?(ТипЗнч(Основание.СкладГруппа) = Тип("СправочникСсылка.Склады"), Основание.СкладГруппа, Неопределено);
      Если НЕ ЗначениеЗаполнено(Склад) Тогда
         Склад = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(глЗначениеПеременной("глТекущийПользователь"), "ОсновнойСклад");
      КонецЕсли;
      #Если Клиент Тогда
      Если НЕ ЗначениеЗаполнено(Склад) Тогда
         ВвестиЗначение(Склад, "Выберите склад", Тип("СправочникСсылка.Склады"));
      КонецЕсли;
      #КонецЕсли
      
      Если Основание.ВидОперации = Перечисления.ВидыОперацийЗаказПокупателя.Переработка Тогда
         ВидОперации = Перечисления.ВидыОперацийЗаказПоставщику.Переработка;
      Иначе
         ВидОперации = Перечисления.ВидыОперацийЗаказПоставщику.ПокупкаКомиссия;
      КонецЕсли;
      ОрганизацияКонтрагента = ЗаполнениеДокументов.ПолучитьОрганизациюПоКонтрагенту(Основание.Контрагент);
      Если ЗначениеЗаполнено(ОрганизацияКонтрагента) Тогда  //межфирменные продажи - просто копируем табличные части

         Контрагент  = ЗаполнениеДокументов.ПолучитьКонтрагентаПоОрганизации( Основание.Организация);
         Организация = ЗаполнениеДокументов.ПолучитьОрганизациюПоКонтрагенту( Основание.Контрагент);
         
         ЗаполнениеДокументов.ПриИзмененииЗначенияКонтрагента(ЭтотОбъект);
         СкопироватьТабличнуюЧасть(Основание, "ВозвратнаяТара");
         СкопироватьТабличнуюЧасть(Основание, "Материалы");
         СкопироватьТабличнуюЧасть(Основание, "Товары");
         СкопироватьТабличнуюЧасть(Основание, "Услуги");

      ИначеЕсли Основание.ВидОперации = Перечисления.ВидыОперацийЗаказПокупателя.Переработка Тогда
         Организация = Основание.Организация;
             //копируем табличные части
         СкопироватьТабличнуюЧасть(Основание, "ВозвратнаяТара");
         СкопироватьТабличнуюЧасть(Основание, "Материалы");
         СкопироватьТабличнуюЧасть(Основание, "Товары");
         СкопироватьТабличнуюЧасть(Основание, "Услуги");

      Иначе   
         Организация = Основание.Организация;

         //переносим в документ необеспеченную часть заказа покупателя
         ЗаполнитьТабличнуюЧастьНеобеспеченнойЧастьюЗаказа(Товары, Основание);
         ЗаполнитьТабличнуюЧастьНеобеспеченнойЧастьюЗаказа(ВозвратнаяТара, Основание);
      КонецЕсли;
      
   ИначеЕсли ТипЗнч(Основание) = Тип("ДокументСсылка.СчетНаОплатуПоставщика") Тогда

      // Заполнение шапки
      ВалютаДокумента    = Основание.ВалютаДокумента;
      ВремяНапоминания   = Основание.ВремяНапоминания;
      ДатаОплаты         = Основание.ДатаОплаты;
      ДатаПоступления    = Основание.ДатаПоступления;
      ДоговорКонтрагента = Основание.ДоговорКонтрагента;
      ИспользоватьПлановуюСебестоимость = Основание.ИспользоватьПлановуюСебестоимость;
      ИтогПлановаяСебестоимость         = Основание.ИтогПлановаяСебестоимость;
      КратностьВзаиморасчетов           = Основание.КратностьВзаиморасчетов;
      Комментарий             = Основание.Комментарий;
      КонтактноеЛицоКонтрагента         = Основание.КонтактноеЛицоКонтрагента;
      Контрагент              = Основание.Контрагент;
      КурсВзаиморасчетов = Основание.КурсВзаиморасчетов;
      НапомнитьОСобытии  = Основание.НапомнитьОСобытии;
      Организация        = Основание.Организация;
      Подразделение      = Основание.Подразделение;
      Склад              = Основание.Склад;
      СтруктурнаяЕдиница = Основание.СтруктурнаяЕдиница;
      СуммаВключаетНДС   = Основание.СуммаВключаетНДС;
      СуммаДокумента     = Основание.СуммаДокумента;
      ТипЦен             = Основание.ТипЦен;
      УчитыватьНДС       = Основание.УчитыватьНДС;
      Если Основание.Оборудование.Количество()>0 Тогда
         ВидОперации = Перечисления.ВидыОперацийЗаказПоставщику.Оборудование;
      КонецЕсли;
      
      УправлениеЗаказами.УстановитьДатуОплатыПоДоговору(ЭтотОбъект);
        СкопироватьТабличнуюЧасть(Основание, "ВозвратнаяТара");
      СкопироватьТабличнуюЧасть(Основание, "Оборудование");
      СкопироватьТабличнуюЧасть(Основание, "Товары");
      СкопироватьТабличнуюЧасть(Основание, "Услуги");
   КонецЕсли;
   
   ///// 13/07/2016
   
ИначеЕсли ТипЗнч(Основание) = Тип("ДокументСсылка.ВнутреннийЗаказ") Тогда
   // Заполнение шапки
   ВремяНапоминания = ДанныеЗаполнения.ВремяНапоминания;
   Комментарий = ДанныеЗаполнения.Комментарий;
   НапомнитьОСобытии = ДанныеЗаполнения.НапомнитьОСобытии;
   НоменклатурнаяГруппа = ДанныеЗаполнения.НоменклатурнаяГруппа;
   Организация = ДанныеЗаполнения.Организация;
   Ответственный = ДанныеЗаполнения.Ответственный;
   Подразделение = ДанныеЗаполнения.Подразделение;
   
   
   Для Каждого ТекСтрокаТовары Из ДанныеЗаполнения.Товары Цикл
      НоваяСтрока = Товары.Добавить();
      НоваяСтрока.ЕдиницаИзмерения = ТекСтрокаТовары.ЕдиницаИзмерения;
      НоваяСтрока.ЕдиницаИзмеренияМест = ТекСтрокаТовары.ЕдиницаИзмеренияМест;
      НоваяСтрока.Количество = ТекСтрокаТовары.Количество;
      НоваяСтрока.КоличествоМест = ТекСтрокаТовары.КоличествоМест;
      НоваяСтрока.Коэффициент = ТекСтрокаТовары.Коэффициент;
      НоваяСтрока.Номенклатура = ТекСтрокаТовары.Номенклатура;
      НоваяСтрока.ХарактеристикаНоменклатуры = ТекСтрокаТовары.ХарактеристикаНоменклатуры;
   КонецЦикла;
КонецЕсли;

КонецПроцедуры // ОбработкаЗаполнения()
/////////////////////////////////////////////////////////////////
В чем может быть проблема? Ключевое слово вроде есть.


Теги:
 

При открытии обр-ки в "Предприятии" есть ошибка, а в "Отладке" нет

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3963
Последний ответ 21 Сен 2011, 17:35
от proofet
ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 5228
Последний ответ 06 Июн 2012, 09:15
от lindelu
Синтаксическая ошибка "В" Номенклатура.Ссылка = <<?>> В ИЕРАРХИИ(&Ссылка)

Автор maskitoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 3553
Последний ответ 28 Апр 2014, 15:53
от maskito
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 6688
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 7645
Последний ответ 26 Апр 2012, 23:08
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
83 Сообщений
wise wise
63 Сообщений
Dethmontt Dethmontt
60 Сообщений
MuI_I_Ika MuI_I_Ika
51 Сообщений
alex0402
49 Сообщений
ilyay ilyay
32 Сообщений
Сергей Федоров Сергей Федоров
32 Сообщений
ilnur75
22 Сообщений
Дмитрий Медведков
19 Сообщений
magnifico61
18 Сообщений

* Кто онлайн

  • Точка Гостей: 196
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal