Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Янв 2017, 22:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Округление суммы  (Прочитано 408 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dmitrij

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-07-12
  • Сайт: 
  • Профессия: Ученик 1С
Есть проблема. в 1с 8.3 УТ1.1 необходимо сделать округление итоговой суммы со скидкой. Само округление я сделал, но оно работает только с проведенным документом. не могу понять где нужно поправить в конфигураторе чтобы при оформлении заказа покупателя со скидкой работало округление до целого числа (т.е. без копеек). вот то что я сделал
Процедура РассчитатьСуммуТабЧасти(СтрокаТабличнойЧасти, ДокументОбъект, СпособРасчета = Неопределено) Экспорт

ИмяТабличнойЧасти = ОбщегоНазначения.ПолучитьИмяТабличнойЧастиПоСсылкеНаСтроку(СтрокаТабличнойЧасти);

МетаданныеДокумента = ДокументОбъект.Метаданные();

   Сумма = СтрокаТабличнойЧасти.Цена * СтрокаТабличнойЧасти.Количество;
   СуммаСкидки = 0;

   Если (СпособРасчета = Неопределено)
    Или (СпособРасчета = Перечисления.СпособРасчетаСуммыДокумента.СУчетомВсехСкидок)
    Или (СпособРасчета = Перечисления.СпособРасчетаСуммыДокумента.БезУчетаРучнойСкидки) Тогда
      Если ОбщегоНазначения.ЕстьРеквизитТабЧастиДокумента("ПроцентАвтоматическихСкидок", МетаданныеДокумента, ИмяТабличнойЧасти) Тогда
         СуммаСкидки = Сумма * СтрокаТабличнойЧасти.ПроцентАвтоматическихСкидок / 100;
      КонецЕсли;

      Если (СпособРасчета <> Перечисления.СпособРасчетаСуммыДокумента.БезУчетаРучнойСкидки)Тогда
Если ОбщегоНазначения.ЕстьРеквизитТабЧастиДокумента("ПроцентСкидкиНаценки", МетаданныеДокумента, ИмяТабличнойЧасти) Тогда
      СуммаСкидки = СуммаСкидки + (Сумма * СтрокаТабличнойЧасти.ПроцентСкидкиНаценки / 100);
         КонецЕсли;
      КонецЕсли;
   КонецЕсли;

   СтрокаТабличнойЧасти.Сумма = Сумма - СуммаСкидки; 
СтрокаТабличнойЧасти.Сумма = Окр(СтрокаТабличнойЧасти.Сумма, 0);
КонецПроцедуры // РассчитатьСуммуТабЧасти()


Оффлайн LexaK

  • *****
  • Сообщений: 1084
  • РЕПУТАЦИЯ: 284
  • КПД: 26%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
Re: Округление суммы
« Ответ #1: 13 Июл 2016, 10:05 »
попробуйте такой вариант, в модуле документа Заказ в событии ПереЗаписью вставить округление.
Затем просто перепроведите или перезапишите те заявки, которые необходимо пересчитать.
будет срабатывать независимо от признака проведенности.

Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)

    //общее округление суммы
    Для каждого лкСтр Из Товары Цикл
        лкСтр.Сумма =  Окр(лкСтр.Сумма, 0);
    КонецЦикла;

    ...

КонецПроцедуры


Помогло? - Нажми СПАСИБО!!!
                       :)


Теги:
 

Как правильно ввести услугу "страховка груза" (рассчитывается процентом от указанной суммы)

Автор ElenaAlmazРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 1586
Последний ответ 28 Окт 2014, 15:26
от ElenaAlmaz
Обработка "Регистрация счетов-фактур на аванс" не видит суммы зачета авансов.

Автор omahiРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 1906
Последний ответ 21 Апр 2015, 21:21
от omahi
Задать отображение суммы в отчёте "Анализ счёта" и подобных ему

Автор stardragonРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 1534
Последний ответ 05 Апр 2011, 20:49
от stardragon
Минфин напомнил правопреемникам о порядке учета в расходах суммы убытка, полученного присоединенной организацией

Автор newsРаздел Новости

Ответов: 0
Просмотров: 211
Последний ответ 28 Июл 2016, 02:15
от news
бухгалтерия 8.3 при закрытии месяца и групповом перепроведении исчезают суммы в проводках в выписке банка

Автор glawbuh-litРаздел Пользователям "1С - Предприятие 8"

Ответов: 5
Просмотров: 2681
Последний ответ 28 Мар 2014, 18:10
от MuI_I_Ika

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
159 Сообщений
alex0402
63 Сообщений
MuI_I_Ika MuI_I_Ika
47 Сообщений
crow1983
35 Сообщений
LexaK
32 Сообщений
alexandr_ll
32 Сообщений
sertak sertak
27 Сообщений
Vzonder
22 Сообщений
BuhRust
19 Сообщений
дфтын дфтын
17 Сообщений

* Кто онлайн

  • Точка Гостей: 257
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal