Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Апр 2018, 23:39
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Форма выбора с открытием предопределенной группы  (Прочитано 2164 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Arhat

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-06-09
  • Сайт: 
  • Профессия: Консультант 1С
Пытаюсь открыть форму выбора определенной группы справочника:

    	&НаКлиенте
Процедура ДокументОрганизацияНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)

СтандартнаяОбработка = Ложь;
ФормаВыбора = ПолучитьФорму("Справочник.ЮридическиеЛица.ФормаВыбора");
ПараметрыФормы = Новый Структура("Отбор", Новый Структура("Родитель", ПредопределенноеЗначение("Справочник.ЮридическиеЛица.ПаспортныеСтолы")));
ОткрытьФормуМодально(ФормаВыбора, ПараметрыФормы);

КонецПроцедуры

Форма открывается, но в корне списка:



Что я делаю не так?


Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Расширение управляемой формы для динамического списка (Managed form extension for dynamic lists)
ТекущаяСтрока (CurrentRow)
Описание:

Строка динамического списка, на которую будет установлен курсор после открытия формы.
В качестве значения для параметра используются значения ссылок на объекты, которые содержит главная таблица динамического списка. Например, СправочникСсылка.Товары.

Оффлайн Arhat

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-06-09
  • Сайт: 
  • Профессия: Консультант 1С
Если так:
	СтандартнаяОбработка = Ложь;
ФормаВыбора = ПолучитьФорму("Справочник.ЮридическиеЛица.ФормаВыбора");
ПараметрыФормы = Новый Структура("ТекущаяСтрока", ПредопределенноеЗначение("Справочник.ЮридическиеЛица.ПаспортныеСтолы"));
ОткрытьФормуМодально(ФормаВыбора, ПараметрыФормы);

Результат тот же.

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Пытаюсь открыть форму выбора определенной группы справочника:
вам нужно спозиционироваться на какую-то строку или открыть форму с отбором?

Оффлайн Arhat

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-06-09
  • Сайт: 
  • Профессия: Консультант 1С
вам нужно спозиционироваться на какую-то строку или открыть форму с отбором?
Открыть определенную папку справочника в форме выбора.

Оффлайн cobra77777

  • ***
  • Сообщений: 168
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
Как пример - работающий. Докрутите, если нужно. Получиться буду очень рад.

&НаКлиенте
Процедура НачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
   
  Если объект.Сотрудникавтоматизации.Пустая() Тогда
    СтандартнаяОбработка=Ложь;
    ПараметрыФормы = Новый Структура;
    ПараметрыФормы.Вставить("ТекущаяСтрока", ПоискРодителяСотрудники("ФИО - как пример"));
    ФормаВыбора = ПолучитьФорму("Справочник.ЮридическиеЛица.ФормаВыбора", ПараметрыФормы,Элемент);
    ФормаВыбора.ОткрытьМодально();
  КонецЕсли;

КонецПроцедуры

&НаСервере
Функция ПоискРодителяСотрудники(НаименованиеГр)
   Спр=Справочники.Сотрудники.НайтиПоНаименованию(НаименованиеГр);
   Возврат Спр;
КонецФункции

Оффлайн Arhat

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-06-09
  • Сайт: 
  • Профессия: Консультант 1С
Пример рабочий, но не совсем то что нужно. При таком варианте я обращаюсь к элементу находящемуся в группе, а если группа пустая и нужно просто открыть справочник с раскрытой группой для добавления в нее нового элемента? К тому же группы у меня предопределены, а вот какие элементы в них будут мне неизвестно, поэтому и обратиться к ним из модуля я не могу. Проще говоря мне нужно получить вот такое окно:

Последний раз редактировалось: Arhat; 06 Июл 2016, 08:33

Оффлайн vitasw

  • *****
  • Сообщений: 2575
  • РЕПУТАЦИЯ: 311
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
В таком случае, думаю, что не получится


Теги:
 

Печатная форма "ЧекККМ" для "Отчета о розничных продажах"

Автор Игорь ПолищукРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 7440
Последний ответ 01 Июн 2011, 20:39
от Шурыгин Иван Сергеевич
УТ 11.3 форма "УправлениеЭквайринговымТерминалом"

Автор skelaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 199
Последний ответ 09 Фев 2018, 21:23
от Геннадий ОбьГЭС
Внешняя обработка (внешняя печатная форма УТ ЗаказПокупателя)

Автор RusadmРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4538
Последний ответ 27 Май 2011, 15:23
от cska-fanat-kz
Печатная форма "Акт сверки взаиморасчетов"

Автор NikolosРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4559
Последний ответ 11 Сен 2012, 08:18
от Nikolos
Форма "Взнос наличными в банк" где она :)

Автор lefantiy_94Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 5414
Последний ответ 30 Июн 2015, 03:50
от lefantiy_94

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
alex0402
69 Сообщений
AIFrame AIFrame
63 Сообщений
oleg-x
42 Сообщений
alexandr_ll
41 Сообщений
pavl_vs
21 Сообщений
BuhRust
20 Сообщений
KOI8-R
16 Сообщений
Sheriff
13 Сообщений
Sandi Sandi
12 Сообщений

* Кто онлайн

  • Точка Гостей: 269
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal