Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 05:53
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Удаление ненужных записей  (Прочитано 2547 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Vlad1m1r19

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-07-23
  • Сайт: 
Здравствуйте..
Помигите ПЛЗ..
Есть справочник Номенклатура.
Есть поле размер, получается много повторных моделей с разными размерами.
Как мне с Оставить только одно значение? (к примеру :модель с60, размер 40; модель с60, размер 41; модель с60, размер 42 И таких записей оч. много. Мне нужно оставить только одну модель с60)


Оффлайн Vlad1m1r19

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-07-23
  • Сайт: 
Разобрался, скину код, может кому понадобится:
Процедура Сформировать()
   Спр = СоздатьОбъект("Справочник.Номенклатура");
   Наим1 = "";
   Спр.ВыбратьЭлементы();
   Пока Спр.ПолучитьЭлемент() = 1 Цикл
      Если Спр.ЭтоГруппа() = 1 Тогда Продолжить;    КонецЕсли;
      Если Спр.ПометкаУдаления() = 1 Тогда Продолжить; КонецЕсли;
      Если Наим1 <> СокрЛП(СПР.Наименование) Тогда Наим1 = СокрЛП(СПР.Наименование); Продолжить;
      КонецЕсли;
      Спр.удалить(0);
      Спр.Записать();
   КонецЦикла;
КонецПроцедуры

Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
А если удаленная модель у вас была уже задействована в каком-либо документе?

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
и вообще сыро


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
175 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
AIFrame
39 Сообщений
andron81_81
38 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 287
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal