Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Мар 2017, 01:10
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Запись в субконто по отбору  (Прочитано 428 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Alex117-117

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-01
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день, Друзья !
у меня мало опыта в 1с, помогите решить проблемму.
есть БГУ, нужно по отбору запроса установить новые записи в проводках - изменить договор


Процедура КнопкаВыполнитьНажатие(Кнопка)
   Если Справочники.Договоры.НайтиПоНаименованию("ТЕСТ_Договор").Пустая() Тогда
      НовыйДоговор = Справочники.Договоры.СоздатьЭлемент();
      НовыйДоговор.Наименование = "ТЕСТ_Договор";
      НовыйДоговор.Учреждение = Справочники.Организации.НайтиПоКоду("00009 ");
      НовыйДоговор.ВидОбязательства = Справочники.ВидыПервичныхДокументов.НайтиПоНаименованию("Договор");
      НовыйДоговор.Записать();
      Сообщить("Создан договор "+НовыйДоговор);
   КонецЕсли;
   Запрос = Новый Запрос;                                     
   Запрос.Текст =
   "ВЫБРАТЬ РАЗЛИЧНЫЕ                                                   
   |   ЕПСБУДвиженияССубконто.Регистратор КАК Док
   |ИЗ                                                                   
   |   РегистрБухгалтерии.ЕПСБУ.ДвиженияССубконто(                               
   |         ДАТАВРЕМЯ(2016, 1, 1),                             
   |         ,                                                                   
   |         (Счет.Код = ""206.91""                                   
   |            ИЛИ Счет.Код = ""302.91"")                       
   |            И КБК.Наименование ПОДОБНО ""%113"",
   |         ,
   |         ) КАК ЕПСБУДвиженияССубконто                     
   |ГДЕ
   |   ЕПСБУДвиженияССубконто.Регистратор.Договор <> ЗНАЧЕНИЕ(Справочник.Договоры.ПустаяСсылка)";
   
   Выборка = Запрос.Выполнить().Выбрать();
   
   НужныйДоговор = Справочники.Договоры.НайтиПоНаименованию("ТЕСТ_Договор");
                                        
   Пока Выборка.Следующий() Цикл
      Набор = РегистрыБухгалтерии.ЕПСБУ.СоздатьНаборЗаписей();
      Набор.Отбор.Регистратор.Установить(Выборка.Док);
      Набор.Прочитать();
      Для каждого Запись Из Набор Цикл
                                            
      КонецЦикла;
      Набор.Записать();
   КонецЦикла;
КонецПроцедуры


Оффлайн LexaK

  • *****
  • Сообщений: 1171
  • РЕПУТАЦИЯ: 313
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
что за го...но код? зачем такой ге...орой?
почему просто не хотите сделать?

1.найти нужные документы
2.заменить в них один договор на другой
3.записать документ с перепроведением

так же можно воспользоваться стандартной обработкой групповое изменение справочников и документов !
вообще ни чего программировать не надо (тем более когда не умеешь)
Помогло? - Нажми СПАСИБО!!!
                       :)


Теги: Субконто 
 

Как понять запись ?(НачОстаток = Null,0,НачОстаток)

Автор olgahachnewРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2107
Последний ответ 07 Апр 2011, 17:38
от chuevsf
Проверка на "новую" запись в рег. сведений

Автор nomer13Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 11616
Последний ответ 11 Янв 2011, 10:04
от nomer13
Удалить запись из справочника "Сотрудники" уволенного

Автор Alex56Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3054
Последний ответ 02 Фев 2014, 21:37
от LordWizard
Запись элемента справочника из модуля объекта другого справочника

Автор 12040Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1022
Последний ответ 05 Май 2016, 09:29
от LexaK
При формир. "Книги покупок" в 1С УПП двойная запись в основ. книге и в доп.листе

Автор Dasha_Раздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 3782
Последний ответ 14 Сен 2012, 09:36
от Dasha_

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
146 Сообщений
alex0402
108 Сообщений
Norfolk
51 Сообщений
LexaK
46 Сообщений
MuI_I_Ika MuI_I_Ika
44 Сообщений
AsadRoman
22 Сообщений
друган
21 Сообщений
alexandr_ll
19 Сообщений
SlimShady
19 Сообщений
Константин5825
18 Сообщений

* Кто онлайн

  • Точка Гостей: 294
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal