Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
30 Май 2017, 10:21
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: При изменения реквизита в документе  (Прочитано 785 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Rust2016

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-06-30
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день.
Так как я еще зеленый но чуть созревающий фрукт в этом деле:D, у меня случился трабл:dfbbdrfb:,во время изучения программирования в 1С. Изучаю по книге "Ощенко И. Азбука программирования в 1С:Предприятие 8.3. Дошел до изучения создания документа, где надо было в модуле документа(Развозка) прописать код при изменения реквизита документа, после чего должно в реквизит контрагента присвоить  имя контрагента. Вся суть проблема в чем,  том что я делаю все по книге, но при выполнения отладки выдает ошибку (Переменная не определена (Документ)Элементы.Контрагенты.Значение = <<?>>Документ.Контрагенты.Ссылка;). Не могу разобраться

Процедура ДокументПриИзменении(Элемент)
ЭлементыФормы.Контрагент.Значение = Документ.Контрагент.Ссылка;
Если ЭлементыФормы.АдресВручную.Значение = Ложь Тогда
ФАдрес = ПолучитьАдресКонтрагента(ЭлементыФормы.Контрагент.Значение);
ЭлементыФормы.Адрес.Значение = ФАдрес;
КонецЕсли;
КонецПроцедуры
 

Функция ПолучитьАдресКонтрагента(Объект)
ФункцияВернет = "";
Запрос = Новый Запрос;
Запрос.Текст = "
|ВЫБРАТЬ РАЗРЕШЕННЫЕ
| КонтактнаяИнформация.Тип КАК Тип,
| КонтактнаяИнформация.Вид КАК Вид,
| КонтактнаяИнформация.Представление КАК Представление
|ИЗ
| РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация
|ГДЕ
| КонтактнаяИнформация.Объект = &Объект";
Запрос.УстановитьПараметр("Объект", Объект);
РезультатПоиска =
Справочники.ВидыКонтактнойИнформации.НайтиПоКоду("000000002");
Результат = Запрос.Выполнить().Выбрать();
Пока Результат.Следующий() Цикл
Если Результат.Тип<>Перечисления.ТипыКонтактнойИнформации.Адрес
Тогда
Продолжить;
КонецЕсли;
Если Результат.Вид = РезультатПоиска Тогда
ФункцияВернет = Результат.Представление;
Прервать;
Иначе
ФункцияВернет = "";
КонецЕсли;
КонецЦикла;
Возврат ФункцияВернет;
КонецФункции
Заранее благодарен помощи.


Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1345
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
(Переменная не определена (Документ)Элементы.Контрагенты.Значение = <<?>>Документ.Контрагенты.Ссылка;)
ну так написано же: переменная не определена. система не понимает вас, когда вы пишете "Документ". вы что имели ввиду, написав "Документ"?

Оффлайн Rust2016

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-06-30
  • Сайт: 
  • Профессия: Ученик 1С
(Переменная не определена (Документ)Элементы.Контрагенты.Значение = <<?>>Документ.Контрагенты.Ссылка;)
ну так написано же: переменная не определена. система не понимает вас, когда вы пишете "Документ". вы что имели ввиду, написав "Документ"?

Этот код взят с книги и делал все по книге. Сам придумать не как не мог. Я пытался анализировать разные моменты. Делаю в 1С Предприятия 8.3

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1345
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
книги такой у меня нет, поэтому я не знаю, о чем там идет речь.
вам нужно не просто сделать по книге, а разобраться, что должно было произойти и что есть "Документ" в данном случае. после чего, если останутся вопросы, вы можете написать их сюда. но пока что суть вашей проблемы не ясна, так как вы даже не смоги объяснить, к чему (к какому объекту) вы пытаетесь обратиться.


Теги:
 

как получить значение реквизита "Код" в обработке "ПодборНоменклатуры" в УТ10.3

Автор JalibРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 696
Последний ответ 02 Дек 2016, 12:58
от Jalib
КД, Перенос Реквизита справочника (7.7) в ТЧ справочника 8.2.

Автор EvgenyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3135
Последний ответ 17 Сен 2014, 13:39
от Kironten
заполнение закладки "Материалы" в документе "Поступление из переработки"

Автор Sasa1CРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3185
Последний ответ 10 Июн 2013, 22:34
от Sasa1C
УТ 11.В документе "Заявка на расходование денежных средств" нет кнопки "Печать"!

Автор Valery3103Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3443
Последний ответ 29 Июн 2012, 18:37
от LexaK
Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 1569
Последний ответ 05 Мар 2017, 14:36
от Igor100500

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
93 Сообщений
wise wise
68 Сообщений
MuI_I_Ika MuI_I_Ika
52 Сообщений
alex0402
49 Сообщений
Dethmontt Dethmontt
48 Сообщений
ilyay ilyay
29 Сообщений
Сергей Федоров Сергей Федоров
29 Сообщений
ilnur75
25 Сообщений
Дмитрий Медведков Дмитрий Медведков
19 Сообщений
DmitriyF DmitriyF
17 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal