Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Июл 2017, 05:44
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ограничение на создание и изменение наименования элементов в справочнике  (Прочитано 917 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн a.nikulnikova

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-08-24
  • Сайт: 
  • Профессия: Программист 1С
Доброе утро всем, подскажите, как можно ограничить доступ на создание и изменение наименования справочника Должности(упр).
В справочнике есть табличные поля, которые пользователь должен заполнять. Поэтому полностью запретить редактирование не получится. Сами элементы справочника будут синхронизироваться при создании элемента в справочнике Должности организаций (регл).
База УПП.


Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
А в чем суть запрета изменения наименования?

Оффлайн a.nikulnikova

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-08-24
  • Сайт: 
  • Профессия: Программист 1С
А в чем суть запрета изменения наименования?
Суть, в том, что новые должности создает один человек, для удобства, была создана некая синхронизация, т.е. если я в регл учете создаю должность, то и в упр учете она тоже создается, но, т.к. справочником в упр учете занимаются и делают изменения другие пользователи (там должностные требования и компетенции), необходимо запретить создавать и изменять наименование в упр справочнике Должности., чтоб люди по своей невнимательности не изменили ничего.

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Ну, синхронизация по наименованию - это в принципе плохой метод. Наименование как раз и дается пользователю на откуп чтобы он там вводил что хотел.
А почему не используете типовую синхронизацию? В спр. ДолжностиОрганизаций есть реквизит "Должность".

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Программно проверить можно.

Если НЕ ЭтоНовый() И Наименование <> Ссылка.Наименование Тогда
    // Ругнуться
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн a.nikulnikova

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-08-24
  • Сайт: 
  • Профессия: Программист 1С
На счет наименования, допустим выход нашли, просто тупо Поставили в свойствах этого поля - Только Просмотр.
А вот на счет запрета создания нового элемента пока не получается ничего.
Я видимо все-равно что-то не так делаю.
Создала роль: Создание Должностей, в ней поставила галочки допустим все (сейчас не имеет значение конкретно какие)
В Процедуре при открытии в справочнике должности закинула условие:

   Если Не РольДоступна("СозданиеДолжностей") Тогда
      Отказ = Истина;
   КонецЕсли;

Все-равно в итоге, я могу создавать должности, даже если у меня не стоит эта роль.

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
  Если Не РольДоступна("СозданиеДолжностей") Тогда
      Отказ = Истина;
   КонецЕсли;
СП никто не отменял.
Форме (равно как и объекту) фиолетово что вы объявили какую-то переменную "Отказ" и задали ей значение "Ложь";
Если хотите отказаться от открытия подобный код стоит писать в "ПередОткрытием" - это конечно если у вас обычное приложение.
А вообще, еще раз настоятельно рекомендую пересмотреть свой подход к синхронизации. - он неправильный.

Оффлайн a.nikulnikova

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-08-24
  • Сайт: 
  • Профессия: Программист 1С
  Если Не РольДоступна("СозданиеДолжностей") Тогда
      Отказ = Истина;
   КонецЕсли;
СП никто не отменял.
Форме (равно как и объекту) фиолетово что вы объявили какую-то переменную "Отказ" и задали ей значение "Ложь";
Если хотите отказаться от открытия подобный код стоит писать в "ПередОткрытием" - это конечно если у вас обычное приложение.
А вообще, еще раз настоятельно рекомендую пересмотреть свой подход к синхронизации. - он неправильный.

Согласна, Вы были правы. Начальство данный метод не одобрило. Говорят делать ограничения на уровне записей (RLS) А я с ними явно не знакома.


Теги:
 

Программное создание документа на основании документа

Автор GolickoffРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 3631
Последний ответ 23 Апр 2015, 08:45
от Golickoff
Автоматическое создание " Заполнение" документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4055
Последний ответ 06 Мар 2014, 14:48
от mashencev_anton
Создание отчета "Отсутствие заказов"

Автор dronspartak9@gmail.comРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3607
Последний ответ 16 Апр 2014, 15:09
от dronspartak9@gmail.com
Создание заказаов на производство на основании заказа на производство.

Автор Елена1986Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 20
Просмотров: 6657
Последний ответ 09 Сен 2015, 13:01
от Елена1986
Создание плана закупок с использованием плана продаж

Автор NataVlРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1042
Последний ответ 26 Сен 2016, 16:25
от NataVl

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
122 Сообщений
alex0402
104 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
73 Сообщений
ilyay ilyay
50 Сообщений
Golickoff Golickoff
49 Сообщений
AIFrame
46 Сообщений
ab30ru
38 Сообщений
wise wise
36 Сообщений
Амал
32 Сообщений
Dethmontt Dethmontt
25 Сообщений

* Кто онлайн

  • Точка Гостей: 228
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal