Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Апр 2018, 19:08
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как сравнить Наименование со строкой шаблона Не в запросе  (Прочитано 785 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Hel

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-27
  • Сайт: 
  • Профессия: Ученик 1С
Таблица.Свернуть("Номенклатура, ХарактеристикаНоменклатуры");
Для Каждого Стр ИЗ Таблица ЦИКЛ
Если Стр.ХарактеристикаНоменклатуры.Наименование =???? ТОгда//( а вот здесь хотелось бы отобрать все хар-ки в наименовании которой есть МММ)типа МММ%
Сообщить("");
Иначе
Сообщить("");
КонецЕсли;
КонецЦикла;

заранее спасибо!


Оффлайн Rasty

  • *****
  • Сообщений: 997
  • РЕПУТАЦИЯ: 141
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
есть извращенский метод
МассивХарактеристик = Новый Массив;
Выборка = Справочники.ХарактеристикиНоменклатура.Выбрать();
Пока Выборка.Следующий() Цикл
    Если СтрНайти(Выборка.Намиенование,"МММ") >0 Тогда
        МассивХарактеристик.Добавить(Выборка.Ссылка);
    КонецЕсли;
КонецЦикла;
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн Hel

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-27
  • Сайт: 
  • Профессия: Ученик 1С
есть извращенский метод
МассивХарактеристик = Новый Массив;
Выборка = Справочники.ХарактеристикиНоменклатура.Выбрать();
Пока Выборка.Следующий() Цикл
    Если СтрНайти(Выборка.Намиенование,"МММ") >0 Тогда
        МассивХарактеристик.Добавить(Выборка.Ссылка);
    КонецЕсли;
КонецЦикла;

1С:Предприятие 8.3 (8.3.6.2014)
пишет, что
Процедура или функция с указанным именем не определена (СтрНайти)

:dfbsdfbsdf:

Оффлайн Rasty

  • *****
  • Сообщений: 997
  • РЕПУТАЦИЯ: 141
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн Hel

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-27
  • Сайт: 
  • Профессия: Ученик 1С


Теги:
 

Получить номер недели в месяце в запросе [номер недели]

Автор MuI_I_IkaРаздел Алгоритмы

Ответов: 0
Просмотров: 4753
Последний ответ 15 Июл 2015, 18:24
от MuI_I_Ika
РС "СостояниеОСОрганизаций" в запросе

Автор ILLUMIРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1310
Последний ответ 07 Янв 2015, 05:33
от ILLUMI
Объединить и Объединить все в одном запросе

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 301
Последний ответ 16 Янв 2018, 21:35
от Tsaiger
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 2543
Последний ответ Сегодня в 06:45
от Геннадий ОбьГЭС
"Поле не найдено" в запросе, но оно есть.

Автор ferrari314Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3197
Последний ответ 27 Окт 2015, 10:29
от vitasw

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
204 Сообщений
alex0402
73 Сообщений
AIFrame AIFrame
69 Сообщений
oleg-x
50 Сообщений
alexandr_ll
40 Сообщений
BuhRust
23 Сообщений
pavl_vs
22 Сообщений
KOI8-R
20 Сообщений
wise wise
15 Сообщений
Sheriff
13 Сообщений

* Кто онлайн

  • Точка Гостей: 355
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal