Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Май 2017, 14:12
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как сравнить Наименование со строкой шаблона Не в запросе  (Прочитано 603 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Hel

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-27
  • Сайт: 
  • Профессия: Ученик 1С
Таблица.Свернуть("Номенклатура, ХарактеристикаНоменклатуры");
Для Каждого Стр ИЗ Таблица ЦИКЛ
Если Стр.ХарактеристикаНоменклатуры.Наименование =???? ТОгда//( а вот здесь хотелось бы отобрать все хар-ки в наименовании которой есть МММ)типа МММ%
Сообщить("");
Иначе
Сообщить("");
КонецЕсли;
КонецЦикла;

заранее спасибо!


Оффлайн Rasty

  • *****
  • Сообщений: 976
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
есть извращенский метод
МассивХарактеристик = Новый Массив;
Выборка = Справочники.ХарактеристикиНоменклатура.Выбрать();
Пока Выборка.Следующий() Цикл
    Если СтрНайти(Выборка.Намиенование,"МММ") >0 Тогда
        МассивХарактеристик.Добавить(Выборка.Ссылка);
    КонецЕсли;
КонецЦикла;
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн Hel

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-27
  • Сайт: 
  • Профессия: Ученик 1С
есть извращенский метод
МассивХарактеристик = Новый Массив;
Выборка = Справочники.ХарактеристикиНоменклатура.Выбрать();
Пока Выборка.Следующий() Цикл
    Если СтрНайти(Выборка.Намиенование,"МММ") >0 Тогда
        МассивХарактеристик.Добавить(Выборка.Ссылка);
    КонецЕсли;
КонецЦикла;

1С:Предприятие 8.3 (8.3.6.2014)
пишет, что
Процедура или функция с указанным именем не определена (СтрНайти)

:dfbsdfbsdf:

Оффлайн Rasty

  • *****
  • Сообщений: 976
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн Hel

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-27
  • Сайт: 
  • Профессия: Ученик 1С


Теги:
 

Получить номер недели в месяце в запросе [номер недели]

Автор MuI_I_IkaРаздел Алгоритмы

Ответов: 0
Просмотров: 3094
Последний ответ 15 Июл 2015, 18:24
от MuI_I_Ika
РС "СостояниеОСОрганизаций" в запросе

Автор ILLUMIРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 898
Последний ответ 07 Янв 2015, 05:33
от ILLUMI
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1555
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Поле не найдено" в запросе, но оно есть.

Автор ferrari314Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1802
Последний ответ 27 Окт 2015, 10:29
от vitasw
Оставить в запросе только те поля, у которых тип значение "Номенклатура"

Автор DirecTwiXРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 2918
Последний ответ 16 Апр 2012, 02:00
от DirecTwiX

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
95 Сообщений
Dethmontt Dethmontt
67 Сообщений
alex0402
65 Сообщений
wise wise
63 Сообщений
MuI_I_Ika MuI_I_Ika
60 Сообщений
ilyay ilyay
40 Сообщений
Сергей Федоров Сергей Федоров
34 Сообщений
magnifico61
25 Сообщений
ilnur75
22 Сообщений
BuhRust
21 Сообщений

* Кто онлайн

  • Точка Гостей: 825
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal