Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Июн 2021, 01:45
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Синхронизация подразделений и подразделений организации  (Прочитано 2296 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн a.nikulnikova

  • *
  • Регистрация: 2015-08-24
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Профессия: Программист 1С
Добрый день всем, делаю обработку, которая переносит подразделения из справочника ПодразделенияОрганизации в Подразделения, элементы переносит все, и помечает на удаление, если в регл справочнике оно помечено на удаление. Но обработка не переносит новые подразделения по группам, а просто списком переносит. Подскажите, как сделать так, чтоб при создании элемента учитывался и родитель?

Процедура КнопкаВыполнитьНажатие(Кнопка)
    ВыборкаПодразделений = Справочники.ПодразделенияОрганизаций.Выбрать();
    Пока ВыборкаПодразделений.Следующий() Цикл
        ТекПодразделение = Справочники.Подразделения.НайтиПоКоду(ВыборкаПодразделений.Код);
        Если ТекПодразделение.Пустая() Тогда
            НовПодразделение = Справочники.Подразделения.СоздатьЭлемент();
            НовПодразделение.Наименование = ВыборкаПодразделений.Наименование;
            НовПодразделение.Код = ВыборкаПодразделений.Код;           
            НовПодразделение.Записать();
        ИначеЕсли ВыборкаПодразделений.ПометкаУдаления  Тогда
            НовПодразделение =  Справочники.Подразделения.НайтиПоКоду(ВыборкаПодразделений.Код).ПолучитьОбъект();
            НовПодразделение.УстановитьПометкуУдаления(Истина);
            НовПодразделение.Записать();           
        КонецЕсли;         
    КонецЦикла;
КонецПроцедуры


Оффлайн Kironten

  • *****
  • Регистрация: 2013-08-12
  • Сообщений: 906
  • РЕПУТАЦИЯ: 187
  • КПД: 21%
  • Профессия: Ученик 1С
Проверяете, есть ли в элементе подразделенияорганизаций родитель.
Если есть, то ищем по этому же коду это подразделение в справочнике подразделения.
Если нашли - то это реквизит родитель для нового элемента справочника подразделения.
Если нет - то создаем новый с нужным кодом, и его присваиваем как родитель.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
84 Сообщений
LexaK
64 Сообщений
antoneus antoneus
30 Сообщений
Ивашка
27 Сообщений
KATERINA 861
24 Сообщений
neek666
22 Сообщений
alexandr_ll
19 Сообщений
SSC
15 Сообщений
Алексей_1985_06
11 Сообщений
MiThO
8 Сообщений

* Кто онлайн

  • Точка Гостей: 155
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Инструменты

* Дополнительно

Поиск