Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
29 Мар 2017, 21:55
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Синхронизация подразделений и подразделений организации  (Прочитано 506 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн a.nikulnikova

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-08-24
  • Сайт: 
  • Профессия: Программист 1С
Добрый день всем, делаю обработку, которая переносит подразделения из справочника ПодразделенияОрганизации в Подразделения, элементы переносит все, и помечает на удаление, если в регл справочнике оно помечено на удаление. Но обработка не переносит новые подразделения по группам, а просто списком переносит. Подскажите, как сделать так, чтоб при создании элемента учитывался и родитель?

Процедура КнопкаВыполнитьНажатие(Кнопка)
    ВыборкаПодразделений = Справочники.ПодразделенияОрганизаций.Выбрать();
    Пока ВыборкаПодразделений.Следующий() Цикл
        ТекПодразделение = Справочники.Подразделения.НайтиПоКоду(ВыборкаПодразделений.Код);
        Если ТекПодразделение.Пустая() Тогда
            НовПодразделение = Справочники.Подразделения.СоздатьЭлемент();
            НовПодразделение.Наименование = ВыборкаПодразделений.Наименование;
            НовПодразделение.Код = ВыборкаПодразделений.Код;           
            НовПодразделение.Записать();
        ИначеЕсли ВыборкаПодразделений.ПометкаУдаления  Тогда
            НовПодразделение =  Справочники.Подразделения.НайтиПоКоду(ВыборкаПодразделений.Код).ПолучитьОбъект();
            НовПодразделение.УстановитьПометкуУдаления(Истина);
            НовПодразделение.Записать();           
        КонецЕсли;         
    КонецЦикла;
КонецПроцедуры


Оффлайн Kironten

  • *****
  • Сообщений: 766
  • РЕПУТАЦИЯ: 164
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Проверяете, есть ли в элементе подразделенияорганизаций родитель.
Если есть, то ищем по этому же коду это подразделение в справочнике подразделения.
Если нашли - то это реквизит родитель для нового элемента справочника подразделения.
Если нет - то создаем новый с нужным кодом, и его присваиваем как родитель.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
alex0402
127 Сообщений
MuI_I_Ika MuI_I_Ika
57 Сообщений
Norfolk
52 Сообщений
LexaK
49 Сообщений
друган
20 Сообщений
alexandr_ll
20 Сообщений
Константин5825
18 Сообщений
AsadRoman
18 Сообщений
MrLvovsky MrLvovsky
16 Сообщений

* Кто онлайн

  • Точка Гостей: 442
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal