Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 04:40
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Синхронизация подразделений и подразделений организации  (Прочитано 820 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн a.nikulnikova

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-08-24
  • Сайт: 
  • Профессия: Программист 1С
Добрый день всем, делаю обработку, которая переносит подразделения из справочника ПодразделенияОрганизации в Подразделения, элементы переносит все, и помечает на удаление, если в регл справочнике оно помечено на удаление. Но обработка не переносит новые подразделения по группам, а просто списком переносит. Подскажите, как сделать так, чтоб при создании элемента учитывался и родитель?

Процедура КнопкаВыполнитьНажатие(Кнопка)
    ВыборкаПодразделений = Справочники.ПодразделенияОрганизаций.Выбрать();
    Пока ВыборкаПодразделений.Следующий() Цикл
        ТекПодразделение = Справочники.Подразделения.НайтиПоКоду(ВыборкаПодразделений.Код);
        Если ТекПодразделение.Пустая() Тогда
            НовПодразделение = Справочники.Подразделения.СоздатьЭлемент();
            НовПодразделение.Наименование = ВыборкаПодразделений.Наименование;
            НовПодразделение.Код = ВыборкаПодразделений.Код;           
            НовПодразделение.Записать();
        ИначеЕсли ВыборкаПодразделений.ПометкаУдаления  Тогда
            НовПодразделение =  Справочники.Подразделения.НайтиПоКоду(ВыборкаПодразделений.Код).ПолучитьОбъект();
            НовПодразделение.УстановитьПометкуУдаления(Истина);
            НовПодразделение.Записать();           
        КонецЕсли;         
    КонецЦикла;
КонецПроцедуры


Оффлайн Kironten

  • *****
  • Сообщений: 900
  • РЕПУТАЦИЯ: 185
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Проверяете, есть ли в элементе подразделенияорганизаций родитель.
Если есть, то ищем по этому же коду это подразделение в справочнике подразделения.
Если нашли - то это реквизит родитель для нового элемента справочника подразделения.
Если нет - то создаем новый с нужным кодом, и его присваиваем как родитель.


Теги:
 

Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 267
Последний ответ 12 Окт 2017, 14:02
от wise
Добрый день Необходимо на основании типовой конфигурации бухгалтерии сделать обработку, которая будет переносить остатки со счета расчетов 62.01 с одной организации в документ ввода начальных

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 223
Последний ответ 18 Авг 2017, 11:57
от ZSS
Не могу найти в 1С8.3 справочник "Организации"

Автор ГюзельРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 13607
Последний ответ 17 Сен 2014, 11:18
от Гюзель
Отчет "Списки сотрудников организации" ЗУП

Автор НовенькаяРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2313
Последний ответ 28 Ноя 2014, 08:36
от cska-fanat-kz
(Функция "Ответственные лица организации") БП 3.0

Автор GanG031Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2180
Последний ответ 24 Мар 2016, 13:41
от LexaK

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 224
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal