Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Июл 2017, 17:26
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Добавить дни недели  (Прочитано 931 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн tudsfr

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-06-22
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте Уважаемые форумчане !!!
Прошу объясните/помогите
Как изменить код, чтобы для А было 1пн, 2вт, 3ср и т.д.
Заранее благодарен

ps у меня получается 1день, 2день...
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)


МассивДобавляемыхРеквизитов = Новый Массив;
МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("План", Новый ОписаниеТипов("ТаблицаЗначений")));   
  МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Сотрудник", Новый ОписаниеТипов("СправочникСсылка.Сотрудники"),"План" ,"Сотрудник"));


 
Для А = 1 По 7 Цикл
МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("День" +  Строка(А), Новый ОписаниеТипов("Число",Новый КвалификаторыЧисла(10,0)),"План" , "День"));
//     МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Часов" + Строка(А), Новый ОписаниеТипов("Число",Новый КвалификаторыЧисла(10,0)),"План" , "Часов"));   
КонецЦикла;

ИзменитьРеквизиты(МассивДобавляемыхРеквизитов);   

ТаблицаФормы = Элементы.Добавить("План", Тип("ТаблицаФормы"));
ТаблицаФормы.ПутьКДанным = "План";
ТаблицаФормы.ПоложениеКоманднойПанели = ПоложениеКоманднойПанелиЭлементаФормы.Нет;
ТаблицаФормы.ФиксацияСлева = 3;
ТаблицаФормы.УстановитьДействие("ПередУдалением", "ПланПередУдалением");
ТаблицаФормы.УстановитьДействие("ПередНачаломДобавления", "ПланПередНачаломДобавления");


НоваяКолонка = Элементы.Добавить("Сотрудник", Тип("ПолеФормы"), Элементы.План);
НоваяКолонка.Заголовок = "Сотрудник";
НоваяКолонка.ПутьКДанным = "План.Сотрудник";
НоваяКолонка.Вид = ВидПоляФормы.ПолеВвода;
НоваяКолонка.РежимРедактирования = РежимРедактированияКолонки.ВходПриВводе;   


Для А = 1 По 7 Цикл

НоваяКолонка = Элементы.Добавить("День" + Строка(А), Тип("ПолеФормы"), Элементы.План);
НоваяКолонка.Заголовок = "День" + Строка(А);

НоваяКолонка.ПутьКДанным = "План.День"+ Строка(А);
НоваяКолонка.Вид = ВидПоляФормы.ПолеВвода;
НоваяКолонка.РежимРедактирования = РежимРедактированияКолонки.ВходПриВводе;   

КонецЦикла;

КонецПроцедуры


Онлайн LexaK

  • *****
  • Сообщений: 1247
  • РЕПУТАЦИЯ: 344
  • КПД: 28%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
всего семь дней, просто забейте их так, без всякого цикла :xfbnsdfb:
МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Понедельник", Новый ОписаниеТипов("Число",Новый КвалификаторыЧисла(10,0)),"План" , "День")); 
МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Вторник", Новый ОписаниеТипов("Число",Новый КвалификаторыЧисла(10,0)),"План" , "День"));
МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Среда", Новый ОписаниеТипов("Число",Новый КвалификаторыЧисла(10,0)),"План" , "День"));
МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Четверг", Новый ОписаниеТипов("Число",Новый КвалификаторыЧисла(10,0)),"План" , "День"));
МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Пятница", Новый ОписаниеТипов("Число",Новый КвалификаторыЧисла(10,0)),"План" , "День"));
МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Суббота", Новый ОписаниеТипов("Число",Новый КвалификаторыЧисла(10,0)),"План" , "День"));
МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Воскресенье", Новый ОписаниеТипов("Число",Новый КвалификаторыЧисла(10,0)),"План" , "День"));
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн tudsfr

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-06-22
  • Сайт: 
  • Профессия: Ученик 1С
всего семь дней, просто забейте их так, без всякого цикла :xfbnsdfb:
МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Понедельник", Новый ОписаниеТипов("Число",Новый КвалификаторыЧисла(10,0)),"План" , "День")); 
МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Вторник", Новый ОписаниеТипов("Число",Новый КвалификаторыЧисла(10,0)),"План" , "День"));
МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Среда", Новый ОписаниеТипов("Число",Новый КвалификаторыЧисла(10,0)),"План" , "День"));
МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Четверг", Новый ОписаниеТипов("Число",Новый КвалификаторыЧисла(10,0)),"План" , "День"));
МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Пятница", Новый ОписаниеТипов("Число",Новый КвалификаторыЧисла(10,0)),"План" , "День"));
МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Суббота", Новый ОписаниеТипов("Число",Новый КвалификаторыЧисла(10,0)),"План" , "День"));
МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Воскресенье", Новый ОписаниеТипов("Число",Новый КвалификаторыЧисла(10,0)),"План" , "День"));
так не получится

Онлайн LexaK

  • *****
  • Сообщений: 1247
  • РЕПУТАЦИЯ: 344
  • КПД: 28%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
Цитировать
так не получится

Что не получится? Внятно и полно можете описать задачу? А то так трудно что либо дельное предложить!
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн tudsfr

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-06-22
  • Сайт: 
  • Профессия: Ученик 1С
Цитировать
так не получится

Что не получится? Внятно и полно можете описать задачу? А то так трудно что либо дельное предложить!
Мне нужно создать - динамически формирующиеся колонки. Табель Фио сотрудника и 1пн,2Вт и т.д
в ячейках количество отработанных часов

Онлайн LexaK

  • *****
  • Сообщений: 1247
  • РЕПУТАЦИЯ: 344
  • КПД: 28%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
а зачем вам динамические колонки? сделайте постоянную таблицу
из ФИО, пн, вт, ..., вс
и заполняйте ее, в тех днях где нечем заполнять пишите 0 (или вообще ничего не пишите, там и так будет 0) такие таблицы сплошь и рядом в различных табелях и ни кто не заморачивается динамическим формированием таблиц.

в конце концов, в такой таблице, если какие-то колонки будут не нужны, их можно просто скрыть, Видимость = Ложь;
так тоже во многих 1С-ных формах делается. 
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн tudsfr

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-06-22
  • Сайт: 
  • Профессия: Ученик 1С
а зачем вам динамические колонки? сделайте постоянную таблицу
из ФИО, пн, вт, ..., вс
и заполняйте ее, в тех днях где нечем заполнять пишите 0 (или вообще ничего не пишите, там и так будет 0) такие таблицы сплошь и рядом в различных табелях и ни кто не заморачивается динамическим формированием таблиц.

в конце концов, в такой таблице, если какие-то колонки будут не нужны, их можно просто скрыть, Видимость = Ложь;
так тоже во многих 1С-ных формах делается.
Да вы абсолютно правы))) Я тоже так думаю, но мне дали такое задание.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alex0402
94 Сообщений
oleg-x
82 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
68 Сообщений
Golickoff Golickoff
51 Сообщений
AIFrame
46 Сообщений
ilyay ilyay
42 Сообщений
Амал
30 Сообщений
lansy
22 Сообщений
Dethmontt Dethmontt
22 Сообщений
BuhRust
21 Сообщений

* Кто онлайн

  • Точка Гостей: 726
  • Точка Скрытых: 0
  • Точка Пользователей: 17
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal