Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
30 Май 2017, 06:12
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Добавить дни недели  (Прочитано 813 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн tudsfr

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-06-22
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте Уважаемые форумчане !!!
Прошу объясните/помогите
Как изменить код, чтобы для А было 1пн, 2вт, 3ср и т.д.
Заранее благодарен

ps у меня получается 1день, 2день...
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)


МассивДобавляемыхРеквизитов = Новый Массив;
МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("План", Новый ОписаниеТипов("ТаблицаЗначений")));   
  МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Сотрудник", Новый ОписаниеТипов("СправочникСсылка.Сотрудники"),"План" ,"Сотрудник"));


 
Для А = 1 По 7 Цикл
МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("День" +  Строка(А), Новый ОписаниеТипов("Число",Новый КвалификаторыЧисла(10,0)),"План" , "День"));
//     МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Часов" + Строка(А), Новый ОписаниеТипов("Число",Новый КвалификаторыЧисла(10,0)),"План" , "Часов"));   
КонецЦикла;

ИзменитьРеквизиты(МассивДобавляемыхРеквизитов);   

ТаблицаФормы = Элементы.Добавить("План", Тип("ТаблицаФормы"));
ТаблицаФормы.ПутьКДанным = "План";
ТаблицаФормы.ПоложениеКоманднойПанели = ПоложениеКоманднойПанелиЭлементаФормы.Нет;
ТаблицаФормы.ФиксацияСлева = 3;
ТаблицаФормы.УстановитьДействие("ПередУдалением", "ПланПередУдалением");
ТаблицаФормы.УстановитьДействие("ПередНачаломДобавления", "ПланПередНачаломДобавления");


НоваяКолонка = Элементы.Добавить("Сотрудник", Тип("ПолеФормы"), Элементы.План);
НоваяКолонка.Заголовок = "Сотрудник";
НоваяКолонка.ПутьКДанным = "План.Сотрудник";
НоваяКолонка.Вид = ВидПоляФормы.ПолеВвода;
НоваяКолонка.РежимРедактирования = РежимРедактированияКолонки.ВходПриВводе;   


Для А = 1 По 7 Цикл

НоваяКолонка = Элементы.Добавить("День" + Строка(А), Тип("ПолеФормы"), Элементы.План);
НоваяКолонка.Заголовок = "День" + Строка(А);

НоваяКолонка.ПутьКДанным = "План.День"+ Строка(А);
НоваяКолонка.Вид = ВидПоляФормы.ПолеВвода;
НоваяКолонка.РежимРедактирования = РежимРедактированияКолонки.ВходПриВводе;   

КонецЦикла;

КонецПроцедуры


Оффлайн LexaK

  • *****
  • Сообщений: 1216
  • РЕПУТАЦИЯ: 333
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
всего семь дней, просто забейте их так, без всякого цикла :xfbnsdfb:
МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Понедельник", Новый ОписаниеТипов("Число",Новый КвалификаторыЧисла(10,0)),"План" , "День")); 
МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Вторник", Новый ОписаниеТипов("Число",Новый КвалификаторыЧисла(10,0)),"План" , "День"));
МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Среда", Новый ОписаниеТипов("Число",Новый КвалификаторыЧисла(10,0)),"План" , "День"));
МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Четверг", Новый ОписаниеТипов("Число",Новый КвалификаторыЧисла(10,0)),"План" , "День"));
МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Пятница", Новый ОписаниеТипов("Число",Новый КвалификаторыЧисла(10,0)),"План" , "День"));
МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Суббота", Новый ОписаниеТипов("Число",Новый КвалификаторыЧисла(10,0)),"План" , "День"));
МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Воскресенье", Новый ОписаниеТипов("Число",Новый КвалификаторыЧисла(10,0)),"План" , "День"));
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн tudsfr

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-06-22
  • Сайт: 
  • Профессия: Ученик 1С
всего семь дней, просто забейте их так, без всякого цикла :xfbnsdfb:
МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Понедельник", Новый ОписаниеТипов("Число",Новый КвалификаторыЧисла(10,0)),"План" , "День")); 
МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Вторник", Новый ОписаниеТипов("Число",Новый КвалификаторыЧисла(10,0)),"План" , "День"));
МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Среда", Новый ОписаниеТипов("Число",Новый КвалификаторыЧисла(10,0)),"План" , "День"));
МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Четверг", Новый ОписаниеТипов("Число",Новый КвалификаторыЧисла(10,0)),"План" , "День"));
МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Пятница", Новый ОписаниеТипов("Число",Новый КвалификаторыЧисла(10,0)),"План" , "День"));
МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Суббота", Новый ОписаниеТипов("Число",Новый КвалификаторыЧисла(10,0)),"План" , "День"));
МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы("Воскресенье", Новый ОписаниеТипов("Число",Новый КвалификаторыЧисла(10,0)),"План" , "День"));
так не получится

Оффлайн LexaK

  • *****
  • Сообщений: 1216
  • РЕПУТАЦИЯ: 333
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
Цитировать
так не получится

Что не получится? Внятно и полно можете описать задачу? А то так трудно что либо дельное предложить!
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн tudsfr

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-06-22
  • Сайт: 
  • Профессия: Ученик 1С
Цитировать
так не получится

Что не получится? Внятно и полно можете описать задачу? А то так трудно что либо дельное предложить!
Мне нужно создать - динамически формирующиеся колонки. Табель Фио сотрудника и 1пн,2Вт и т.д
в ячейках количество отработанных часов

Оффлайн LexaK

  • *****
  • Сообщений: 1216
  • РЕПУТАЦИЯ: 333
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
а зачем вам динамические колонки? сделайте постоянную таблицу
из ФИО, пн, вт, ..., вс
и заполняйте ее, в тех днях где нечем заполнять пишите 0 (или вообще ничего не пишите, там и так будет 0) такие таблицы сплошь и рядом в различных табелях и ни кто не заморачивается динамическим формированием таблиц.

в конце концов, в такой таблице, если какие-то колонки будут не нужны, их можно просто скрыть, Видимость = Ложь;
так тоже во многих 1С-ных формах делается. 
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн tudsfr

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-06-22
  • Сайт: 
  • Профессия: Ученик 1С
а зачем вам динамические колонки? сделайте постоянную таблицу
из ФИО, пн, вт, ..., вс
и заполняйте ее, в тех днях где нечем заполнять пишите 0 (или вообще ничего не пишите, там и так будет 0) такие таблицы сплошь и рядом в различных табелях и ни кто не заморачивается динамическим формированием таблиц.

в конце концов, в такой таблице, если какие-то колонки будут не нужны, их можно просто скрыть, Видимость = Ложь;
так тоже во многих 1С-ных формах делается.
Да вы абсолютно правы))) Я тоже так думаю, но мне дали такое задание.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
89 Сообщений
wise wise
68 Сообщений
MuI_I_Ika MuI_I_Ika
51 Сообщений
alex0402
49 Сообщений
Dethmontt Dethmontt
48 Сообщений
Сергей Федоров Сергей Федоров
29 Сообщений
ilyay ilyay
28 Сообщений
ilnur75
25 Сообщений
Дмитрий Медведков Дмитрий Медведков
19 Сообщений
DmitriyF DmitriyF
17 Сообщений

* Кто онлайн

  • Точка Гостей: 343
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal