Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
27 Июл 2017, 15:47
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: СКД: получить значение поля отбора  (Прочитано 1218 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн anyut_ka

  • *
  • Сообщений: 47
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-03-31
  • Сайт: 
Добрый день! Ребята, подскажите пожалуйста: в скд установила в настройке отчета отбор, например ПроцентОтклонения = 30. Как при компоновке отчета получить его программно, чтобы вывести его в заголовок отчета?


Оффлайн Golickoff

  • ****
  • Сообщений: 252
  • РЕПУТАЦИЯ: 15
  • КПД: 6%
  • Регистрация: 2015-02-05
  • Сайт: 
  • Профессия: Ученик 1С
Заголовок = СхемаКомпоновкиДанных.Параметры.ПроцентОтклонения.Значение;
КомпоновщикНастроек.Настройки.ПараметрыВывода.Элементы.Найти("Заголовок").Значение = Заголовок;
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

Оффлайн anyut_ka

  • *
  • Сообщений: 47
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-03-31
  • Сайт: 
Т.е. получить по имени поля "ПроцентОтклонения" значение отбора (правое значение).
Сейчас делаю следующим образом:
Для Каждого ЭлОтбора Из Настройки.Отбор.Элементы Цикл
    Если ЭлОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("ПроцентОтклонения") Тогда
        Если ЭлОтбора.Использование Тогда
            ПроцентОтклонения = ЭлОтбора.ПравоеЗначение;
        КонецЕсли;
    КонецЕсли;
КонецЦикла;
Добавлено: 15 Июн 2016, 10:54

Заголовок = СхемаКомпоновкиДанных.Параметры.ПроцентОтклонения.Значение;
КомпоновщикНастроек.Настройки.ПараметрыВывода.Элементы.Найти("Заголовок").Значение = Заголовок;

У меня данное поле не в параметрах, а в отборе


Теги:
 

Получить номер недели в месяце в запросе [номер недели]

Автор MuI_I_IkaРаздел Алгоритмы

Ответов: 0
Просмотров: 3412
Последний ответ 15 Июл 2015, 18:24
от MuI_I_Ika
Как в СКД вычислить значение ресурса для группировки по значениям ресурса нижестоящей группировки

Автор ОтцовскийРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 660
Последний ответ 23 Ноя 2016, 12:53
от sertak
В строке номер "1" табличной части "Состав набора": Не заполнено значение реквиз

Автор ХеляРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 6532
Последний ответ 18 Сен 2011, 16:07
от Хеля
В строке "1" табличной части "Состав набора": Не заполнено значение реквизитов Цена

Автор rusalkaРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 2173
Последний ответ 11 Апр 2014, 16:52
от rusalka
Не работают поля "налоговый" и "бухгалтерский"

Автор oleg_e1Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 2227
Последний ответ 31 Дек 2011, 11:36
от AntonB

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alex0402
94 Сообщений
oleg-x
78 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
66 Сообщений
Golickoff Golickoff
51 Сообщений
AIFrame
46 Сообщений
ilyay ilyay
42 Сообщений
Амал
30 Сообщений
MuI_I_Ika MuI_I_Ika
27 Сообщений
LexaK
23 Сообщений
lansy
22 Сообщений

* Кто онлайн

  • Точка Гостей: 905
  • Точка Скрытых: 0
  • Точка Пользователей: 17
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal