Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Янв 2017, 05:47
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Привязка нового элемента формы к имеющемуся, всплывающая подсказка  (Прочитано 910 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Arhat

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-06-09
  • Сайт: 
  • Профессия: Консультант 1С


Нужна помощь коллективного разума. Задача следующая:при наличии комментария в карточке контрагента выводить в документах значок рядом с полем контрагент, при наведении на который мыши появляется тот самый комментарий. Делаю следующее:

Если ЭтотОбъект.Контрагент.Комментарий <> "" Тогда
Флаг = ЭтаФорма.ЭлементыФормы.Добавить(Тип("ПолеКартинки"),"Картинка");
Флаг.Высота = 15;
Флаг.Ширина = 15;
Флаг.Картинка = БиблиотекаКартинок.Важно;

А вот дальше тупик. Пробовал следующее:

Флаг.УстановитьПривязку(ГраницаЭлементаУправления.Низ,ЭтаФорма.ЭлементыФормы.Контрагент, ГраницаЭлементаУправления.Низ);
Флаг.УстановитьПривязку(ГраницаЭлементаУправления.Право,ЭтаФорма.ЭлементыФормы.Контрагент, ГраницаЭлементаУправления.Лево);
и
Флаг.Подсказка(ЭтотОбъект.Контрагент.Комментарий);

Не работает. Вариант добавить элемент в редакторе диалога и управлять видимостью не хотелось бы использовать т.к. документ не один и хочется решить все через общий модуль, чтобы не править кучу форм при каждом обновлении. Что делать, подскажите люди добрые.

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Оффлайн Golickoff

  • ***
  • Сообщений: 186
  • РЕПУТАЦИЯ: 10
  • КПД: 5%
  • Регистрация: 2015-02-05
  • Сайт: 
  • Профессия: Ученик 1С
Можно проще: добавить картинку на форму в конфигураторе, а при открытии формы смотреть на наличие комментария и в зависимости от него менять видимость картинки на истину/ложь в зависимости от результата.
Процедура ПриОткрытии()
бла бла бла
Если ЭтотОбъект.Контрагент.Комментарий <> "" Тогда
      ЭтаФорма.Элементы.ДобавленнаяКартинка.Видимость = Ложь;
      ЭтаФорма.Элементы.ДобавленнаяКартинка.Комментарий= "";
Иначе
      ЭтаФорма.Элементы.ДобавленнаяКартинка.Видимость = Истина;
      ЭтаФорма.Элементы.ДобавленнаяКартинка.Видимость = ЭтотОбъект.Контрагент.Комментарий;
КонецЕсли;
бла бла бла
КонецПроцедуры

Оффлайн Arhat

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-06-09
  • Сайт: 
  • Профессия: Консультант 1С
Можно проще: добавить картинку на форму в конфигураторе, а при открытии формы смотреть на наличие комментария и в зависимости от него менять видимость картинки на истину/ложь в зависимости от результата.
Вариант добавить элемент в редакторе диалога и управлять видимостью не хотелось бы использовать т.к. документ не один и хочется решить все через общий модуль, чтобы не править кучу форм при каждом обновлении.

Оффлайн Golickoff

  • ***
  • Сообщений: 186
  • РЕПУТАЦИЯ: 10
  • КПД: 5%
  • Регистрация: 2015-02-05
  • Сайт: 
  • Профессия: Ученик 1С
Беда, не заметил. Хорошо, что это не моя проблема (шутка). Ширину и высоту вы указали, а .Верх и .Лево -- нет. Попробуйте указать и их тоже. А ещё посмотрите отладчиком на элементы формы и убедитесь, что новый элемент имеет место быть.

Оффлайн Arhat

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-06-09
  • Сайт: 
  • Профессия: Консультант 1С
Элемент выводится, с этим проблем нет, но строго в левом верхнем углу. При помощи Верх и Лево я задам абсолютные координаты на форме и если поле контрагента в одном из документов у меня окажется в другом месте, то они с картинкой разминутся.

Оффлайн Golickoff

  • ***
  • Сообщений: 186
  • РЕПУТАЦИЯ: 10
  • КПД: 5%
  • Регистрация: 2015-02-05
  • Сайт: 
  • Профессия: Ученик 1С
А что если попробовать прочитать координаты поля контрагента и в зависимости от них выставить координаты картинки?

Оффлайн Arhat

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-06-09
  • Сайт: 
  • Профессия: Консультант 1С
Согласен. А есть такая возможность?

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Скорее всего в обычном интерфейсе чего-то удобоваримого вы не получите. Я б менял фон поля "контрагент" и выводил информацию в поле "подсказка"

Оффлайн Arhat

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-06-09
  • Сайт: 
  • Профессия: Консультант 1С


Спасибо за наводку. Решил через свойства поля Контрагент.

Если ЭтотОбъект.Контрагент.Комментарий <> "" Тогда
ЭтаФорма.ЭлементыФормы.Контрагент.Картинка = БиблиотекаКартинок.Комментарий;
ЭтаФорма.ЭлементыФормы.Контрагент.Подсказка = ЭтотОбъект.Контрагент.Комментарий;
КонецЕсли;

Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Картинка в поле контрагент = зачетно.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
152 Сообщений
alex0402
73 Сообщений
alexandr_ll
37 Сообщений
LexaK
29 Сообщений
MuI_I_Ika MuI_I_Ika
27 Сообщений
crow1983
27 Сообщений
sertak sertak
22 Сообщений
дфтын дфтын
17 Сообщений
BuhRust
15 Сообщений
Vzonder
15 Сообщений

* Кто онлайн

  • Точка Гостей: 213
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal