Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Окт 2017, 05:05
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Условие проверки выбранного флажка  (Прочитано 1424 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ришат Гайсин

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-06-09
  • Сайт: 
Всем доброго дня суток товарищи :befhbt:
Имеется Документ с Табличной частью 'СоставГруппы' и тремя Столбцами ПосещаемостьН, ПосещаемостьБ, ПосещаемостьЗ со свойствами типа поле 'Флажок', необходимо чтобы можно было выбирать только ОДИН флажок в строке.

Никак не могу написать проверку выбранного флажка.

&НаКлиенте
Процедура ПосещаемостьНПриИзменении(Элемент)
Если ЭтаФорма.Элементы.ПосещаемостьН = Истина Тогда
ЭтаФорма.Элементы.ПосещаемостьБ = Ложь;
ЭтаФорма.Элементы.ПосещаемостьЗ = Ложь;
КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура ПосещаемостьБПриИзменении(Элемент)
Если ЭтаФорма.Элементы.ПосещаемостьБ = Истина Тогда
ЭтаФорма.Элементы.ПосещаемостьН = Ложь;
ЭтаФорма.Элементы.ПосещаемостьЗ = Ложь;
КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура ПосещаемостьЗПриИзменении(Элемент)
Если ЭтаФорма.Элементы.ПосещаемостьЗ = Истина Тогда
ЭтаФорма.Элементы.ПосещаемостьБ = Ложь;
ЭтаФорма.Элементы.ПосещаемостьН = Ложь;
КонецЕсли;
КонецПроцедуры

Помогите люди добрые! :dfbsdfbsdf:


Оффлайн pavl_vs

  • *****
  • Сообщений: 1049
  • РЕПУТАЦИЯ: 168
  • КПД: 16%
  • Регистрация: 2011-05-09
  • Сайт: 
  • Профессия: Программист 7.7
Ришат Гайсин, могу ошибаться, но следует обращаться к ТЧ документа.

Оффлайн Ришат Гайсин

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-06-09
  • Сайт: 
pavl_vs, не могли бы показать пример? если не сложно конечно)
Объект.СоставГруппы.ПосещаемостьБ = ...
так?)

Оффлайн Летящий в даль

  • **
  • Сообщений: 56
  • РЕПУТАЦИЯ: 12
  • КПД: 21%
  • 1с - это диагенез :D
  • Регистрация: 2016-05-16
  • Сайт: 
  • Профессия: Программист 1С
Поставьте для каждого реквизита одну процедуру
Процедура СоставГруппыПосещаемостьЗПриИзменении(Элемент)
      // получаем текущие данные табличной части
ТекущиеДанные = Элементы.СоставГруппы.ТекущиеДанные;
//пРОВЕРЯЕМ  ваши рекизиты
   Если ТекущиеДанные.ПосещаемостьН Тогда
ТекущиеДанные.ПосещаемостьБ = Ложь;
ТекущиеДанные.ПосещаемостьЗ = Ложь;
    ИначеЕсли ТекущиеДанные.ПосещаемостьБ Тогда
         ТекущиеДанные.ПосещаемостьН = Ложь;
ТекущиеДанные.ПосещаемостьЗ = Ложь;
    ИначеЕсли ТекущиеДанные.ПосещаемостьЗ Тогда
         ТекущиеДанные.ПосещаемостьН = Ложь;
         ТекущиеДанные.ПосещаемостьБ = Ложь;
   КонецЕсли;

КонецПроцедуры

--------------------------
Помогло - скажи спасибо )))

Оффлайн Ришат Гайсин

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-06-09
  • Сайт: 
Летящий в даль, жалуется на поле объекта -____- Указал вроде правильно


Оффлайн Летящий в даль

  • **
  • Сообщений: 56
  • РЕПУТАЦИЯ: 12
  • КПД: 21%
  • 1с - это диагенез :D
  • Регистрация: 2016-05-16
  • Сайт: 
  • Профессия: Программист 1С
Или справь на Элементы

Оффлайн Ришат Гайсин

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-06-09
  • Сайт: 
Летящий в даль, продолжает ссылаться на эту ошибку :dfbsdfbsdf:

Оффлайн Летящий в даль

  • **
  • Сообщений: 56
  • РЕПУТАЦИЯ: 12
  • КПД: 21%
  • 1с - это диагенез :D
  • Регистрация: 2016-05-16
  • Сайт: 
  • Профессия: Программист 1С
выгрузи конфигурацию (Пункт меню Конфигурация \ сохранить конфгурацию в файл) ну или поставь уже точку останова  проверь сидит ли у тебя там данный элемент


Теги:
 

Условие запроса из запроса

Автор ilmir_02Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 976
Последний ответ 24 Июл 2015, 09:01
от ilmir_02
Условие запроса, цикл, конструктор запроса

Автор mashamashaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 301
Последний ответ 31 Янв 2017, 14:29
от Oldman06
Как в условие запроса указать результат другого запроса?

Автор maskitoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4082
Последний ответ 29 Апр 2014, 03:57
от cska-fanat-kz
"ПОДОБНО" в условие связи запроса

Автор Станиславъ ЗверевъРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 2800
Последний ответ 11 Май 2016, 15:29
от LexaK
УТ11.1 - Условие уменьшения скидки: "Если одна из форм оплаты в чеке - Платежная карта"

Автор lsiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2473
Последний ответ 17 Сен 2014, 13:22
от lsi

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
89 Сообщений
alex0402
53 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
43 Сообщений
AIFrame
40 Сообщений
Oldman06
31 Сообщений
vitasw
29 Сообщений
Golickoff Golickoff
27 Сообщений
MuI_I_Ika MuI_I_Ika
18 Сообщений
BuhRust
14 Сообщений
AsadRoman
13 Сообщений

* Кто онлайн

  • Точка Гостей: 253
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal