Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
27 Июл 2017, 09:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Кто может помочь с РегистромСведений  (Прочитано 496 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн webservise

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-06-04
  • Сайт: 
  • Профессия: Консультант 1С
Добрый день.
Может кто сталкивался с РегистромСведений. Перепробовал разные варианты систаксиса -результат ошибки!!!
Исходные данные - есть ТаблицаЗначений (3 колонки дата-имя-событие) нужно программно загрузить эти данные в РегистрСведений.События(реквизиты дата-событие измерение -имя)реквизиты и измерение можно изменить,теории по регистрам так и не нашел, может кто делал такое??? 


Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
см. синтаксис помощник СоздатьНаборЗаписей и СоздатьМенеджерЗаписи

Оффлайн Летящий в даль

  • **
  • Сообщений: 56
  • РЕПУТАЦИЯ: 12
  • КПД: 21%
  • 1с - это диагенез :D
  • Регистрация: 2016-05-16
  • Сайт: 
  • Профессия: Программист 1С


Для каждого Стр из Таблицы Цикл
 Набор = РегистрыНакопления.ИмяРегистра.СоздатьНаборЗаписей();
 Набор.Дата = Стр.Дата;
 Набор.Имя = Стр.Имя ;
 Набор.Событие = Стр.Событие;
 Набор.Записать(Истина);
КонецЦикла;

Онлайн LexaK

  • *****
  • Сообщений: 1249
  • РЕПУТАЦИЯ: 345
  • КПД: 28%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
ржунемогу!!! извините не смог удержаться

Для каждого Стр из Таблицы Цикл
 Набор = РегистрыНакопления.ИмяРегистра.СоздатьНаборЗаписей();
 Набор.Дата = Стр.Дата;
 Набор.Имя = Стр.Имя ;
 Набор.Событие = Стр.Событие;
 Набор.Записать(Истина);
КонецЦикла;

webservise, ни в коем случае так не делайте! а то получите в регистре всего одну запись!

вот более правильный алгоритм, при условии конечно что в регистр нужно поместить ТОЛЬКО данные из таблицы значений


    // 1 раз до цикла создаем набор записей
    лкНабор = РегистрыНакопления.ИмяВашегоРегистра.СоздатьНаборЗаписей();

    Для каждого лкСтр из ТаблицаСДаннымиТЗ Цикл
        лкЗапись = лкНабор.ДОбавить();
        //можно использовать такое заполнение, если совпадают Имена полей/колонок
        ЗаполнитьЗначенияСвойств(лкЗапись, лкСтр);
        // или можно заполнять по полям
        //лкЗапись.Дата = лкСтр.НоваяДата;
    КонецЦикла;
    // 1 раз после цикла, сразу целиком, записываем весь набор данных 
    лкНабор.Записать();

Примечание: Все данные которые были до этого в регистре, будут затерты и заменены на новые данные из таблицы.
если вам надо ДОПОЛНИТЬ или какие-то записи ЗАМЕНИТЬ, то вам необходимо использовать настройки ОТБОР(а)
но это уже другая задача.

Помогло? - Нажми СПАСИБО!!!
                       :)


 

Поле "ВаловаяПрибыль" не может быть использовано в группировке "Store" СКД

Автор virtusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 5694
Последний ответ 10 Июл 2014, 15:16
от virtus
"Период не может быть пустым..."

Автор alexbelРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 3998
Последний ответ 25 Янв 2015, 20:17
от alexbel
Нужна помощь в формировании отчета "Преобразование значения к типу Дата не может быть выполнено"

Автор STLuka1337Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1832
Последний ответ 14 Ноя 2014, 13:24
от cska-fanat-kz
Каким образом может быть просмотрен документ "Реализация товаров", ранее введенн

Автор DDDРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 2735
Последний ответ 25 Ноя 2008, 10:45
от DDD
Конвертация данных, ошибка "Преобразование значения к типу Число не может быть выполнено"

Автор CerebrinРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1628
Последний ответ 10 Май 2015, 21:51
от Дмитрий@

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alex0402
94 Сообщений
oleg-x
71 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
66 Сообщений
Golickoff Golickoff
51 Сообщений
AIFrame
46 Сообщений
ilyay ilyay
42 Сообщений
Амал
30 Сообщений
Dethmontt Dethmontt
22 Сообщений
lansy
22 Сообщений
wise wise
21 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal