Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Мар 2017, 19:57
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Кто может помочь с РегистромСведений  (Прочитано 395 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн webservise

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-06-04
  • Сайт: 
  • Профессия: Консультант 1С
Добрый день.
Может кто сталкивался с РегистромСведений. Перепробовал разные варианты систаксиса -результат ошибки!!!
Исходные данные - есть ТаблицаЗначений (3 колонки дата-имя-событие) нужно программно загрузить эти данные в РегистрСведений.События(реквизиты дата-событие измерение -имя)реквизиты и измерение можно изменить,теории по регистрам так и не нашел, может кто делал такое??? 


Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1345
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
см. синтаксис помощник СоздатьНаборЗаписей и СоздатьМенеджерЗаписи

Оффлайн Летящий в даль

  • **
  • Сообщений: 56
  • РЕПУТАЦИЯ: 12
  • КПД: 21%
  • 1с - это диагенез :D
  • Регистрация: 2016-05-16
  • Сайт: 
  • Профессия: Программист 1С


Для каждого Стр из Таблицы Цикл
 Набор = РегистрыНакопления.ИмяРегистра.СоздатьНаборЗаписей();
 Набор.Дата = Стр.Дата;
 Набор.Имя = Стр.Имя ;
 Набор.Событие = Стр.Событие;
 Набор.Записать(Истина);
КонецЦикла;

Оффлайн LexaK

  • *****
  • Сообщений: 1173
  • РЕПУТАЦИЯ: 313
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
ржунемогу!!! извините не смог удержаться

Для каждого Стр из Таблицы Цикл
 Набор = РегистрыНакопления.ИмяРегистра.СоздатьНаборЗаписей();
 Набор.Дата = Стр.Дата;
 Набор.Имя = Стр.Имя ;
 Набор.Событие = Стр.Событие;
 Набор.Записать(Истина);
КонецЦикла;

webservise, ни в коем случае так не делайте! а то получите в регистре всего одну запись!

вот более правильный алгоритм, при условии конечно что в регистр нужно поместить ТОЛЬКО данные из таблицы значений


    // 1 раз до цикла создаем набор записей
    лкНабор = РегистрыНакопления.ИмяВашегоРегистра.СоздатьНаборЗаписей();

    Для каждого лкСтр из ТаблицаСДаннымиТЗ Цикл
        лкЗапись = лкНабор.ДОбавить();
        //можно использовать такое заполнение, если совпадают Имена полей/колонок
        ЗаполнитьЗначенияСвойств(лкЗапись, лкСтр);
        // или можно заполнять по полям
        //лкЗапись.Дата = лкСтр.НоваяДата;
    КонецЦикла;
    // 1 раз после цикла, сразу целиком, записываем весь набор данных 
    лкНабор.Записать();

Примечание: Все данные которые были до этого в регистре, будут затерты и заменены на новые данные из таблицы.
если вам надо ДОПОЛНИТЬ или какие-то записи ЗАМЕНИТЬ, то вам необходимо использовать настройки ОТБОР(а)
но это уже другая задача.

Помогло? - Нажми СПАСИБО!!!
                       :)


 

Поле "ВаловаяПрибыль" не может быть использовано в группировке "Store" СКД

Автор virtusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4939
Последний ответ 10 Июл 2014, 15:16
от virtus
"Период не может быть пустым..."

Автор alexbelРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 3327
Последний ответ 25 Янв 2015, 20:17
от alexbel
Нужна помощь в формировании отчета "Преобразование значения к типу Дата не может быть выполнено"

Автор STLuka1337Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1610
Последний ответ 14 Ноя 2014, 13:24
от cska-fanat-kz
Каким образом может быть просмотрен документ "Реализация товаров", ранее введенн

Автор DDDРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 2557
Последний ответ 25 Ноя 2008, 10:45
от DDD
Конвертация данных, ошибка "Преобразование значения к типу Число не может быть выполнено"

Автор CerebrinРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1375
Последний ответ 10 Май 2015, 21:51
от Дмитрий@

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
alex0402
115 Сообщений
Norfolk
51 Сообщений
LexaK
45 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
друган
21 Сообщений
AsadRoman
20 Сообщений
alexandr_ll
20 Сообщений
Alex55
18 Сообщений
Константин5825
18 Сообщений

* Кто онлайн

  • Точка Гостей: 324
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal