Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Янв 2017, 18:28
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите сделать печатный документ  (Прочитано 1369 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн vaxilion

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-04-25
    • Skype: vasi4ka4
  • Сайт: 
  • Профессия: Разработчик 1С
Помогите пожалуста сделать печатный документ ВыданаяНН. Есть макет для печати. Его выводит, но без данных из документа. Написал такую процедуру:
Процедура Печать(ТабДок, Ссылка) Экспорт
//{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
//ТабДокумент = Новый ТабличныйДокумент;
//ТабДокумент.КлючПараметровПечати  = "ПАРАМЕТРЫ_ПЕЧАТИ_НалоговаяНакладная_2016" + ИмяМакета;
Макет = Документы.ВыданнаяНН.ПолучитьМакет("НДС2016Альбом");
//Если ИмяМакета = "НалоговаяНакладнаяАльбом" Тогда
// Макет = ПолучитьМакет("НДС2016Альбом");
// ТабДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
//КонецЕсли;


Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ

| ВыданнаяНН.ВидНДС,
| ВыданнаяНН.Выписал,
| ВыданнаяНН.Дата,
| ВыданнаяНН.ДатаДокумента,
| ВыданнаяНН.ЕРНН,
| ВыданнаяНН.ЕстьНулевыеСтавкиНДС,
| ВыданнаяНН.Итоговая,
| ВыданнаяНН.Контрагент,
| ВыданнаяНН.НДС,
| ВыданнаяНН.Номер,
| ВыданнаяНН.НомерДокумента,
| ВыданнаяНН.Организация,
| ВыданнаяНН.ВидОперации,
| ВыданнаяНН.Оставляем,
| ВыданнаяНН.СпецРежимНалогообложения,
| ВыданнаяНН.СуммаБезНДС,
| ВыданнаяНН.СуммаСНДС,
| ВыданнаяНН.УточняющийРасчет,
| ВыданнаяНН.Состав.(
| НомерСтроки,
| Номенклатура,
| СуммаБезНДС,
| НДС,
| СуммаСНДС,
| ЦенаБезНДС,
| ЦенаСНДС,
| Количество,
| ЕдиницаИзмерения,
| КодУКТВЭД
| )
|ИЗ
| Документ.ВыданнаяНН КАК ВыданнаяНН
|ГДЕ
| ВыданнаяНН.Ссылка В (&Ссылка)";
Запрос.Параметры.Вставить("Ссылка", Ссылка);
Выборка = Запрос.Выполнить().Выбрать();



ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
ОбластьПробел = Макет.ПолучитьОбласть("Пробел");

Оригинал = Макет.ПолучитьОбласть("Оригинал");
//Заголовок = Макет.ПолучитьОбласть("Заголовок");

Шапка = Макет.ПолучитьОбласть("Шапка");
//ОбластьСоставШапка = Макет.ПолучитьОбласть("СоставШапка");
//ОбластьСостав = Макет.ПолучитьОбласть("Состав");
ОбластьСостав = Макет.ПолучитьОбласть("РазделI");
Подвал = Макет.ПолучитьОбласть("Подвал");

ТабДок.Очистить();

ВставлятьРазделительСтраниц = Ложь;
Пока Выборка.Следующий() Цикл
Если ВставлятьРазделительСтраниц Тогда
ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
КонецЕсли;

//ТабДок.Вывести(ОбластьЗаголовок);
ТабДок.Вывести(ОбластьПробел);
ТабДок.Вывести(Оригинал);

Шапка.Параметры.Заполнить(Выборка);
ТабДок.Вывести(Шапка, Выборка.Уровень());

//ТабДок.Вывести(ОбластьСоставШапка);
ВыборкаСостав = Выборка.Состав.Выбрать();
Пока ВыборкаСостав.Следующий() Цикл
ОбластьСостав.Параметры.Заполнить(ВыборкаСостав);
ТабДок.Вывести(ОбластьСостав, ВыборкаСостав.Уровень());
КонецЦикла;

Подвал.Параметры.Заполнить(Выборка);
ТабДок.Вывести(Подвал);

ВставлятьРазделительСтраниц = Истина;
КонецЦикла;
//}}
КонецПроцедуры

Вот так выгледит макет

 Помогите дописать процедуру, чтобы все выводило из документа.


Оффлайн crow1983

  • Глобальный модератор
  • *****
  • Сообщений: 431
  • РЕПУТАЦИЯ: 43
  • КПД: 10%
  • Регистрация: 2010-04-26
  • Сайт: 
  • Профессия: Программист 8.1
Выборка.Следующий (); после первого запроса. Через отладку можно посмотреть результаты.
Преподаватель, программист...и просто хороший человек

Оффлайн Тём

  • *
  • Сообщений: 19
  • РЕПУТАЦИЯ: 2
  • КПД: 11%
  • Регистрация: 2016-06-07
  • Сайт: 
ЧТо то мне подсказывает, что наименования полей выборки не соответствуют наименованиям параметров в макете. Программа не знает что куда вставлять. Воспользуйтесь в запросе представлениями строк.

Далее, область "Оригинал" вообще ничем не заполняется.

Далее, цикл Выборка.Следующий() в цикле Выборка.Следующий(), работать должно, но выглядит не слишком красиво.

Оффлайн vaxilion

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-04-25
    • Skype: vasi4ka4
  • Сайт: 
  • Профессия: Разработчик 1С
Цитировать
ЧТо то мне подсказывает, что наименования полей выборки не соответствуют наименованиям параметров в макете. Программа не знает что куда вставлять. Воспользуйтесь в запросе представлениями строк.

Далее, область "Оригинал" вообще ничем не заполняется.

Далее, цикл Выборка.Следующий() в цикле Выборка.Следующий(), работать должно, но выглядит не слишком красиво.

Помогло исправление названий параметров в макете
Добавлено: 08 Июн 2016, 14:49

1 вопрос. Как сделать так, чтобы дата разбивалась по ячейках? Например не так 08.06.2016 должно быть, а 0 8 0 6 2 0 1 6 в каждой клетке.

Последний раз редактировалось: vaxilion; 08 Июн 2016, 14:49. Причина: Объединение сообщений

Оффлайн Golickoff

  • ***
  • Сообщений: 190
  • РЕПУТАЦИЯ: 11
  • КПД: 6%
  • Регистрация: 2015-02-05
  • Сайт: 
  • Профессия: Ученик 1С
Как сделать так, чтобы дата разбивалась по ячейках? Например не так 08.06.2016 должно быть, а 0 8 0 6 2 0 1 6 в каждой клетке.
На макете не видно. Напишите как называются параметры даты, хотя бы первые два.

Оффлайн vaxilion

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-04-25
    • Skype: vasi4ka4
  • Сайт: 
  • Профессия: Разработчик 1С
Как сделать так, чтобы дата разбивалась по ячейках? Например не так 08.06.2016 должно быть, а 0 8 0 6 2 0 1 6 в каждой клетке.
На макете не видно. Напишите как называются параметры даты, хотя бы первые два.
Датадокумента_1, ДатаДокумента_2 и т.д.
Добавлено: 08 Июн 2016, 15:21

Как сделать так, чтобы дата разбивалась по ячейках? Например не так 08.06.2016 должно быть, а 0 8 0 6 2 0 1 6 в каждой клетке.
На макете не видно. Напишите как называются параметры даты, хотя бы первые два.
Датадокумента_1, ДатаДокумента_2 и т.д.

Сама нужная мне дата храниться в  |    ВыданнаяНН.ДатаДокумента,

Оффлайн Golickoff

  • ***
  • Сообщений: 190
  • РЕПУТАЦИЯ: 11
  • КПД: 6%
  • Регистрация: 2015-02-05
  • Сайт: 
  • Профессия: Ученик 1С
ДатаТекст=СтрЗаменить(Строка(Формат(ВыданнаяНН.ДатаДокумента,"MM.DD.yyyy"),".","")
Для Симв = 1 По СтрДлина(ДатаТекст) Цикл
     ТекущийСимвол = Сред(ДатаТекст, Симв, 1);
     НужнаяОбласть.Параметры["ДатаДокумента_" + Строка(Симв)] = ТекущийСимвол;
КонецЦикла;

Оффлайн vaxilion

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-04-25
    • Skype: vasi4ka4
  • Сайт: 
  • Профессия: Разработчик 1С
ОбластьШапка.Параметры.Заполнить(Выборка);
ДатаДокумента = Выборка.Выбрать(ДатаДокумента);
Для Симв = 1 По СтрДлина(ДатаДокумента) Цикл
     ТекущийСимвол = Сред(ДатаДокумента, Симв, 1);
    ОбластьШапка.Параметры["ДатаДокумента_1" + Строка(Симв)] = ТекущийСимвол;
КонецЦикла;

ТабДок.Вывести(ОбластьШапка, Выборка.Уровень());



Оффлайн Golickoff

  • ***
  • Сообщений: 190
  • РЕПУТАЦИЯ: 11
  • КПД: 6%
  • Регистрация: 2015-02-05
  • Сайт: 
  • Профессия: Ученик 1С
Скопируйте сюда текст ошибки, скрывающийся за кнопкой "Подробно...".
Добавлено: 08 Июн 2016, 15:39

Можете не копировать. Я чуть позже дописал код, посмотрите предыдущее сообщение. Вам нужно превратить дату в строку.
Добавлено: 08 Июн 2016, 15:40

После строки
ДатаДокумента = Выборка...
вставьте это
ДатаТекст=СтрЗаменить(Строка(Формат(ДатаДокумента,"MM.DD.yyyy"),".","")
Для Симв = 1 По СтрДлина(ДатаТекст) Цикл
     ТекущийСимвол = Сред(ДатаТекст, Симв, 1);
     НужнаяОбласть.Параметры["ДатаДокумента_" + Строка(Симв)] = ТекущийСимвол;
КонецЦикла;
Добавлено: 08 Июн 2016, 15:41

А вот эту строку
ОбластьШапка.Параметры["ДатаДокумента_" + Строка(Симв)] = ТекущийСимвол;
оставьте как есть. Не нужно в неё ничего дописывать. "ДатаДокумента_" так и должна быть "ДатаДокумента_".

Оффлайн vaxilion

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-04-25
    • Skype: vasi4ka4
  • Сайт: 
  • Профессия: Разработчик 1С
Написал так: 

ОбластьШапка.Параметры.Заполнить(Выборка);
      ДатаДокумента = Выборка.Выбрать(ДатаДокумента);
      ДатаТекст=СтрЗаменить(Строка(Формат(ДатаДокумента,"MM.DD.yyyy"),".","")
Для Симв = 1 По СтрДлина(ДатаТекст) Цикл
     ТекущийСимвол = Сред(ДатаТекст, Симв, 1);
     ОбластьШапка.Параметры["ДатаДокумента_" + Строка(Симв)] = ТекущийСимвол;
КонецЦикла;

ТабДок.Вывести(ОбластьШапка, Выборка.Уровень());


Ошыбка: {Документ.ВыданнаяНН.МодульМенеджера(148,66)}: Ожидается символ ')'
      ДатаТекст=СтрЗаменить(Строка(Формат(ДатаДокумента,"MM.DD.yyyy")<<?>>,".","") (Проверка: Сервер)



не вижу где нехватает дужки :D


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 1518
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3517
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 3807
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1665
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 179
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
174 Сообщений
alex0402
58 Сообщений
MuI_I_Ika MuI_I_Ika
51 Сообщений
crow1983
37 Сообщений
LexaK
32 Сообщений
alexandr_ll
29 Сообщений
sertak sertak
25 Сообщений
Vzonder
21 Сообщений
BuhRust
18 Сообщений
дфтын дфтын
17 Сообщений

* Кто онлайн

  • Точка Гостей: 530
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal