Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Янв 2017, 21:07
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не получает значение из справочника в обработку  (Прочитано 324 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн marshalbratsk

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-05-25
  • Сайт: 
  • Профессия: Ученик 1С
Пытаюсь вывести значение из справочника в поле обработки (в данном случае Сообщить пытаюсь). Но не хочет работать. Прикрепляю функцию с запросом и процедуру. Что не так?:dfbsdfbsdf:

 Функция ПолучитьСтавку(Наименование)
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Водители.Наименование,
| Водители.Ставка
|ИЗ
| Справочник.Водители КАК Водители
|ГДЕ
| Водители.Наименование = &Наименование";

Запрос.УстановитьПараметр("Наименование", Наименование);

Результат = Запрос.Выполнить();
Если Результат.Пустой() Тогда
Возврат 0;
Иначе
Выборка = Результат.Выбрать();
Выборка.Следующий();
Возврат Выборка.Ставка;
КонецЕсли

КонецФункции
&НаКлиенте
Процедура ВодительПриИзменении(Элемент)
Сообщить(ПолучитьСтавку(Объект.Водитель));
КонецПроцедуры


Оффлайн LexaK

  • *****
  • Сообщений: 1079
  • РЕПУТАЦИЯ: 282
  • КПД: 26%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
куча ошибок, корявый код,

самая главная ошибка
Водители.Наименование = &Наименование";

замените на

Водители.Ссылка = &Наименование";
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн marshalbratsk

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-05-25
  • Сайт: 
  • Профессия: Ученик 1С
куча ошибок, корявый код,

самая главная ошибка
Водители.Наименование = &Наименование";

замените на

Водители.Ссылка = &Наименование";
Спасибо, заработало) Я только учусь, пока говнокоды на костылях получаются

Оффлайн LexaK

  • *****
  • Сообщений: 1079
  • РЕПУТАЦИЯ: 282
  • КПД: 26%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
а-а-а, тогда понятно!
не забываем нажимать кнопку: Спасибо!
Помогло? - Нажми СПАСИБО!!!
                       :)


Теги:
 

Как вызвать "Анализ субконто" из справочника "Контрагенты"

Автор EnigManРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 5529
Последний ответ 06 Фев 2012, 10:46
от cska-fanat-kz
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2593
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Работа с формой Справочника "Физ.Лица" в ЗУП 2.5

Автор Митя_Просто_МитяРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3161
Последний ответ 15 Дек 2011, 00:04
от Vit1501
Удалить запись из справочника "Сотрудники" уволенного

Автор Alex56Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2458
Последний ответ 02 Фев 2014, 21:37
от LordWizard
Как в 1С 8.2 при проведении документа заполнить элемент справочника информацией из документа?

Автор Галина55555Раздел Беседка

Ответов: 1
Просмотров: 4168
Последний ответ 01 Июл 2014, 16:44
от Галина55555

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
162 Сообщений
alex0402
74 Сообщений
alexandr_ll
38 Сообщений
LexaK
32 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
crow1983
31 Сообщений
sertak sertak
26 Сообщений
BuhRust
18 Сообщений
Vzonder
17 Сообщений
дфтын дфтын
17 Сообщений

* Кто онлайн

  • Точка Гостей: 370
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal