Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
27 Июл 2017, 11:41
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите допилить дополнительный отчет на СКД  (Прочитано 1743 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Алексей Шмуйлович

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-06-03
  • Сайт: 
Здравствуйте, уважаемые!

Помогите, пожалуйста, доделать дополнительный отчет.

Написал дополнительный отчет по образцу отчета из БСП (_ДемоКонтекстныйОтчет). Отчет назначаемый - привязан к списку или форме документа.
Написан на СКД. Работает корректно. Только одна загвоздка - не получается программно задать параметр. В примере из СКД привязка к назначаемым документам осуществляется через отбор, а мне нужно сделать это через параметр данных. И это сделать не получается.

Для знающего человека - исправить одну строчку кода в процедуре ПриСозданииНаСервере.

Вот весь код модуля объекта:

////////////////////////////////////////////////////////////////////////////////
// ПРОГРАММНЫЙ ИНТЕРФЕЙС

#Область ПрограммныйИнтерфейс

// Возвращает сведения о внешней обработке.

Функция СведенияОВнешнейОбработке() Экспорт
ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("2.2.5.1");

ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиОтчет();
ПараметрыРегистрации.Версия = "1.6";
ПараметрыРегистрации.Назначение.Добавить("Документ.РеализацияТоваровУслуг");
ПараметрыРегистрации.ОпределитьНастройкиФормы = Истина;

НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
НоваяКоманда.Представление = НСтр("ru = 'Анализ рентабельности продаж'");
НоваяКоманда.Идентификатор = "Основная";
НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыОткрытиеФормы();
НоваяКоманда.ПоказыватьОповещение = Ложь;

Возврат ПараметрыРегистрации;


КонецФункции
// Настройки общей формы отчета подсистемы "Варианты отчетов".
//
// Параметры:
//   Форма - УправляемаяФорма, Неопределено - Форма отчета или форма настроек отчета.
//       Неопределено когда вызов без контекста.
//   КлючВарианта - Строка, Неопределено - Имя предопределенного
//       или уникальный идентификатор пользовательского варианта отчета.
//       Неопределено когда вызов без контекста.
//   Настройки - Структура - см. возвращаемое значение
//       ОтчетыКлиентСервер.ПолучитьНастройкиОтчетаПоУмолчанию().
//
Процедура ОпределитьНастройкиФормы(Форма, КлючВарианта, Настройки) Экспорт
Настройки.ФормироватьСразу = Истина;
Настройки.События.ПриСозданииНаСервере = Истина;
КонецПроцедуры

// Вызывается в обработчике одноименного события формы отчета после выполнения кода формы.
//
// Параметры:
//   Форма - УправляемаяФорма - Форма отчета.
//   Отказ - Передается из параметров обработчика "как есть".
//   СтандартнаяОбработка - Передается из параметров обработчика "как есть".
//
// См. также:
//   "УправляемаяФорма.ПриСозданииНаСервере" в синтакс-помощнике.
//
Процедура ПриСозданииНаСервере(Форма, Отказ, СтандартнаяОбработка) Экспорт
ОбъектыНазначения = ОбщегоНазначенияКлиентСервер.СвойствоСтруктуры(Форма.Параметры, "ОбъектыНазначения");
Если ОбъектыНазначения <> Неопределено Тогда

///// ВОТ ЭТА СТРОЧКА НЕ РАБОТАЕТ:
Форма.ФормаПараметры.УстановитьЗанчениеПараметра("Регистратор", ОбъектыНазначения);


КонецЕсли;
КонецПроцедуры


#КонецОбласти

Сам отчет прикладываю.




Онлайн LexaK

  • *****
  • Сообщений: 1249
  • РЕПУТАЦИЯ: 345
  • КПД: 28%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
1.проверьте заполнение реквизита: Хранилище вариантов в вашем отчете, без него не работает вызов: ОпределитьНастройкиФормы
2.ошибка в модуле отчета, в процедуре  ПриСозданииНаСервере(Форма, Отказ, СтандартнаяОбработка) Экспорт
код
    Форма.ФормаПараметры.УстановитьЗанчениеПараметра("Регистратор", ОбъектыНазначения);

замените на такой

    Форма.ФормаПараметры.Отбор = Новый Структура("Регистратор", ОбъектыНазначения);

после таких изменений, ваш отчет у меня (база БП30 корп) заработал в автоматическом режиме,
как из списка документов Реализация, так и из формы документа, по кнопке: Отчеты - Анализ рентабельности.

 
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн Алексей Шмуйлович

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-06-03
  • Сайт: 
1.проверьте заполнение реквизита: Хранилище вариантов в вашем отчете, без него не работает вызов: ОпределитьНастройкиФормы
2.ошибка в модуле отчета, в процедуре  ПриСозданииНаСервере(Форма, Отказ, СтандартнаяОбработка) Экспорт
код
    Форма.ФормаПараметры.УстановитьЗанчениеПараметра("Регистратор", ОбъектыНазначения);

замените на такой

    Форма.ФормаПараметры.Отбор = Новый Структура("Регистратор", ОбъектыНазначения);

после таких изменений, ваш отчет у меня (база БП30 корп) заработал в автоматическом режиме,
как из списка документов Реализация, так и из формы документа, по кнопке: Отчеты - Анализ рентабельности.

 

Сделал все по вашему слову, к сожалению, не работает. У меня тоже БП30? только не корп. Но это, вроде, не должно влиять.
В образце из БСП нет реквизита отчета ХранилищеВариантов, а он работает.
А какого типа этот реквизит должен быть?

Вы не могли бы выложить отчет, который у Вас получился, который работает?

Онлайн LexaK

  • *****
  • Сообщений: 1249
  • РЕПУТАЦИЯ: 345
  • КПД: 28%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
да это ваш же отчет.
выкладываю.
на рис. Свойство отчета Хранилище вариантов, заполненное.
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн Алексей Шмуйлович

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-06-03
  • Сайт: 
Хранилище вариантов нашел, спасибо. Я тупил, не мог найти, как свойства самого внешнего отчета открыть.
Но, к сожалению, опять не помогло. Не работает. Ваш отчет тоже у меня не работает.
Не заполняет поле параметра и не формирует отчет при открытии.
Если выбираешь документ вручную и нажимаешь "Сформировать" то все формирует правильно и сохраняет настройку. При следующем открытии параметр регистрация заполняется не нужными документами их ОбъектыНазначения, а теми, что сохранились с прошлого раза.
Добавлено: 09 Июн 2016, 11:56

Добавил в ПриСозданииНаСервере и ОпределитьНастройкиФормы контрольные строчки Сообщить(...). Ни одно сообщение не выползает. Я так понимаю, мой код вообще не выполняется.

Последний раз редактировалось: Алексей Шмуйлович; 09 Июн 2016, 11:56. Причина: Объединение сообщений

Онлайн LexaK

  • *****
  • Сообщений: 1249
  • РЕПУТАЦИЯ: 345
  • КПД: 28%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
даже не знаю,  :dfbsdfbsdf:  может у вас какая-то старая версия базы, БСП?
тогда только остается обратиться к настоящему программисту 1С, который чего хочешь настроит и запрограммирует. :)
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн Алексей Шмуйлович

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-06-03
  • Сайт: 
ЧуднО. Поставил на рабочую базу, чтобы пользовались хотя бы с ручным выбором, а он работает! Может он на файловой версии работать не хотел? Только на серверной?
Еще раз огромное спасибо!


 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3991
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5252
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5567
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 3706
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1777
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alex0402
94 Сообщений
oleg-x
71 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
66 Сообщений
Golickoff Golickoff
51 Сообщений
AIFrame
46 Сообщений
ilyay ilyay
42 Сообщений
Амал
30 Сообщений
lansy
22 Сообщений
BuhRust
22 Сообщений
Dethmontt Dethmontt
22 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal