Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
30 Мар 2017, 15:33
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Копирование данных с регистра в регистр  (Прочитано 418 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн akaipbay

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-04-25
    • Skype: akaipbay
  • Сайт: 
  • Профессия: Ученик 1С
Здравсвуйте!

Пытаюсь скопировать данные с регистра КурсВалют в копию такого же регистра со смещением даты на -1 день.
Сделал обработку, на форме кнопка, в кнопке процедура

Процедура КнопкаВыполнитьНажатие(Кнопка)

// Вставить содержимое обработчика.
      //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
// Данный фрагмент построен конструктором.
// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| КурсыВалют.Период КАК Период,
| КурсыВалют.Валюта КАК Валюта,
| КурсыВалют.Курс КАК Курс,
| КурсыВалют.Кратность КАК Кратность
|ИЗ
| РегистрСведений.КурсыВалют КАК КурсыВалют";

Результат = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = Результат.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
// Вставить обработку выборки ВыборкаДетальныеЗаписи
        Дата = НачалоДня(ВыборкаДетальныеЗаписи.Период);
НоваяЗапись = РегистрыСведений.КурсыВалютKASE.СоздатьМенеджерЗаписи();
НоваяЗапись.Период = Дата - 24*60*60;
НоваяЗапись.Валюта = ВыборкаДетальныеЗаписи.Валюта;
НоваяЗапись.Курс = ВыборкаДетальныеЗаписи.Курс;
НоваяЗапись.Кратность = ВыборкаДетальныеЗаписи.Кратность;
НоваяЗапись.Записать();
КонецЦикла;

//}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА

КонецПроцедуры

Код не работает, подскажите что не так?


Оффлайн Rasty

  • *****
  • Сообщений: 973
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
НаборЗаписей= РегистрыСведений.КурсыВалютKASE.СоздатьНаборЗаписей();
Цикл
Запись = НаборЗаписей.Добавить();
...
...
...
...
КонецЦикла;
НаборЗаписей.Записать()

Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн akaipbay

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-04-25
    • Skype: akaipbay
  • Сайт: 
  • Профессия: Ученик 1С
НаборЗаписей= РегистрыСведений.КурсыВалютKASE.СоздатьНаборЗаписей();
Цикл
Запись = НаборЗаписей.Добавить();
...
...
...
...
КонецЦикла;
НаборЗаписей.Записать()

спасибо разобрался


Теги:
 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 6351
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3301
Последний ответ 19 Май 2014, 15:40
от kot_oo
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1257
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 5482
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 5778
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
alex0402
126 Сообщений
MuI_I_Ika MuI_I_Ika
55 Сообщений
Norfolk
52 Сообщений
LexaK
51 Сообщений
alexandr_ll
25 Сообщений
друган
20 Сообщений
AsadRoman
18 Сообщений
Константин5825
18 Сообщений
ef0din
18 Сообщений

* Кто онлайн

  • Точка Гостей: 963
  • Точка Скрытых: 0
  • Точка Пользователей: 21
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal