Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Янв 2017, 06:01
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проблема с отпусками ЗУП 2.5  (Прочитано 358 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ksander-fars

  • **
  • Сообщений: 56
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-05-04
  • Сайт: 
  • Профессия: Программист 1С
ДД!

1) Создан документ отпуска для работника с 26.04.2016 по 29.05.2016
+ дополнительный отпуск с 30.05.2016  по 05.06.2016
2) Затем создали второй документ-исправление где убрали дополнительный отпуск.

Вопрос: Теперь при попытке указать рабочее время в сдельном наряде например на 30.05.2016 появляется сообщение с ошибкой (скрин).
Процедура ВывестиНеявкиЗаМесяц(пСотрудник, Д1, Д2) Экспорт
   Запрос = Новый Запрос("ВЫБРАТЬ РАЗРЕШЕННЫЕ РАЗЛИЧНЫЕ
                         |   ОсновныеНачисленияРаботниковОрганизаций.Регистратор КАК Регистратор,
                         |   ОсновныеНачисленияРаботниковОрганизаций.ПериодДействияНачало КАК ПериодДействияНачало,
                         |   ОсновныеНачисленияРаботниковОрганизаций.ПериодДействияКонец КАК ПериодДействияКонец,
                         |   ОсновныеНачисленияРаботниковОрганизаций.Сотрудник КАК Сотрудник,
                         |   ОсновныеНачисленияРаботниковОрганизаций.ВидРасчета КАК ВидРасчета
                         |ИЗ
                         |   РегистрРасчета.ОсновныеНачисленияРаботниковОрганизаций КАК ОсновныеНачисленияРаботниковОрганизаций
                         |ГДЕ
                         |   НЕ ОсновныеНачисленияРаботниковОрганизаций.ВидРасчета.ЗачетОтработанногоВремени
                         |   И ОсновныеНачисленияРаботниковОрганизаций.ВидРасчета.ЗачетНормыВремени
                         |   И ОсновныеНачисленияРаботниковОрганизаций.Сотрудник = &Сотрудник
                         |   И (&Д1 МЕЖДУ ОсновныеНачисленияРаботниковОрганизаций.ПериодДействияНачало И ОсновныеНачисленияРаботниковОрганизаций.ПериодДействияКонец
                         |         ИЛИ &Д2 МЕЖДУ ОсновныеНачисленияРаботниковОрганизаций.ПериодДействияНачало И ОсновныеНачисленияРаботниковОрганизаций.ПериодДействияКонец)
                         |
                         |УПОРЯДОЧИТЬ ПО
                         |   ПериодДействияНачало,
                         |   ПериодДействияКонец");
                   
   Запрос.УстановитьПараметр("Д1", НачалоДня(Д1));
   Запрос.УстановитьПараметр("Д2", КонецДня(Д2));
   Запрос.УстановитьПараметр("Сотрудник", пСотрудник);
   
   
   Выборка = Запрос.Выполнить().Выбрать();
   
   ТекстПредупреждение = "";
   ТекстСотрудник = "";
   Пока Выборка.Следующий() Цикл
      ТекстСотрудник = Выборка.Сотрудник.Наименование;
      ТекстПредупреждение = ТекстПредупреждение + "[" + Выборка.ВидРасчета.Наименование + "] за период с "+ Формат(Выборка.ПериодДействияНачало, "ДЛФ=D") +" по "+ Формат(Выборка.ПериодДействияКонец, "ДЛФ=D") +" ("+ Выборка.Регистратор +")"+Символы.ПС;
      //Сообщить(Выборка.Сотрудник.Наименование + " начисление [" + Выборка.ВидРасчета.Наименование + "] за период с "+ Формат(Выборка.ПериодДействияНачало, "ДЛФ=D") +" по "+ Формат(Выборка.ПериодДействияКонец, "ДЛФ=D") +" ("+ Выборка.Регистратор +")");
   КонецЦикла;
   Если ЗначениеЗаполнено(ТекстПредупреждение) Тогда
      #Если ТолстыйКлиентОбычноеПриложение тогда
         Предупреждение(ТекстПредупреждение, , ТекстСотрудник);
      #КонецЕсли
   КонецЕсли;
   
КонецПроцедуры
 
Код прописан в общем модуле, подскажите в какую сторону копать? Как я понимаю что по идее документ-исправление должно перекрывать основной документ.


Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Оффлайн ksander-fars

  • **
  • Сообщений: 56
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-05-04
  • Сайт: 
  • Профессия: Программист 1С
Как я понял нужно сделать условие что если документ сторно, то делать проверку по его периоду действия(указанному периоду отпуска)? Как в случае нахождения сторно документа не проверять исправленный документ?


Теги:
 

Проблема с выгрузкой НН в "Звит" Не найдено соответствие для схемы "J1201008"

Автор AldemaHРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 657
Последний ответ 06 Июл 2016, 09:19
от AldemaH
проблема с "ЗагрузкаДанныхИзТабличногоДокумента"

Автор bratmaratРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 3803
Последний ответ 08 Янв 2014, 14:30
от LordWizard
Проблема с развертыванием окон и сохранением окон

Автор SokresРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 1153
Последний ответ 09 Дек 2015, 14:09
от pavl_vs
Проблема с отчетом "Перемещение товаров"

Автор sailРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2743
Последний ответ 14 Дек 2010, 20:27
от progmikon
1C 8.2 УПП проблема с отчетом "Задолженость по контрагентам"

Автор LeonidLeonidРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2926
Последний ответ 26 Сен 2011, 20:42
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
alex0402
56 Сообщений
MuI_I_Ika MuI_I_Ika
49 Сообщений
crow1983
35 Сообщений
LexaK
32 Сообщений
alexandr_ll
28 Сообщений
sertak sertak
25 Сообщений
Vzonder
21 Сообщений
BuhRust
17 Сообщений
дфтын дфтын
17 Сообщений

* Кто онлайн

  • Точка Гостей: 250
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal