Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 21:36
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как привязать введённую Дату на форме к параметру запроса этого модуля ?  (Прочитано 833 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ksander-fars

  • **
  • Сообщений: 78
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2016-05-04
  • Сайт: 
  • Профессия: Ученик 1С
ДД!

Создал внешнюю обработку, в модуле создал запрос. на форму добавил поле ввода для начала периода.

Подскажите как мне привязать поле ввода периода к параметру в запросе?

Вопрос конечно несерьёзный, но я только недавно работаю с 1С....



Оффлайн ksander-fars

  • **
  • Сообщений: 78
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2016-05-04
  • Сайт: 
  • Профессия: Ученик 1С
Решено

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)

 
Процедура ОсновныеДействияФормыОсновныеДействияФормыВыполнить(Кнопка)
   
   ТекстЗапрос = Новый Запрос;
   ТекстЗапрос.УстановитьПараметр("ДатаНачала",ДатаНачала);
   ТекстЗапрос.Текст="ВЫБРАТЬ
                     |   НачислениеПоБольничномуЛисту.Сотрудник,
                     |   НачислениеПоБольничномуЛисту.ПричинаНетрудоспособности,
                     |   НачислениеПоБольничномуЛисту.ДатаНачала,
                     |   НачислениеПоБольничномуЛисту.ДатаОкончания
                     |ИЗ
                     |   Документ.НачислениеПоБольничномуЛисту КАК         НачислениеПоБольничномуЛисту
                     |ГДЕ
                     |   НачислениеПоБольничномуЛисту.ДатаНачала >= &ДатаНачала";
                ТЗ = ТекстЗапрос.Выполнить().Выгрузить();
                ВыбранныйЭлемент = ТЗ.ВыбратьСтроку();
                Сообщить(ВыбранныйЭлемент.Зарплата);
                                  
КонецПроцедуры
         

Добавлено: 02 Июн 2016, 05:28

Следующий вопрос.

Как при закрытии формы сохранить значения введёные в поля НачалоПериода и КонецПериода, а при открытии автоматически восстанавливались например в таком коде?


Процедура НачПериодаПриИзменении(Элемент)
   УстановитьПараметрыПериода();
КонецПроцедуры

Процедура КонПериодаПриИзменении();
   УстановитьПараметрыПериода();
КонецПроцедуры

Процедура УстановитьПараметрыПериода()
   
   Параметр=КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра
(Новый ПараметрКомпоновкиДанных("КонецПериода"));
   Параметр.Значение = КонецДня(КонПериода);
   Параметр.Использование = Истина;
   
   Параметр = КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра
(Новый ПараметрКомпоновкиДанных("НачалоПериода"));
   Параметр.Значение = НачПериода;
   Параметр.Использование = Истина;

КонецПроцедуры

Процедура ВыбПериодНажатие(Элемент);
   
   НастройкаПериода = Новый НастройкаПериода;
   НастройкаПериода.УстановитьПериод(НачПериода, ?(КонПериода='0001-01-01', КонПериода,
КонецДня(КонПериода)));
   НастройкаПериода.РедактироватьКакИнтервал = Истина;
   НастройкаПериода.РедактироватьКакПериод = Истина;
   НастройкаПериода.ВариантНастройки = ВариантНастройкиПериода.Период;
   Если НастройкаПериода.Редактировать() Тогда
      НачПериода = НастройкаПериода.ПолучитьДатуНачала();
      КонПериода = НастройкаПериода.ПолучитьДатуОкончания();
   КонецЕсли;
   
   УстановитьПараметрыПериода();
КонецПроцедуры

Добавлено: 02 Июн 2016, 05:49

Решено

Процедура ПриОткрытии()
   НачПериода = ВосстановитьЗначение("КадровыеОтчеты_НачПериода");
   КонПериода = ВосстановитьЗначение("КадровыеОтчеты_Конпериода");
КонецПроцедуры

Процедура НачПериодаПриИзменении(Элемент)
   УстановитьПараметрыПериода();
КонецПроцедуры

Процедура КонПериодаПриИзменении();
   УстановитьПараметрыПериода();
КонецПроцедуры

Процедура УстановитьПараметрыПериода()
   
   Параметр=КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра
(Новый ПараметрКомпоновкиДанных("КонецПериода"));
   Параметр.Значение = КонецДня(КонПериода);
   Параметр.Использование = Истина;
   
   Параметр = КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра
(Новый ПараметрКомпоновкиДанных("НачалоПериода"));
   Параметр.Значение = НачПериода;
   Параметр.Использование = Истина;

КонецПроцедуры

Процедура ВыбПериодНажатие(Элемент);
   
   НастройкаПериода = Новый НастройкаПериода;
   НастройкаПериода.УстановитьПериод(НачПериода, ?(КонПериода='0001-01-01', КонПериода,
КонецДня(КонПериода)));
   НастройкаПериода.РедактироватьКакИнтервал = Истина;
   НастройкаПериода.РедактироватьКакПериод = Истина;
   НастройкаПериода.ВариантНастройки = ВариантНастройкиПериода.Период;
   Если НастройкаПериода.Редактировать() Тогда
      НачПериода = НастройкаПериода.ПолучитьДатуНачала();
      КонПериода = НастройкаПериода.ПолучитьДатуОкончания();
   КонецЕсли;
   
   УстановитьПараметрыПериода();
КонецПроцедуры

Процедура ПередЗакрытием(Отказ, СтандартнаяОбработка)
   СохранитьЗначение("КадровыеОтчеты_НачПериода", НачПериода);
   СохранитьЗначение("КадровыеОтчеты_Конпериода", КонПериода);
КонецПроцедуры


Последний раз редактировалось: ksander-fars; 02 Июн 2016, 05:49. Причина: Объединение сообщений

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
у формы есть флаг "СохранятьЗначения" и список реквизитов, которые надо сохранять.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Группа "СписокКомпоновщикНастроекПользовательскиеНастройки" в форме "Перечисления"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1764
Последний ответ 12 Ноя 2016, 18:08
от Азамат Хубиев
Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 271
Последний ответ 12 Окт 2017, 14:02
от wise
Как настроить отображение на форме "группа плательщика единого налога" при выборе системы налогообложения "Единый налог"?

Автор Nicolayci91Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2281
Последний ответ 17 Авг 2015, 07:48
от cska-fanat-kz
Из запроса не выводятся значения полей - выводятся пустые значения

Автор Alex1111Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 24
Просмотров: 12245
Последний ответ 14 Июн 2012, 17:44
от Alex1111
Добавление строки и заполнение строки в ТЗ на форме

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 304
Последний ответ 25 Сен 2017, 09:00
от Св Ч

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
51 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 243
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal