Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Июл 2017, 11:43
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как привязать введённую Дату на форме к параметру запроса этого модуля ?  (Прочитано 669 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ksander-fars

  • **
  • Сообщений: 69
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-05-04
  • Сайт: 
  • Профессия: Программист 1С
ДД!

Создал внешнюю обработку, в модуле создал запрос. на форму добавил поле ввода для начала периода.

Подскажите как мне привязать поле ввода периода к параметру в запросе?

Вопрос конечно несерьёзный, но я только недавно работаю с 1С....



Оффлайн ksander-fars

  • **
  • Сообщений: 69
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-05-04
  • Сайт: 
  • Профессия: Программист 1С
Решено

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)

 
Процедура ОсновныеДействияФормыОсновныеДействияФормыВыполнить(Кнопка)
   
   ТекстЗапрос = Новый Запрос;
   ТекстЗапрос.УстановитьПараметр("ДатаНачала",ДатаНачала);
   ТекстЗапрос.Текст="ВЫБРАТЬ
                     |   НачислениеПоБольничномуЛисту.Сотрудник,
                     |   НачислениеПоБольничномуЛисту.ПричинаНетрудоспособности,
                     |   НачислениеПоБольничномуЛисту.ДатаНачала,
                     |   НачислениеПоБольничномуЛисту.ДатаОкончания
                     |ИЗ
                     |   Документ.НачислениеПоБольничномуЛисту КАК         НачислениеПоБольничномуЛисту
                     |ГДЕ
                     |   НачислениеПоБольничномуЛисту.ДатаНачала >= &ДатаНачала";
                ТЗ = ТекстЗапрос.Выполнить().Выгрузить();
                ВыбранныйЭлемент = ТЗ.ВыбратьСтроку();
                Сообщить(ВыбранныйЭлемент.Зарплата);
                                  
КонецПроцедуры
         

Добавлено: 02 Июн 2016, 05:28

Следующий вопрос.

Как при закрытии формы сохранить значения введёные в поля НачалоПериода и КонецПериода, а при открытии автоматически восстанавливались например в таком коде?


Процедура НачПериодаПриИзменении(Элемент)
   УстановитьПараметрыПериода();
КонецПроцедуры

Процедура КонПериодаПриИзменении();
   УстановитьПараметрыПериода();
КонецПроцедуры

Процедура УстановитьПараметрыПериода()
   
   Параметр=КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра
(Новый ПараметрКомпоновкиДанных("КонецПериода"));
   Параметр.Значение = КонецДня(КонПериода);
   Параметр.Использование = Истина;
   
   Параметр = КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра
(Новый ПараметрКомпоновкиДанных("НачалоПериода"));
   Параметр.Значение = НачПериода;
   Параметр.Использование = Истина;

КонецПроцедуры

Процедура ВыбПериодНажатие(Элемент);
   
   НастройкаПериода = Новый НастройкаПериода;
   НастройкаПериода.УстановитьПериод(НачПериода, ?(КонПериода='0001-01-01', КонПериода,
КонецДня(КонПериода)));
   НастройкаПериода.РедактироватьКакИнтервал = Истина;
   НастройкаПериода.РедактироватьКакПериод = Истина;
   НастройкаПериода.ВариантНастройки = ВариантНастройкиПериода.Период;
   Если НастройкаПериода.Редактировать() Тогда
      НачПериода = НастройкаПериода.ПолучитьДатуНачала();
      КонПериода = НастройкаПериода.ПолучитьДатуОкончания();
   КонецЕсли;
   
   УстановитьПараметрыПериода();
КонецПроцедуры

Добавлено: 02 Июн 2016, 05:49

Решено

Процедура ПриОткрытии()
   НачПериода = ВосстановитьЗначение("КадровыеОтчеты_НачПериода");
   КонПериода = ВосстановитьЗначение("КадровыеОтчеты_Конпериода");
КонецПроцедуры

Процедура НачПериодаПриИзменении(Элемент)
   УстановитьПараметрыПериода();
КонецПроцедуры

Процедура КонПериодаПриИзменении();
   УстановитьПараметрыПериода();
КонецПроцедуры

Процедура УстановитьПараметрыПериода()
   
   Параметр=КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра
(Новый ПараметрКомпоновкиДанных("КонецПериода"));
   Параметр.Значение = КонецДня(КонПериода);
   Параметр.Использование = Истина;
   
   Параметр = КомпоновщикНастроек.Настройки.ПараметрыДанных.НайтиЗначениеПараметра
(Новый ПараметрКомпоновкиДанных("НачалоПериода"));
   Параметр.Значение = НачПериода;
   Параметр.Использование = Истина;

КонецПроцедуры

Процедура ВыбПериодНажатие(Элемент);
   
   НастройкаПериода = Новый НастройкаПериода;
   НастройкаПериода.УстановитьПериод(НачПериода, ?(КонПериода='0001-01-01', КонПериода,
КонецДня(КонПериода)));
   НастройкаПериода.РедактироватьКакИнтервал = Истина;
   НастройкаПериода.РедактироватьКакПериод = Истина;
   НастройкаПериода.ВариантНастройки = ВариантНастройкиПериода.Период;
   Если НастройкаПериода.Редактировать() Тогда
      НачПериода = НастройкаПериода.ПолучитьДатуНачала();
      КонПериода = НастройкаПериода.ПолучитьДатуОкончания();
   КонецЕсли;
   
   УстановитьПараметрыПериода();
КонецПроцедуры

Процедура ПередЗакрытием(Отказ, СтандартнаяОбработка)
   СохранитьЗначение("КадровыеОтчеты_НачПериода", НачПериода);
   СохранитьЗначение("КадровыеОтчеты_Конпериода", КонПериода);
КонецПроцедуры


Последний раз редактировалось: ksander-fars; 02 Июн 2016, 05:49. Причина: Объединение сообщений

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
у формы есть флаг "СохранятьЗначения" и список реквизитов, которые надо сохранять.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Группа "СписокКомпоновщикНастроекПользовательскиеНастройки" в форме "Перечисления"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1431
Последний ответ 12 Ноя 2016, 18:08
от Азамат Хубиев
Как настроить отображение на форме "группа плательщика единого налога" при выборе системы налогообложения "Единый налог"?

Автор Nicolayci91Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2079
Последний ответ 17 Авг 2015, 07:48
от cska-fanat-kz
Из запроса не выводятся значения полей - выводятся пустые значения

Автор Alex1111Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 24
Просмотров: 10651
Последний ответ 14 Июн 2012, 17:44
от Alex1111
Ребята, срочно нужна помощь. Какую процедуру нужно написать в форме справочника, чтобы таблица заполнялась данными из другого справочника?

Автор Олька БякинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2364
Последний ответ 27 Май 2016, 15:19
от Олька Бякина
Модуль к форме "Настройка заполнения"

Автор oyufedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4207
Последний ответ 17 Янв 2014, 16:35
от oyufed

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
105 Сообщений
alex0402
93 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
65 Сообщений
Golickoff Golickoff
49 Сообщений
ilyay ilyay
49 Сообщений
AIFrame
47 Сообщений
ab30ru
38 Сообщений
wise wise
34 Сообщений
Амал
30 Сообщений
LexaK
22 Сообщений

* Кто онлайн

  • Точка Гостей: 255
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal