Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Май 2017, 02:13
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: И снова здравствуйте! Нужна помощь умненьких людей по 1С v8.1  (Прочитано 397 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Олька Бякина

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-03-16
  • Сайт: 
Тема такая: есть такая процедура (1С v8.1)
_____________________________________________
Процедура ПолучитьДанныеИзШтрафа (Элемент)
   перем код1;
   перем дата1;
   перем наруш1;
   перем штраф1;
   СтрокаТЧ=ЭлементыФормы.Штрафы.ТекущиеДанные;
   код1=Строка(СтрокаТЧ.КодНарушения);
   Выборка=Справочники.Нарушения.Выбрать();
   пока Выборка.Следующий()Цикл
      Если Выборка.Код=код1 Тогда
         дата1=Выборка.ДатаНарушения;
         Наруш1=Выборка.ФИОНарушителя;
         штраф1=Выборка.ИтоговаяСумма;
      КонецЕсли;
   КонецЦикла;
           СтрокаТЧ.ДатаНарушения=дата1;
         СтрокаТЧ.ФИО_нарушителя=наруш1;
         СтрокаТЧ.Штраф=штраф1;
            ИтоговаяСумма=Штрафы.Итог("Штраф");
КонецПроцедуры

______________________________
Суть такова, пытаюсь достать данные из справочника "нарушения" и добавить в документ "оплата"
Ошибок в процедуре нет, но таблицу не заполняет. Поле наименование в справочнике "Нарушения" я не использовала. По этому ориентируюсь по коду.

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
96 Сообщений
Dethmontt Dethmontt
69 Сообщений
alex0402
58 Сообщений
MuI_I_Ika MuI_I_Ika
55 Сообщений
wise wise
47 Сообщений
Сергей Федоров Сергей Федоров
41 Сообщений
ilyay ilyay
39 Сообщений
BuhRust
22 Сообщений
videomause
20 Сообщений
ilnur75
20 Сообщений

* Кто онлайн

  • Точка Гостей: 228
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal