Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Янв 2017, 23:16
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: И снова здравствуйте! Нужна помощь умненьких людей по 1С v8.1  (Прочитано 333 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Олька Бякина

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-03-16
  • Сайт: 
Тема такая: есть такая процедура (1С v8.1)
_____________________________________________
Процедура ПолучитьДанныеИзШтрафа (Элемент)
   перем код1;
   перем дата1;
   перем наруш1;
   перем штраф1;
   СтрокаТЧ=ЭлементыФормы.Штрафы.ТекущиеДанные;
   код1=Строка(СтрокаТЧ.КодНарушения);
   Выборка=Справочники.Нарушения.Выбрать();
   пока Выборка.Следующий()Цикл
      Если Выборка.Код=код1 Тогда
         дата1=Выборка.ДатаНарушения;
         Наруш1=Выборка.ФИОНарушителя;
         штраф1=Выборка.ИтоговаяСумма;
      КонецЕсли;
   КонецЦикла;
           СтрокаТЧ.ДатаНарушения=дата1;
         СтрокаТЧ.ФИО_нарушителя=наруш1;
         СтрокаТЧ.Штраф=штраф1;
            ИтоговаяСумма=Штрафы.Итог("Штраф");
КонецПроцедуры

______________________________
Суть такова, пытаюсь достать данные из справочника "нарушения" и добавить в документ "оплата"
Ошибок в процедуре нет, но таблицу не заполняет. Поле наименование в справочнике "Нарушения" я не использовала. По этому ориентируюсь по коду.

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
alex0402
65 Сообщений
MuI_I_Ika MuI_I_Ika
47 Сообщений
crow1983
35 Сообщений
alexandr_ll
33 Сообщений
LexaK
32 Сообщений
sertak sertak
25 Сообщений
Vzonder
22 Сообщений
BuhRust
17 Сообщений
дфтын дфтын
17 Сообщений

* Кто онлайн

  • Точка Гостей: 273
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal