Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 сен 2021, 23:50

Ребята, срочно нужна помощь. Какую процедуру нужно написать в форме справочника, чтобы таблица заполнялась данными из другого справочника?

Автор Олька Бякина, 26 мая 2016, 19:31

0 Пользователей и 1 гость просматривают эту тему.

Олька Бякина

Есть вот такая процедура, которая не работает, может я не так написала ее<_<
Процедура ПриВводеИИзмененииТаблицы(Элемент)
   СтрокаТЧ=ЭлементыФормы.Автомобиль.ТекущиеДанные;
   СтрокаТЧ.Марка_автомобиля=СтрокаТЧ.Марка;
   СтрокаТЧ.Модель_автомобиля=СтрокаТЧ.Модель;
   СтрокаТЧ.Номер_автомобиля=СтрокаТЧ.НомерЗнака;
КонецПроцедуры



Олька Бякина

Цитата: metiloff от 27 мая 2016, 09:16
Поделитесь с нами? :dfbsdfbsdf:
Процедура ПолучитьДанныеИзПравил (Элемент)
   перем наим1;
   перем штраф1;
   СтрокаТЧ=ЭлементыФормы.Нарушение.ТекущиеДанные;
   наим1=Строка(СтрокаТЧ.Нарушение);
   Выборка=Справочники.Правила.Выбрать();
   пока Выборка.Следующий()Цикл
      Если Выборка.Наименование=наим1 Тогда
         штраф1=Выборка.Наказание;
      КонецЕсли;
   КонецЦикла;
         СтрокаТЧ.Штраф=штраф1;
        КонецПроцедуры


Rasty

Цитата: Олька Бякина от 27 мая 2016, 14:28пока Выборка.Следующий()Цикл
      Если Выборка.Наименование=наим1 Тогда
         штраф1=Выборка.Наказание;
      КонецЕсли;
Можно сократить до Справочники.Правила.НайтиПоНаименованию(наим1);

Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Олька Бякина

Цитата: Rasty от 27 мая 2016, 14:31
Цитата: Олька Бякина от 27 мая 2016, 14:28пока Выборка.Следующий()Цикл
      Если Выборка.Наименование=наим1 Тогда
         штраф1=Выборка.Наказание;
      КонецЕсли;
Можно сократить до Справочники.Правила.НайтиПоНаименованию(наим1);


прикольно, а можешь помочь с подобной ситуацией, только данные из справочника в документ?
ссылка на тему: http://forum-1c.ru/index.php?topic=62200.msg167161#msg167161

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск