Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Ноя 2017, 23:26
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ребята, срочно нужна помощь. Какую процедуру нужно написать в форме справочника, чтобы таблица заполнялась данными из другого справочника?  (Прочитано 2712 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Олька Бякина

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-03-16
  • Сайт: 
Есть вот такая процедура, которая не работает, может я не так написала ее<_<
Процедура ПриВводеИИзмененииТаблицы(Элемент)
   СтрокаТЧ=ЭлементыФормы.Автомобиль.ТекущиеДанные;
   СтрокаТЧ.Марка_автомобиля=СтрокаТЧ.Марка;
   СтрокаТЧ.Модель_автомобиля=СтрокаТЧ.Модель;
   СтрокаТЧ.Номер_автомобиля=СтрокаТЧ.НомерЗнака;
КонецПроцедуры



Оффлайн metiloff

  • **
  • Сообщений: 54
  • РЕПУТАЦИЯ: 3
  • КПД: 6%
  • Регистрация: 2015-06-25
  • Сайт: 
  • Профессия: Ученик 1С

Оффлайн Олька Бякина

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-03-16
  • Сайт: 
Поделитесь с нами? :dfbsdfbsdf:
Процедура ПолучитьДанныеИзПравил (Элемент)
   перем наим1;
   перем штраф1;
   СтрокаТЧ=ЭлементыФормы.Нарушение.ТекущиеДанные;
   наим1=Строка(СтрокаТЧ.Нарушение);
   Выборка=Справочники.Правила.Выбрать();
   пока Выборка.Следующий()Цикл
      Если Выборка.Наименование=наим1 Тогда
         штраф1=Выборка.Наказание;
      КонецЕсли;
   КонецЦикла;
         СтрокаТЧ.Штраф=штраф1;
        КонецПроцедуры


Оффлайн Rasty

  • *****
  • Сообщений: 988
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
 пока Выборка.Следующий()Цикл
      Если Выборка.Наименование=наим1 Тогда
         штраф1=Выборка.Наказание;
      КонецЕсли;
Можно сократить до Справочники.Правила.НайтиПоНаименованию(наим1);

Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн Олька Бякина

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-03-16
  • Сайт: 
пока Выборка.Следующий()Цикл
      Если Выборка.Наименование=наим1 Тогда
         штраф1=Выборка.Наказание;
      КонецЕсли;
Можно сократить до Справочники.Правила.НайтиПоНаименованию(наим1);


прикольно, а можешь помочь с подобной ситуацией, только данные из справочника в документ?
ссылка на тему: http://forum-1c.ru/index.php?topic=62200.msg167161#msg167161


Теги:
 

Группа "СписокКомпоновщикНастроекПользовательскиеНастройки" в форме "Перечисления"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1705
Последний ответ 12 Ноя 2016, 18:08
от Азамат Хубиев
Как настроить отображение на форме "группа плательщика единого налога" при выборе системы налогообложения "Единый налог"?

Автор Nicolayci91Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2251
Последний ответ 17 Авг 2015, 07:48
от cska-fanat-kz
Добавление строки и заполнение строки в ТЗ на форме

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 246
Последний ответ 25 Сен 2017, 09:00
от Св Ч
Модуль к форме "Настройка заполнения"

Автор oyufedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4436
Последний ответ 17 Янв 2014, 16:35
от oyufed
Отображение HTML-макета в форме с HTML-полем.

Автор spikee666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3561
Последний ответ 21 Авг 2014, 17:51
от spikee666

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
169 Сообщений
MuI_I_Ika MuI_I_Ika
87 Сообщений
oleg-x
71 Сообщений
ilyay ilyay
68 Сообщений
alex0402
62 Сообщений
Dmitry Qwe Dmitry Qwe
32 Сообщений
Golickoff Golickoff
24 Сообщений
Sy4a
24 Сообщений
Dima Dddd Dima Dddd
20 Сообщений
andron81_81
17 Сообщений

* Кто онлайн

  • Точка Гостей: 211
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal