Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Авг 2017, 08:33
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выборка по табличным частям документа  (Прочитано 917 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dima karpsov

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-05-25
  • Сайт: 
Здравствуйте нужна ваша помощь, вопрос такой нужно чтобы когда в Документа Таблица Результатов выбиралась Фамилия определенного человека, из Табличной части документа Сводная Оценочная Ведомость автоматически в Документ Таблица Результатов подставлялись баллы за определенный критерий, который был выставлен в Документе Сводная Оценочная Ведомость.


Оффлайн Rasty

  • *****
  • Сообщений: 976
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
есть событие такое обработкавыбора, пишите туда код
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн dima karpsov

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-05-25
  • Сайт: 
Я как раз и хотел попросить помощи с кодом так как я профан в 1С.

Оффлайн Rasty

  • *****
  • Сообщений: 976
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
&НаКлиенте
Процедура ОбработкаВыбора(ВыбранноеЗначение)
 ОбработатьВыбранноеЗначение(ВыбранноеЗначение)
КонецПроцедуры

&НаСервере
Процедура ОбработатьВыбранноеЗначение(ВыбранноеЗначение)

    Для Каждого Строка Из ВыбранноеЗначение.ПК21 Цикл
        Элементы.ВашаТаблица.ТекущиеДанные["Критерий"+СтрЗаменить(Строка.Номер,".","")] = Строка.Баллы/Строка.Оценка/Строка.Балы //нужное подставит если не сработает тогда придется обращаться по нормальному через точку и сравнивать номер с именем колонки
    КонецЦикла;
КонецПроцедуры
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн dima karpsov

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-05-25
  • Сайт: 
&НаКлиенте
Процедура ОбработкаВыбора(ВыбранноеЗначение)
 ОбработатьВыбранноеЗначение(ВыбранноеЗначение)
КонецПроцедуры

&НаСервере
Процедура ОбработатьВыбранноеЗначение(ВыбранноеЗначение)

    Для Каждого Строка Из ВыбранноеЗначение.ПК21 Цикл
        Элементы.ВашаТаблица.ТекущиеДанные["Критерий"+СтрЗаменить(Строка.Номер,".","")] = Строка.Баллы/Строка.Оценка/Строка.Балы //нужное подставит если не сработает тогда придется обращаться по нормальному через точку и сравнивать номер с именем колонки
    КонецЦикла;
КонецПроцедуры
Прощу прощенья, в Выбранном значении мне нужна указать ссылку на документ откуда будут браться значения?

Оффлайн Rasty

  • *****
  • Сообщений: 976
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
Нет ОбработкаВыбора это стандартное событие которое указывается в свойствах колонки таблицы в конифгураторе
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн dima karpsov

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-05-25
  • Сайт: 
Тогда к сожалению, придётся обращаться через точку, не поможете с этим? Просто я вообще не понимаю как это реализуется, только учусь ещё)

Оффлайн Rasty

  • *****
  • Сообщений: 976
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
если Строка.Номер = Какой - то там номер тогда
    Элементы.ТекущиеДанные.КолонкаКоторойСоответствуетЭтотНомер = Строка.Какое-тоЗначение;
ИначеЕсли Строка.Номер = ......
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)


 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4251
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 14898
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3863
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 365
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7350
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
132 Сообщений
alex0402
59 Сообщений
AIFrame
52 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
27 Сообщений
pavl_vs
25 Сообщений
Kironten
24 Сообщений
Александр Лахтин Александр Лахтин
18 Сообщений
Golickoff Golickoff
18 Сообщений
xproh
16 Сообщений

* Кто онлайн

  • Точка Гостей: 186
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal