Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
28 Июл 2017, 21:51
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Допечатать что-либо в табличный документ, передаваемый как параметр процедуры  (Прочитано 626 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Vdeg

Хочу объединить бухгалтерскую и налоговую справку в один табличный документ, для этого хочу передать табличный документ с бухгалтерской справкой в процедуру печати налоговой справки. Но программа ругается (

Цитировать
{Документ.ОперацияБух.МодульОбъекта(225)}: Значение не является значением объектного типа (Вывести)
   ТабДокумент.Вывести(ШапкаДокумента);

при первой же попытке вывести новую секцию в передаваемый (в параметре) табличный документ.

Что тут не так? Как можно решить этот вопрос?

Функция ПечатьНалоговойСправки(ТабличныйДокумент = Неопределено)

Запрос = Новый Запрос();
Запрос.УстановитьПараметр("Ссылка", Ссылка);
Запрос.Текст =
"ВЫБРАТЬ
| ОперацияБух.Организация,
| ОперацияБух.Номер,
| ОперацияБух.Дата,
| ОперацияБух.Содержание
|ИЗ
| Документ.ОперацияБух КАК ОперацияБух
|ГДЕ
| ОперацияБух.Ссылка = &Ссылка";

Док = Запрос.Выполнить().Выбрать();
Док.Следующий();

Запрос = Новый Запрос();
Запрос.УстановитьПараметр("Регистратор", Ссылка);
Запрос.Текст =
"ВЫБРАТЬ
| НалоговыйДвиженияССубконто.НомерСтроки КАК НомерСтроки,
| НалоговыйДвиженияССубконто.СчетДт,
| НалоговыйДвиженияССубконто.СубконтоДт1,
| НалоговыйДвиженияССубконто.СубконтоДт2,
| НалоговыйДвиженияССубконто.СубконтоДт3,
| НалоговыйДвиженияССубконто.СчетКт,
| НалоговыйДвиженияССубконто.СубконтоКт1,
| НалоговыйДвиженияССубконто.СубконтоКт2,
| НалоговыйДвиженияССубконто.СубконтоКт3,
| НалоговыйДвиженияССубконто.Организация,
| НалоговыйДвиженияССубконто.Сумма,
| НалоговыйДвиженияССубконто.КоличествоДт,
| НалоговыйДвиженияССубконто.КоличествоКт,
| НалоговыйДвиженияССубконто.Содержание,
| НалоговыйДвиженияССубконто.ВидУчетаДт,
| НалоговыйДвиженияССубконто.ВидУчетаКт
|ИЗ
| РегистрБухгалтерии.Налоговый.ДвиженияССубконто(, , Регистратор = &Регистратор, , ) КАК НалоговыйДвиженияССубконто
|
|УПОРЯДОЧИТЬ ПО
| НомерСтроки";

ВыборкаДвижений = Запрос.Выполнить().Выбрать();

Макет = ПолучитьМакет("НалоговаяСправка");

// Получаем области макета для вывода в табличный документ.
ШапкаДокумента   = Макет.ПолучитьОбласть("Шапка");
ЗаголовокТаблицы = Макет.ПолучитьОбласть("ЗаголовокТаблицы");
СтрокаТаблицы    = Макет.ПолучитьОбласть("СтрокаТаблицы");
ПодвалТаблицы    = Макет.ПолучитьОбласть("ПодвалТаблицы");
ПодвалДокумента  = Макет.ПолучитьОбласть("Подвал");

Если ТабличныйДокумент = Неопределено Тогда
ТабДокумент = Новый ТабличныйДокумент;

// Зададим параметры макета по умолчанию.
ТабДокумент.ПолеСверху              = 10;
ТабДокумент.ПолеСлева               = 0;
ТабДокумент.ПолеСнизу               = 0;
ТабДокумент.ПолеСправа              = 0;
ТабДокумент.РазмерКолонтитулаСверху = 10;
ТабДокумент.ОриентацияСтраницы      = ОриентацияСтраницы.Ландшафт;

// Загрузим настройки пользователя.
ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ОперацияБух_НалоговаяСправка";
КонецЕсли;

// Выведем шапку документа.
СведенияОбОрганизации = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Док.Организация, Док.Дата);

ШапкаДокумента.Параметры.Организация    = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОбОрганизации);
ШапкаДокумента.Параметры.НомерДокумента = ОбщегоНазначения.ПолучитьНомерНаПечать(Док);
ШапкаДокумента.Параметры.ДатаДокумента  = Формат(Док.Дата, "ДЛФ=D");
ШапкаДокумента.Параметры.Содержание     = Док.Содержание;

ТабДокумент.Вывести(ШапкаДокумента);

// Выведем заголовок таблицы.
ТабДокумент.Вывести(ЗаголовокТаблицы);

// Выведем строки документа.
Пока ВыборкаДвижений.Следующий() Цикл

СтрокаТаблицы.Параметры.Заполнить(ВыборкаДвижений);

АналитикаДт = Строка(ВыборкаДвижений.СубконтоДт1) + Символы.ПС
            + Строка(ВыборкаДвижений.СубконтоДт2) + Символы.ПС
                    + Строка(ВыборкаДвижений.СубконтоДт3);

АналитикаКт = Строка(ВыборкаДвижений.СубконтоКт1) + Символы.ПС
            + Строка(ВыборкаДвижений.СубконтоКт2) + Символы.ПС
                    + Строка(ВыборкаДвижений.СубконтоКт3);

СтрокаТаблицы.Параметры.АналитикаДт = АналитикаДт;
СтрокаТаблицы.Параметры.АналитикаКт = АналитикаКт;

// Проверим, помещается ли строка с подвалом.
СтрокаСПодвалом = Новый Массив;
СтрокаСПодвалом.Добавить(СтрокаТаблицы);
СтрокаСПодвалом.Добавить(ПодвалТаблицы);
СтрокаСПодвалом.Добавить(ПодвалДокумента);

Если НЕ ФормированиеПечатныхФорм.ПроверитьВыводТабличногоДокумента(ТабДокумент, СтрокаСПодвалом) Тогда

// Выведем подвал таблицы.
ТабДокумент.Вывести(ПодвалТаблицы);

// Выведем разрыв страницы.
ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();

// Выведем заголовок таблицы.
ТабДокумент.Вывести(ЗаголовокТаблицы);

КонецЕсли;

ТабДокумент.Вывести(СтрокаТаблицы);

КонецЦикла;

// Выведем подвал таблицы.
ТабДокумент.Вывести(ПодвалТаблицы);

// Выведем подвал документа.
ПодвалДокумента.Параметры.РасшифровкаПодписиИсполнителя = ?(НЕ ЗначениеЗаполнено(Ответственный), "", ОбщегоНазначения.ФамилияИнициалыФизЛица(Ответственный.ФизЛицо));
ТабДокумент.Вывести(ПодвалДокумента);

Возврат ТабДокумент;

КонецФункции // ПечатьНалоговойСправки()
Житель района Восточное Дегунино (Москва, Россия)
Мой блог программиста


Оффлайн Rasty

  • *****
  • Сообщений: 976
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С

    Если ТабличныйДокумент = Неопределено Тогда
        ТабДокумент = Новый ТабличныйДокумент;
       
        // Зададим параметры макета по умолчанию.
        ТабДокумент.ПолеСверху              = 10;
        ТабДокумент.ПолеСлева               = 0;
        ТабДокумент.ПолеСнизу               = 0;
        ТабДокумент.ПолеСправа              = 0;
        ТабДокумент.РазмерКолонтитулаСверху = 10;
        ТабДокумент.ОриентацияСтраницы      = ОриентацияСтраницы.Ландшафт;
       
        // Загрузим настройки пользователя.
        ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ОперацияБух_НалоговаяСправка";

    КонецЕсли;
а должно быть
    Если ТабличныйДокумент = Неопределено Тогда
        ТабличныйДокумент = Новый ТабличныйДокумент;
       
        // Зададим параметры макета по умолчанию.
        ТабличныйДокумент .ПолеСверху              = 10;
        ТабличныйДокумент .ПолеСлева               = 0;
        ТабличныйДокумент .ПолеСнизу               = 0;
        ТабличныйДокумент .ПолеСправа              = 0;
        ТабличныйДокумент .РазмерКолонтитулаСверху = 10;
        ТабличныйДокумент .ОриентацияСтраницы      = ОриентацияСтраницы.Ландшафт;
       
        // Загрузим настройки пользователя.
        ТабличныйДокумент .ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ОперацияБух_НалоговаяСправка";

 и т.д.
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Оффлайн Vdeg

Rasty, не совсем понял, что именно изменено в Вашем варианте кода.
Добавлено: 24 Май 2016, 12:50

Всё, я сам понял, спасибо! :zebzdr:

Я перепутал имя переменной, глупейшая ошибка.
Житель района Восточное Дегунино (Москва, Россия)
Мой блог программиста


Теги:
 

Какова взаимосвязь объектов конфигурации "Договоры" и "Документ"?

Автор DDDРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 4227
Последний ответ 25 Ноя 2008, 10:43
от DDD
Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8288
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
не могу вывести отображение цен в "подборе" документ "Заявка покупателя" УТ 10.3

Автор Виталий ЕмельяновРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 3063
Последний ответ 05 Окт 2015, 19:22
от Виталий Емельянов
Как программно открыть документ программно

Автор СерьезныйЧеловекРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 17408
Последний ответ 10 Ноя 2010, 14:08
от Lexius
Документ "Сторно" в 1с 8.2 бух 2.0

Автор cannabis_86Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 11958
Последний ответ 09 Июн 2011, 12:57
от defers

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alex0402
96 Сообщений
oleg-x
76 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
66 Сообщений
Golickoff Golickoff
53 Сообщений
AIFrame
46 Сообщений
ilyay ilyay
40 Сообщений
Амал
30 Сообщений
MuI_I_Ika MuI_I_Ika
27 Сообщений
Dethmontt Dethmontt
22 Сообщений
lansy
22 Сообщений

* Кто онлайн

  • Точка Гостей: 289
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal