Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
28 Май 2017, 13:22
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Изменение вида "выпадающего списка"  (Прочитано 828 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн JohnDoe144

  • *
  • Сообщений: 29
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-02-26
  • Сайт: 
Добрый день,

Имеется:
1. Самостоятельная конфигурация
2. Поле ввода на форме документа с реквизитом СсылкаСправочникКонтрагенты
3. При вводе первых букв в поле 1С начинает предлагать варианты из соответствующего справочника в виде "Наименование (Код)"

Вопрос: можно каким-либо образом изменить вид предлагаемых вариантов на "Наименование (другое поле)", в идеале "Наименование (ИНН)"?

Заранее благодарю.

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Оффлайн LexaK

  • *****
  • Сообщений: 1214
  • РЕПУТАЦИЯ: 333
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
да можно сделать, посмотрите в конфигурации БП 3.0 (у меня корп) документ РеализацияТоваровУслуг
там автовыбор по Код, наименование, ИНН - то что проверил - есть, может и еще по чем, дальше не проверил
вот вызов автоподбора контрагента
&НаКлиенте
Процедура КонтрагентАвтоПодбор(Элемент, Текст, ДанныеВыбора, ПараметрыПолученияДанных, Ожидание, СтандартнаяОбработка)

РаботаСКонтрагентамиБПКлиент.КонтрагентАвтоПодбор(
Элемент, Текст, ДанныеВыбора, ПараметрыПолученияДанных, Ожидание, СтандартнаяОбработка);

КонецПроцедуры

модуль
Процедура КонтрагентАвтоПодбор(Элемент, Текст, ДанныеВыбора, ПараметрыПолученияДанных, Ожидание, СтандартнаяОбработка) Экспорт

Если НЕ ПустаяСтрока(Текст)
И (НЕ ЗначениеЗаполнено(Элемент.ОграничениеТипа)
ИЛИ Элемент.ОграничениеТипа.СодержитТип(Тип("СправочникСсылка.Контрагенты"))) Тогда
СтандартнаяОбработка = Ложь;
ДанныеВыбора = РаботаСКонтрагентамиБПВызовСервера.ДанныеВыбораКонтрагента(ПараметрыПолученияДанных, Ложь);
КонецЕсли;

КонецПроцедуры


ну там приличная вложенность. блин вся конфигурация в окно не влезет.
 
Помогло? - Нажми СПАСИБО!!!
                       :)


Теги:
 

Как из справочника вытащить список одной группы справочника и вставить его в поле документа для выбора одного элемента из полученного списка?

Автор ilnur75Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 1145
Последний ответ 21 Сен 2016, 08:16
от GadLex
Передача значений из Формы Списка одного документа в Таблицу другого документа

Автор MoZzArTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 764
Последний ответ 21 Сен 2015, 13:07
от MoZzArT
Если декларант не может предоставить дополнительные документы, это не влечет изменение таможенной стоимости

Автор newsРаздел Новости

Ответов: 0
Просмотров: 702
Последний ответ 05 Ноя 2014, 12:06
от news
Из списка субъектов, которые занимаются отсрочками по федеральным налогам, исключены Правительство РФ и Минфин

Автор newsРаздел Новости

Ответов: 0
Просмотров: 633
Последний ответ 12 Май 2014, 11:34
от news
Нужно на форму добавить объект, чтобы можно было выбрать из списка документ

Автор RoDiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 10
Просмотров: 1124
Последний ответ 05 Июл 2016, 14:04
от RoDi

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
83 Сообщений
wise wise
63 Сообщений
Dethmontt Dethmontt
60 Сообщений
MuI_I_Ika MuI_I_Ika
51 Сообщений
alex0402
49 Сообщений
Сергей Федоров Сергей Федоров
32 Сообщений
ilyay ilyay
32 Сообщений
ilnur75
23 Сообщений
Дмитрий Медведков
19 Сообщений
magnifico61
18 Сообщений

* Кто онлайн

  • Точка Гостей: 321
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal